ST hub will not register, blocked? (used to work fine)


I have a Smartthings Hub Gen 3 that was working fine until yesterday. It suddenly started showing blue blinking led then solid and back to normal green. I decided to reset wifi (15 sec push pin), then started "re-"adding the hub but since then it would not register (it fails at the hub registration step). Tried multiple times with Android and iOS clients with same error.

Tried wifi and ethernet and forwarding ports such as 11111 but it did not help. I’m sure the hub can connect to my router and access internet but it as if Samsung is blocking it!

The strange thing is the first time I tried to register it was successful but then returned back to blue led a few minutes later.

The hub events log shows a couple registration entries then disconnect and inactive. No other entries since then. That’s why I suspect Samsung has blocked the hub maybe due to too many registration attempts?

Did any experience such behavior?

Would doing a full reset and deleting the hub help? I really don’t want to do that unless I have to.

I also contacted Samsung through email and from within the ST app but have not received any replay yet.

Tagging @SamsungZell

Hey there!

Thank you for reaching out for assistance with getting your hub registered, I’m sorry to hear your having issues.

What is the current color status of your LED indicator showing on the Smartthings Hub, this will help us determine where to start troubleshooting?

Here is an article that can help differentiate between the LED colors:

If you need immediate support, I wanted to also provide you directly with support number. They can be reached at 1-866-813-2404. They will be able to remotely monitor the setup of the Hub to help determine what the symptom could be.

I hope this message finds you well!



After doing the rest (pushing the pin until yellow become solid). It cycles quickly through magenta and blue until it blinks green red.

Then I start adding the hub. Keep in mind that the hub used to work so I still have it listed in the ST app and did not delete it from there or from ST website. So I go through the steps and selecting the wifi or ethernet and when it starts the hub registration step it fails/times out saying that it could not register with an option to try again. Tried again several times and at different times with same error.

When setting up the hub I know that it can connect to the internet because my phone can ping the servers while it is connected to the temporary st-… wifi.

I’ve attached a screenshot of the hub events.

So after many frustatted attempts to re-register the hub I decided to delete it but then I get this error!
This makes make suspicious that there is something messed up with my account @ smartthings.

Finally was able to delete the hub, tried ST app and classic. Now the hub is registering. I suspect that one of the devices was the cause becuase when I tried to delete it before deleting the hub I could not!
But that’s a shame that the ST is such unstable.