Code already registered. Invitation from owner needed to use this hub

Think am in a pickle entirely of my own making. Was having issues with some of my automations and Alexa and decided to wipe all and go back to the beginning. Anyway, defaulted my st v2 and deleted my locations. Ran into the issue where I didn’t have my welcome code, but after calling the states managed to get my code from them (#1089065). However now when trying to add my hub to my new location I am getting the code already registered error. Tried defaulting the hub a few times and scrapping the location again and even tried different devices and the old classic app to no avail. Am I right in thinking only Samsung can help me at this point?

Thanks all.

Nick

1 Like

One thing that’s not intuitive about the factory reset is that it happens completely offline. That means that until the hub is once again connected to the internet it hasn’t actually told any of the cloud infrastructure that it’s been factory reset.

What you can try is factory resetting again (as described in https://www.samsung.com/us/support/answer/ANS00048958/), and then plug the hub in and make sure it gets a green LED. Then let it sit connected to the internet while you get a cup of coffee/tea/$BEVERAGE (i.e. about 5-10 minutes). Hopefully in that time the reset message will have successfully been processed cloud side and you should be able to claim.

If that doesn’t work please do reach out to support - they have tools to check for any stale info that might be blocking your claim and get you moving.

Thanks Nick, tried another default and still get the same error so I’ve raised a ticket with Smartthings UK to see what they make of it. Thanks for your help.

Tagging @Brad_ST

Can you give it another try? It should work this time.

2 Likes

You star Brad, thanks for your help. Nick

1 Like

@Brad_ST same issue. Support Ticket: 1101910
Have factory reset multiple times. Hub not in Smartthings app or IDE. Continue to get error: Code already registered. Invitation from owner needed to use this hub. Thank you for any assistance.

The hub got stuck while resetting. The welcome code should work now.

Thank you!

1 Like

@Brad_ST
I have the same problem.
Please help
Ticket #1111272

After resetting mine and repairing 100+ devices it has a password that I do not know. should have been the default 1111 but it is not.

@Brad_ST We are experiencing the same code - already registered. Logging into the account on the computer shows that the hub is online. We have not reset the hub because it is still connected, but we can’t add it to the new SmartThings app. Serial # 3000172125.

Account migration was never performed which is causing this confusion. The hub is registered to the legacy SmartThings account. Please sign into the Classic app as an existing user and follow the prompts to complete account migration.

You should be able to activate the hub now.

1 Like

Thank you so much!

1 Like

Mine too. case 1121919. Don’t have access to old classic app (old phone). Hub was off for about a year during my move. I don’t remember if I ever migrated to new app.

@Brad_ST

Hi I am having a similar issue
Support request #1124073

Do you think you’d be able to help?

I cleared out some data and you should be able to claim the hub again now.

1 Like

@Brad_ST

Thank you so much
Is there anyway I can leave positive feedback for your manager
This really is appreciated

1 Like

I am hoping @Brad_ST can help me as well. My support ticket is 1125730.