Adding v2 Hub to account via smartthings cli or smartthings advanced web?

I’m having an issue trying to add a v2 hub to my account via the SmartThings app (STH-ETH-200) where the registration process fails and it is proving impossible to add my hub to my account this way

Is there a way to add my hub to my account via either the smartthings cli, or via the smartthings advanced web portal using it’s serial or MAC as it’s unique ID?

Currently my account shows no hubs, and this is the error from the SmartThings app

You should contact ST support to investigate why you can’t add the hub through the app.

You can’t add Hubs or devices through CLI or the Advanced Web App.


Thanks @jkp - I did so and they told me to contact them via the app support, which I have done twice and still no response

Any better email or submission forms to use to expedite the process?

They have been revamping their contact methods recently and unfortunately the only way I know of is through the app in Menu > Contact us.

just make sure I remember from your earlier post:

  • you purchased a used v2 hub?
  • you mentioned they asked you to contact UK support?
  • what country are you in?
  • you have the Welcome code for the v2 hub?

Yes, used v2 hub, contacted UK support, I’m based in the UK and the Welcome code in the screenshot above is the welcome code on the bottom of the instructions envelope so everything should work

Just the app fails every time it tries to connect to the SmartThings servers with the Welcome Code at that step of the process - almost like they have taken the back-end servers off-line or similar, so there is no way to get past that step of the hub registration and add it to my account

You may want to contact Support and ask for a new code. In the image you posted above, there is a link for doing that. They generally want to see an image of the bottom of the hub that clearly displays the serial number (the image you posted in your other thread). You should also remove that image from the other post as it does display the serial number.

read @JDRoberts post below. if you send support the image, I would assume they can tell you if it is was one of the models used for the vodaphone service.


Just to check since you bought it used in the UK… any chance it was originally sold as part of the VHome service from Vodafone? That was a security package that required a Vodafone subscription, and you couldn’t add hubs with those codes to a regular SmartThings account. But after they shut down the service, you were supposed to be able to, but sometimes you had to ask support to help. I think it would’ve said V home on the box. :thinking:


Thanks guys - this is the images of the box from the eBay advert and I’m pretty sure it’s a standard unit not a Vodafone one as there is no Vodafone branding on the box

BTW if I enter a junky ABC123 value as the Welcome Key it gives exactly the same error message so it feels more like a server error than a code error

BTW just to make you laugh that link in the image above produces this :face_with_head_bandage:

not surprised about the invalid link… they have been revamping their contact over the past couple of months.

as for the error when trying to add the hub… I don’t know :person_shrugging::person_shrugging:

  • could be a cloud issue
  • could be the hub was not removed from previous owner’s account
  • could be an app issue
  • could be the Welcome code

Hopefully Support will reach out to you


one thought: download an older version of the app from an APK site such as APKPURE

OK, probably not from the Vhome service then, so at least we’ve eliminated that.

As @jkp said, Samsung started restructuring their whole support process a few weeks ago and there are a lot of bad links and it’s hard to figure out how to get in touch now. I think for right now you either have to start from within the smartthings app, or get their new “members app“ and use that. :thinking:

1 Like

Yes, I’m going to copy in @SamsungZell to see if that helps and this thread has the UK support phone number so I can try that

That page link was

which I guess is now replaced / superseded by

@samsungzell has not visited this forum for two years, I’m not sure he’s even still with the company.

This forum was set up several years ago so that customers could help other customers with smartthings, it’s not actually an official support channel. Samsung employees do moderate it for spam and harassment, but they don’t officially provide content here, except for a small section for developer partners.

You could try posting a question about how to get in touch with support on either their Facebook or Twitter/x accounts, those are at least monitored by marketing staff and they might know what you’re supposed to do now. :man_shrugging:t2:

1 Like

that staff member is no longer active on the forum


Thanks guys - the £40 option to buy a v3 hub might be an easier path to success…

As far as I am aware there hasn’t been a phone number or a chat line for UK support for a few years now. Not only that but there has not been a viable method of contacting them via the app either as all the options result in messages to Samsung support where they are either abandoned in a mailbox (I used to be able to see them still unread two or three years later) or if you are very unlucky they attempt to answer them. It used to be the case that the support menus in the app were marginally less useless if you avoided installing the Samsung Members app as that overrode the defaults in the app. You couldn’t contact support but you could generate a log, for example.

The current options in the app don’t seem to do anything useful at all. The ‘Contact us’ is particularly pathetic as it just opens an unhelpful web page. The main problem I see is that it is basically a Samsung app.

The only way I have ever successfully contacted UK support in the last few years is by email to and I rather hope that still works.


Thanks Graham

Not looking very hopeful but the final link ends up here - Samsung SmartThings - have submitted a form and will see if I get any response

That’s interesting.

You’d think that they’d have the courtesy to let customers with open support tickets know that they’ve moved the goalposts.


Well I thought I would update that the good news is that somehow my support enquiry managed to get through to Samsung support and the super helpful Fiona (I think the same lady that helped you Graham on this thread) came back and has helped resolve my Hub pairing issue

The problem was as suggested that the Hub was still paired to the old user’s account so I needed to do a full factory reset to get the device to re-register with my account, and even though I had gone through the process with the flashing yellow, and then solid yellow lights - the part I hadn’t got correct was to immediately release the reset switch as soon as the hub light goes to solid yellow

This was the detailed response from Fiona

Thanks for providing the pictures of the Hub serial number. Checking on our end, the Hub is still attached to the previous owner’s account so that is the most likely reason you’re having trouble adding to your account. You’ll need to factory reset the Hub before it can be activated again. Here are the steps:

1. Disconnect the power cable and remove the batteries from the Hub
2. Using a pin or a small tool, hold down the reset button on the back of the Hub
3. While continuing to hold down the reset button, replace the power cable
4. Continue holding the button for more than 30 seconds
5. When the LED on the front switches from flashing yellow to solid yellow, release the button
6. Reinstall the batteries into the Hub

If you do not release the button within a few seconds after the LED switches to solid yellow, the Hub may not begin the reset. The Hub will take 5-10 minutes to fully factory reset. Once the LEDs on the front of the Hub turn solid green, you should then be able to add the Hub in the app using the Welcome Code you have

And then the even better news is I managed to get my Zigbee thermostat connected to my hub using a combination of the search for device and these very cool beta drivers from @Mariano_Colmenarejo - thanks Mariano these work perfectly with my Centralite 3-Series Pearl ZigBee Smart Touch Thermostat


and for anyone using these thermostats, from the thermostat side this is what you need to do to put it in connect mode with the SmartThings hub

ZigBee Connect

Note: The thermostat is configured to automatically search for open ZigBee networks upon power-up for 90 seconds.

Complete the following steps to join the thermostat to your ZigBee network:

  1. Open your ZigBee touchscreen, router or gateway for joining.

  2. On the thermostat, enter programming mode and navigate to menu option 12, press HOLD to enter the “Join Network” menu, press (+) to display “01”, then press HOLD again to begin searching for an open network.

  3. The thermostat should now pair with your ZigBee network. Follow any on-screen prompts from your ZigBee touchscreen, router, or gateway to complete setup.