Code already registered. Invitation from owner needed to use this hub

Hi Kevin - Give it another go now. You should be all set.

I am having the same issue. I factory reset my Hub to clean it up after I moved to a new home. Now getting the message “Code already registered. Invitation from owner needed to use this hub.” I clicked on “Tap here for help” and when I log in it says “You’re not authorized to access this page.”

Can someone please help? Many thanks!

@Brad_ST
hi Brad, hoping you can help as you have shown in the above tread.
My serial number is #4000139284 - I am getting the same error message as others on here (Code already registered. Invitation from owner needed to be use this hub).
Support request ticket number is #1131518.
Thanks

You should be able to re-register the the hub as expected now.

1 Like

I am having the same issue “code already registered” on a STH-ETH-250 hub with S/N 3010035516.

I’ve reset the hub using instructions found online and the LED on the hub is a solid green.

@Brad_ST: hopefully you can help me like the others. (or perhaps I just need to give the system time to deregister the prior hub entry ?"

Thank you very much. Worked perfected and registered back onto my app.

1 Like

Do you have a support ticket open? Your hub doesn’t need to be deregistered or reset.

I just now opened a request 1132538

Your hub is already active on your account. Do you see it in the app?

yes, i see it now. thank you for the help

1 Like

Ticket #14150119222, kindly requesting for help, unable to connect