Challenged connecting RF23HCEDBSR to Android SmartThings app

I consider myself a reasonably proficient user but this has me beat!

I’m using a Pixel 5a running Android 11. My wifi networks are 5G biased but support 2.4G. I have a bunch of IoT devices connected to the Wifi network that I’m trying to use.

I connect my phone to that network though it connects to it at 5G and I’m unable to force it to connect at 2.4G

I’m using the Samsung SmartThings app. I’ve tried many times to connect to the fridge and failed.

I put the fridge in AP and can see a SMART-DEVFRIDGE or similar wifi network appear on the phone.

The app is unable to find the fridge.

I’ve disabled the cellular modem as that has helped with other devices. I’ve tried another wifi network that’s provided by a different router but that also prefers 5G.

The 2.4G vs 5G may be a red-herring because the SmartThings app isn’t discovering the Fridge even though I’m confident the fridge is in AP mode.

Are there any tricks? I’m beyond wanting this for convenience and it’s become a battle of wills :grinning:

At a guess you have tried all the connection methods recommended? I had a brief read and there seems to be some button pushing and door opening involved

Thanks! Yes, I think I have.

The RF23HCEDBSR can be put into “AP” mode with the buttons on the fridge’s front control panel.

After this is done, the phone sees the fridge’s wifi networks (SMART-DEVFRIDGE or something).

Not sure which form of connection your fridge has but a quick read says for non family hub fridges you have to push the door alarm button when door open then button to activate AP mode, I guess you already pushed the door alarm button to unlock the temperate control panel ?

Your fridge then needs to be seen on your WiFi network, if you are unable to switch off 5 ghz WiFi leaving only 2.4 ghz have a read at this thread

The issue with 5ghz affects alot of users who cannot switch off 5ghz in favour of 2.4ghz

Thanks @fido

I’m confident I’m getting the fridge into AP because it displays AP and I see the network appear on my phone.

I will give this “distance” trick a whirl, thanks.

Well if non of the above help perhaps @SamsungZell will have more ideas

Having a re read of your first post I think the main issue seems to be your phone is not connecting to the 2.4ghz network

If that is correct then a hotspot should work best

Hey there! @DazWilkin, Welcome to the Community! :slight_smile:

The 23 cu. ft. French Door Refrigerator in Stainless Steel, US model RF23HCEDBSR isn’t listed as a supported model in Smart Things after checking my list. I see that the US White model RF23HCEDBWW is listed. You may want to reach out and put in a support ticket to see if your specific model has compatibility within the Smart Things application. (Support@smartthings.com)

This specific model (BSR) is listed as using the “Samsung E-Smart Ref” application available at this link in the Google play store: https://play.google.com/store/apps/details?id=com.samsung.ref&hl=en_US&gl=US

Here are the steps for Connecting the Refrigerator to your Network using the Downloaded ‘Samsung E-Smart Ref’ App.

  1. Launch the app. The network configuration screen appears.
  2. Configure the AP information (SSID, Password, etc.) on the app screen.
  3. Configure the network settings according to the instructions in the app.
  4. On the refrigerator, press and hold the Fridge and Energy Saver buttons at the same time
    for 3 seconds. The refrigerator enters the AP mode.
  5. If you have completed the network settings
    properly, the app shows the home screen.

I hope this message finds you well!

^SamsungZell

1 Like

Thanks @SamsungZell this is helpful.

I have tried the Samsung E-Smart Ref app too and been unsuccessful with it.

The fact that the fridge is creating a wireless network that I can see only my phone only when the fridge in in “AP” mode (DEV-SMARTREF) suggests to me that the issue is either with my phone (I have tried another albeit another modern Pixel phone) and/or an issue downgrading to 2.4GHz wifi.

Thank you for the pointers… I’ll email support.

1 Like

This evening I tried using a really old phone (Google Nexus 5) that I’m confident doesn’t even support 5Ghz.

I used the E-Smart Refrigerator app.

Still no luck

I’m admitting defeat :frowning: