How Do I Connect Samsung Refrigerator RS22HDHPNSR "Non-Family Hub" to iPhone SmartThings?

I bought a place with a Samsung refrigerator RS22HDHPNSR (2014) and I want to connect to SmartThings on my iPhone 12. The original instruction manual names a different app, but it’s not available on iPhone. I tried these instructions to connect to SmartThings but it didn’t work: Connect Family Hub and non Family Hub fridges to SmartThings

The “DIRECT-SMARTREF” wifi connection does not request a password. Then I got a 04-100 error in SmartThings with steps to reset the refrigerator but those steps didn’t work either. Any ideas how to get this older model to connect with SmartThings on iPhone?

These are steps I tried:

  1. Navigate to and open the SmartThings app on your phone or tablet.
  2. If this is the first time you are using the app, tap Start. Then, tap Allow all the time when prompted. This will enable the app to scan for your refrigerator.
  3. Next, tap the Device tab, and then tap Add (the plus icon). Tap Add device, then tap By device type, and then tap Refrigerator. Tap Samsung.
  4. You’ll need to select a location and room for your refrigerator. When you’re finished, tap Next.
  5. Then, open your fridge’s door and press the Door Alarm button. This will unlock the temperature control panel.
  6. Press the Fridge button until “AP” appears on the temperature control panel’s display. After a few moments, your refrigerator will appear in the SmartThings app.
  7. Once it does, you can select your Wi-Fi network and enter your information if it’s a secured network. Then, tap CONNECT. We recommend connecting the fridge to the same network as the phone or tablet.
  8. Your refrigerator will be added to the SmartThings app. Add a name for your fridge, and then tap Done. The fridge will now appear in the SmartThings app where you can remotely control some of its features and functions, like changing the temperature.

Contact Support and see if they can assist :slight_smile:

US: 1-866-813-2404
UK support 0333 0000333

I tried but they didn’t reply - it was escalated to Tier 2 but nothing - not sure what to do from here.