Can't set temperature and power consumption does not work

Hi. I have moved all my 122 devices to home assistant and my smartthings hub is powered off. How do I untag my self from this tread?

oooh, that’s unfortunate. I know some things aren’t entirely functional because it is still a Beta version, but I hoped it worked.
Ok, could you report that as well to Customer Support, please? To see if they can help with that as well


You can select “mute” so you don’t receive notifications anymore, this button is at the bottom of the page in a browser, I’m not sure about the mobile version:

1 Like

Customer support does not support is non-US users, and asks us to contact the UK one. And, frankly, either they dont know a thing, or, points back to the US. @nayelyz

I emailed support in early June, never heard back from them. I am in the US and I didnt get any help with this either. LOL. This happened in Feb 2021 as well and they fixed it in a couple of days.

Hi, there are no updates, yet. I’ve seen internal engineers keep asking the corresponding team thanks to your reports. Sorry for the delay.

Hi, I have exactly the same issue (loosing control of temperature control). It started on my Android device and now I have the same issue on IOS. Please keep us posted. Thansk

I have 4 thermastats and they all have this issue. The issue can be replicated to android and to ios. This issue is wide spread since march i believe. I talked to 2 of the major thermastat manifactures in canada and from what they both are telling me Samsung is giving them bad support and is not telling them usefull information. I tried to call over the phone but they refused to assist and told me to go to this community forum.

Actions speak louder than words and i dont see any actions in fixing this issue.

Hello @nayelyz ,

I second @Ooga’s message.

I talked to Sinope (one of the manufacturers whose products are affected by this bug). They mention that you guys are indeed aware of the issue and that it might be related to the edge drivers rollout. They seem to have as little info/feedback/reinsurance from Smartthings as we do.

We’re stuck on SmartThings app version (available on APK Mirror, SmartThings APKs - APKMirror ). More recent versions of the app make the thermostats unusable (again, we simply cannot set temperature, which is the main raison-d’être of such devices).

Could you update us on this?

Agree. It would certainly be nice to be able to adjust temperatures to compensate for variable autumn temperatures… Winter IS coming this year, too!

I would guess that the devices having this problem are using a DTH that relies on the old thermostat capability. That capability has been replaced with a collection of new ones, such as thermostatOperatingState, thermostatMode, thermostatHeatingSetpoint, etc.

At least the heatit thermostats use “thermostat operating state”, thermostat mode", “Thermostat Heating Setpoint” capability and so on. IF this error should be related to capabilities not beeing used anymore, do I really hope that smartthings support is able to see so. For me is the issue no longer a issue as I have moved to home assistant. This error started in April with the app version 1.7.85.x. The fact that smartthings/samsung is not able to say whats causing this issue tells me that smartthings is more or less a dead product. I did like smartthings until this started in April, but there is no chance I will go back to smartthings now.

Hi, @SmarterStuff

Edge drivers are not related to the issue. When there’s a problem in the app UI, it’s due to the plugin and it is a separate element. Edge drivers are basically in the backend and you should be able to use this capability through the API.
Another thing that I don’t know if I mentioned before is that, can you help us check if you can configure a scene with the new value of the thermostat setpoint and see if this changes the value?

I don’t have updates about this, I’m sorry.

Having the same problems as those above.
I did try to create a scene that changes the thermostat setpoint, but that didn’t work (setting temp to 15c)

Logs showing

ad079eb3-c545-4f76-9a3b-feb11c48d073 09:58:17: trace Enforcing limits in °C for request 22.0 heatingSetpoint. Adjusted Settings → Heat: 22.0

ad079eb3-c545-4f76-9a3b-feb11c48d073 09:57:35: trace null: ThermostatModeReport(reserved01: 0, mode: 1)

ad079eb3-c545-4f76-9a3b-feb11c48d073 09:57:35: trace Parse returned [null]

ad079eb3-c545-4f76-9a3b-feb11c48d073 09:57:35: trace null: ThermostatOperatingStateReport(operatingState: 0, reserved01: 0)

ad079eb3-c545-4f76-9a3b-feb11c48d073 09:57:32: trace Parse returned [null]

ad079eb3-c545-4f76-9a3b-feb11c48d073 09:57:32: trace null: ThermostatSetpointReport(setpointType: 0, scaledValue: 0, scale: 0, precision: 0, value: [0], reserved01: 0, size: 1)

ad079eb3-c545-4f76-9a3b-feb11c48d073 09:57:28: trace null: ThermostatSetpointReport(setpointType: 1, scaledValue: 22.0, scale: 0, precision: 1, value: [0, 220], reserved01: 0, size: 2)

ad079eb3-c545-4f76-9a3b-feb11c48d073 09:57:25: debug Setting setpoints: [targetHeatingSetpoint:22.0, targetCoolingSetpoint:null]

ad079eb3-c545-4f76-9a3b-feb11c48d073 09:57:25: trace Enforcing limits in °C for request 22.0 heatingSetpoint. Adjusted Settings → Heat: 22.0

Thank you @nayelyz,

I updated the Android app to last version ( for this test.
Temperature control buttons are gone on Sinope Thermostats (type “TH1300ZB Sinope Thermostat” and type “TH1123ZB-TH1124ZB Sinope Thermostat”) and Stelpro thermostats (type “Stelpro Maestro Thermostat”)

Creating a scene that sets the heating point at 28C and running it works (the heaters connected to these 3 types of thermostats start heating, heatingSetpoint to 28C appears in devices’ logs).

The heatingSetpoint still doesn’t show up on the device view nor temperature control buttons (attached screenshot). Same thing in
So end-users have no way to see what the current heatingSetpoint is or adjust it.

Reverting to (which works as expected) while this is being worked on.
Do not hesitate to ask for other tests: “winter is coming” (and as these two companies are Canadian, quite a few of us will soon have a very real need for this to work properly).

Hello @Geir_Skalvik,

Creating and running a scene on 3 different affected models works on my end (see my earlier message today).

May I ask:

  • What is the device type of the thermostat you ran the test on?
  • On which app version? Android or iPhone?
  • Is it possible that you have a minimum temperature setting set to 22C (09:57:25: trace Enforcing limits)?
  • Could you try to configure you scene to set the heating temperature to 25C and run it?

@SmarterStuff So, setting the temp to 25 in the scene did actually work. The only way to find out is to check the physical device :slight_smile:
The device type is “Heatit Electronic Thermostat” (Heatit Z-TRM3).
Running android 12, and app version

1 Like

Thank you @Geir_Skalvik,

Are you Using Rboy’s custom DTH?
They’re talking about this issue here: [RELEASE] Heatit Z-TRM2fx / Z-TRM3 Electronic Thermostat Device Handler (Official) - #99 by Banisaad

You may also read The End of Groovy Has Arrived

So, @nayelyz, the following devices experience the bug (heatingsetpoint info and control buttons missing on the device screen) but are able to have there heatingsetpoint changed via a scene:
*TH1300ZB Sinope Thermostat
*TH1123ZB-TH1124ZB Sinope Thermosta
*Stelpro Maestro Thermostat
*Heatit Electronic Thermostat” (Heatit Z-TRM3)
(Sinope and Stelpro thermostats are not using custom DTH and use the default device type provided by Smartthings)

My Stelpro Maestro also has no tile for setting the temperature, what’s going on? This problem have been on-going since April really??

Is this the place to ask: will the new SmartThings that is coming soon fix this problem?

I am very frustrated that my relatively new Stelpro thermostats can’t be controlled by the app.