Can't add devices to rooms? An Unexpected Error Occurred

So I just got a SmartThings home monitoring kit this past Thanksgiving weekend and set it up per the instructions. I paired the included things, two multi purpose sensors, a motion sensor, and a outlet. Everything went fine. I then went through and created all my rooms in the house. After that I edited the outlet and called it “Christmas Tree” and used it to turn on and off the tree which worked. However I wanted to put the outlet into the room I created called “Living Room”. I clicked on rooms then Living Room then “Add a Device”. On the next screen almost immediately it pops up a red box at the top with a triangle and the text “An unexpected error occurred”. I click Back on my phone and the error goes away but I can’t do anything other then back again or done. On the screen is “Devices in Living Room” which has nothing then “Devices not in Living Room” which also has nothing.

So I thought it was a fluke and ignored it for the time being, installed the “Smart Lighting” SmartApp and set it up for the tree to auto turn on and off. That works just fine. I went back into the living room hoping to add it and same thing. So I tried other rooms and got the same error on them. I then went into the “Christmas Tree” think and did a Edit Device. I changed the name slightly hoping something would update but I still couldn’t add it to a room. Then I went into the Living Room and did a Edit Room. From there I tried “Add/Edit devices in this room” and got the same error message again.

Finally I closed all open apps and rebooted my phone and tried again. Same thing. Then I went into the application manager, went to SmartThings, cleared the cache and data. Started it back up and it was reset. Logged back in, went through the welcome screens, tried adding the tree to the living room again and the same message.

After all that I cleared the cache and data again, force stopped the app, and uninstalled it. Rebooted the phone, reinstalled the app, logged back in, went through the welcome again, tried one last time, and same error.

So I broke out my old android tablet which is awfully slow but still works. Installed the app and got the exact same error. I have to assume at this point that this is a bug in the app. My phone is a Samsung Galaxy S6 running Android 5.1.1, my tablet is a Nexus 7 also running 5.1.1.

With that thought in mind I had my girlfriend using her iPhone 6 Plus install the app for iOS. She logged in, went into rooms, clicked Add Device and all the devices were listed under not in the room. She clicked the Christmas Tree outlet, added it to the Living Room, hit done and it worked fine. I looked in the room on my Android and sure enough it was there. I then hit Add Device hoping that now that a device was added it could get around the bug but same error again.

I couldn’t find anyone else reporting this so I’m posting it here so hopefully it can be fixed and others having the issues will find this post.


I’m pretty sure this is a new bug. I’ve done it a million times but noticed the same thing earlier today.


I can add devices to rooms.

Are there any errors in the logs? What kind of device is it?

Android… Not device specific… If I go into any room and say add device I get the red bar before ever selecting a device. Nothing in logs.

Ahhhh ok, tested on a iPhone.

I’ll test on an android tomorrow. :smile:

1 Like

Same issue here Android Nexus 6 and Leviton Outlets Zwave

Same issue. Android. I opened a ticket. Feel free to do so as well. Think it showed up in 2.06

Same here android note 5.

Same here with v2 hub and Android

Not that this needs any further confirmation, but I’m seeing the same issue. Nexus 6 on 6.0.

@slagle do you want us all to submit support tickets or will you handle the communication about this bug?

I submitted a support ticket stating that you can not add devices to a room on the current Android app and put a link to this forum thread. I would think, hopefully, with the other replies that should be enough for them to see its widespread.

Although this did not help me in my “android is better then iOS” argument when my girlfriend smirked and said “Hrm…works fine on my iPhone…”.


1 Like

Please submit a ticket, but I have submitted a internal ticket as well.

Is anyone else seeing strangeness with not being able to add devices to an existing or new room?

This just started happening a couple of days ago, and with the ‘lag time’ of attempting to email or chat with support (Ha!, good luck with that!), it’s driving me crazy. @slagle, could this be related to the same issue you’re currently tracking with engineering?

I get (in the Android app): ‘An Unexpected Error Occured’


No date… but, this has been prioritized by the Android dev team :smile:


Heh - I should hope so… :smile:

Thanks @slagle - guess I’ll have to eat crow and use my wife’s iPhone to move room stuff around…

Tim, can I borrow your iphone in the meantime? I am sure that will make it a higher priority to fix :smile: