Unexpected Error Occurred

When trying to modify or remove any smartapp I get this. Anyone else seeing this?

1 Like

I just set up my smartthings for the first time today. I got the light switch to work and now everything I try to add is giving me a red bar with “An unexpected error occurred.”

It’s an issue on their end.

1 Like

Thank you - seems to be working now.

try to use a different device. mine was not working on Apple iphone 6s, but works on andriod!

It works now, it was because of the issue they sent an email out about.

This has been so fustrating… I signed up via the app with my email. It worked, I added a device then other devices gave me an error. I came here and saw this thread so I waited 15 minutes and everything worked. I was able to add stuff and automate a few things but saw I needed a “momentary button” for something I wanted to automate.

I tried to login to https://graph.api.smartthings.com/ but it said I didn’t have an account with my email address - so I created one (thinking it was different) - sure enough it said no hubs present. I logged out of my smartphone app and logged back in hoping that would kick something but now its asking me for my device code again. I try to enter it and it says the device code is not valid.

I emailed support and now I wait.

do you have the email?


They got right back to me and all seems well again.