Unable to Create Rooms or Add Devices

Hi all,

I need some help please, I have the problem of unable to add rooms or devices in the new SmartThings app (version 1.6.52-437), I’m currently using SmartThings WiFi as my hub.

  1. If I create a room in the SmartThings app it gives a “No network connection. Connect to a network and try again.” error and does not continue.

  2. If I log into graph.api.smartthings.com and tap on my location I see the room I just tried to create in the SmartThings app.

  3. I have sent countless messages and emails to Samsung using the SmartThings app and email, however, I receive the same response every time… I’m guessing that “Subrahmanyam C” is either a bot or the least knowledgable person on planet Earth that can only reply in two ways. :frowning: (not much English with that one!)

  4. I have done google searches and found back in 2016 other people were having the same issue, however, this didn’t advise on how to go about fixing my issues.

If someone can advise or point me on the correct path for resolving my problem I would be forever grateful.



Tagging @Brad_ST

This looks like an account region mismatch. If you sign into https://account.smartthings.com/ what URL are you redirected to?

Morning @Brad_ST

Thank you, thank you! :smiley: :smiley: and Thank You @jkp for helping out.

The location is out of sync is most likely causing the issue, as I have raised support tickets and some have been sent to the US team, sadly they could not give and help :frowning: as I do not reside in that region. (They did reply nicely, which is better than the support from the land down under!) . - Australia, so my local server should be Asia Pacific… ap02

I have multiple hubs (SmartThings WiFi, 2018 & V2) I’m a long time SmartThings user about 5 yrs or more.

When logged into graph.api.smartthings.com they were showing different servers.

SmartThing WiFi = ap02 server
2018 = not in use, upgradded location to WiFi model.
V2 = na04 server

The geolocation details of the hubs are set correctly (Sydney Australia) so the sever back-end thing must not be user-settable.

In an effort to try and resolve the issue I have;

  1. Reset the SmartThings WiFi and set up again.
    (Nightmare by the way… you need internet to set up a router :roll_eyes: it times-out when entering in PPPoE details (iOS)… and the PPPoE user login has to be less than a certain number charters i think)

  2. Deleted and redownloaded the app many times from my smartphone app store.
    (Deleted the app from purchase history and downloaded again)

  3. Removed and re-added locations.

  4. Removed & Reset the V2-hub from my account.

Everything I try seems to not work :frowning:

My last attempt I guess is to delete my Samsung account in hopes that when I set up the hubs they will correct themselves, I better not hold my breath, I have already started losing hair over this :frowning:

After this, I guess I set fire to my apartment and claim insurance before I really lose the rest of my sanity.

If you can offer any sort of suggestions on how I go about fixing the issue I would be again grateful. :smile: :smile:

Cheers and stay safe.


These are the two most probable scenarios:

  1. Your Samsung account region is Australia
  2. Your Samsung account region isn’t Australia

Adding in these scenarios to the v2 and ST Wifi locations we’d get:

  1. in the new app you would have issues with the v2 while the ST Wifi location should work as expected.

  2. The opposite would be true. The ST Wifi location would have issues while the v2 location would work fine.

As you are in Australia, #1 is the most desirable scenario. In that case you would need to delete and re-configure your v2 location. For #2, technically you could remove and reconfigure the ST Wifi location but I would highly discourage that as you’ll still have a region mismatch. The region value isn’t user-settable and the only way of “resetting it” that I am aware of is to delete your Samsung account and re-create it. If you find you’re in situation #2, that would be my recommendation. Deleting/Recreating your account or creating a new account.

Do you recall having the Samsung account team change your account’s region previously? If so, that change would not impact SmartThings and would explain this predicament.

Thanks @Brad_ST

You have been very helpful :smile: :smile: I owe you a beer buddy if we ever cross paths!

Yes, I did have the Samsung team update location details on my account a while back long before my issues started to come into effect, (that I’m aware of) I didn’t think this would impact so much, and I confirmed with them if it would have any impact my SmartThings setup. - perhaps it only all got messed up when the servers/merge roll over to the new platform as my SmartThings email and Samsung email address are the same just different passwords.

I have tried even with no hubs attached to my account, I can create a new location, however, when I try to add a hub it asks to set up a room and fails :frowning:

I think the best thing to do is delete everything, Samsung account, SmartThings account if possible (although this is no longer in use), and start fresh.

Thank you, buddy, for your support and guidance in the last 24 hrs, this has been the most I have had in weeks.

:beer: :beer: :beers: :beers: :beer: :beer:



1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.