Cannot reset SmartThings Hub 2018 v3 (IM6001-V3P22)

I recently deleted my SmartThings hub from my SmartThings account, as I wanted to reset it and move it to another account completely. Deleting the hub from the app worked as expected and the device + all the other devices linked to it where removed. However I then went to reset the device, but every time I do so, the device ends up in a state where the front LED is blinking blue (i.e. it a hasn’t got a network connection) if I connect an ethernet cable to it the light sometimes goes solid green but often goes back to blinking blue- (before I deleted the hub it was connected via ethernet), but ultimately it doesn’t reset.

To factory reset the device I am doing the following:

  1. Unplug the device
  2. Holding down the reset button
  3. Re-plugging in the power while
  4. Continue to hold the reset button for 30 seconds. - here the front LED rapidly flashes yellow
  5. Once the LED has stopped blinking and turned solid, I release the reset button (within a couple of seconds of the LED turning solid yellow)

As soon as I release the reset button, the LED goes off. After a couple of minutes, the led then starts blinking blue again.

I have also tried holding the reset button while the device is powered on, waiting for the front LED’s to flash yellow and then preforming the above steps; but again to no avail.

The issue here is now I cannot connect to the hub at all as it no longer detected in the SmartThings app, but it seems I can also not reset it.

Am I doing something wrong here?

1 Like

Tagging @Brad_ST

It doesn’t sound like you are holding the reset button long enough if you’re letting go before the LED goes solid yellow. Releasing while the LED is flashing yellow will just soft reset the hub which doesn’t remove the hub from your account.


In step 5 I said “Once the LED has stopped blinking and turned solid, I release the reset button (within a couple of seconds of the LED turning solid yellow)” so after it’s stopped blinking - is this correct?

Ah sorry. I was looking at the steps described in your support ticket which don’t mention the solid yellow LED.

What does the LED do if you power cycle the hub?

No worries! When I power cycle the LED stays off for while after reinserting the power cable, but then goes back to blinking blue.

If the LED is blinking blue then the hub doesn’t have an IP address. Can you try activating the hub while connected to ethernet?

When you say activate the hub do you mean set it up in the SmartThings app?

Correct. The hub is already reset and is ready to be added in the app. The blinking blue LED indicates the hub isn’t connected to your network properly. So it doesn’t seem that the hub needs to be reset but it does need to be properly connected to your network.

Hi there,

I’m having the exact same issues, please can you confirm how you overcame this?


Same issue here. Blue led always on. Hard reset done many times (releasing reset after solid yellow)

Hello @Brad_ST :slight_smile: Is there something we could do?

Do you have more information? A serial number? A customer support ticket #?

Hello @Brad_ST
SN is 3011098267
That’s a hub v3

That hub is currently trying to update. What is the speed of the internet that the hub is connected to?

It’s connected thru cable and internet is high speed 250Mbps

Hmm, I assume you aren’t resetting the hub every few minutes. The hub isn’t fully downloading the firmware update which indicates a local network issue.

Hi @Brad_ST !
There’s no network issue since it’s directly connected to the ISP router and it’s connected for more than 2 hours without reseting. I can also ping the hub IP.

Hi @Brad_ST
Just wondering if there’s something we could do to resolve that :slight_smile:
Hub still with solid blue light even after changing network connection.

@andrefalcao There isn’t anything I can do remotely. If the hub isn’t able to update and connect to our servers it isn’t going to work in your location.