Cannot factory reset smartthings HUB V3

Good morning community,

This is my first post and this is not starting well.

I just received a smartthings HUB v3.

At the begining everything seems to be working well, i was able to pair the hub in the app and add devices.
Then I tried to add a member, and the app was not allowing me to do so as the accounts were not in the same regions.
In fact my samsung account was not in Canada but in another country were i lived in the past.
So after 45 minutes trying to change the country in my account i have decided to delete my account and start from scratch.

I have also decided to factory reset the hub to start clean.

Here is the probleme , I’ve tried many times the reset process as explain by samsung but the hub won’t reset.
I’m removing the cable, insert a pin, put back the cable in. Then the led is blinking yellow for 30 seconds, then when the led is steady yellow i remove the pin. The led blink 2 times blue then stay solid magenta for 30 - 45 seconds then turn steady red for ever.

I have tried many times and waited more than 10 -15 mins ( all night) the led is solid red.

I have opened a ticket with samsung but still waiting a reply.

If anyone as a quick solution, as i can’t wait to start using it.

Thank you.

It sounds like you’re following the correct procedure to factory reset the hub. I’ve never had a V3 do this. It should eventually begin flashing red/green.

Edit: I just factory reset a V3 I have laying around, I had no issues. Went from a quick blue light to magenta, then briefly blue again, and the flashing red/green. Total time it took was about 1.5 minutes.

Following in case this is related to my current issues with hubs returning network error during setup. Lots of bugs recently. There is a current degraded performance status that’s been posted for days now with no update.

I just spent 45 mins with Samsung on the Phone.
I went 10 times through their reset process.
Conclusion, nothing can be done, i must return it to best buy.

My own diagnostic is that the problem is coming from when i have changed the region and tried to reset the hub. Seems to have created an internal bug.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.