Can’t Connect my oven with smartthings : error : Wrong pp list


I bought a Samsung NV7B4430ZAB oven and I try to Connect il with the smartthings app on iPhone. When I put the Bluetooth on on the oven, the app find it but when i click on it I have a screen with this error ;Wrong pp list.
What can I do ?
I use a wifi 2ghz with a password with only letter and number.

You may want to post on the Samsung Community forum or contact Samsung Support. I have never seen that error before.

Go to and scroll to the bottom of the page to find the Community Forum and Support Contact.

1 Like

I have exactly the same problem with a new oven

I put a message on the Samsung community forum.
Not alone with this issue.


Tagging @AlejandroPadilla : connection error

Hi @Fran6 @Peter_Jones1 Welcome to SmartThings Community

I was checking with the team and this issue has already been reported, and the team is working on it, based on the report, it seems this error has been exclusively happening in iOS, @Peter_Jones1 are you also using iOS, or are you encountering a similar issue on Android?

1 Like

I’m using iOS and have just purchased oven and am getting the exact same error message when trying to connect my oven (NV7B41403AK/U4). ‘Wrong pp list’.

Do you know how long until this is fixed?


Same here - just bought a NV7B5… serie oven. Trying to scan the QR code on the small label in the front - giving me: Not supported QR code This QR code doesn’t apply for adding a unit to SmartThings!!! It is the ONLY QR code available. Then I tried to add the oven without the QR code - and I get exactly the same error message Fran6 reported in the beginning of this thread. I use IOS, 17.1

“Wrong pp list” error here also on newly installed NV7B45305AS/U4. Running iOS 17. Added to thread for updates on resolution. Thanks.

I get this exact same error when trying to add my oven to the SmarthThings app, however, my wife, also using iOS (but on iPhone 14 - im on iPhone 15 plus) does NOT get this error.

It might also be an error seen with the latest iOS?

Same error here - iOS, latest version. Can’t add NV7B45305AS/U4 to the app.

Happy to help with diagnostics if you need anything from this side. Reach out.

The ppList within the URL shows as: ppList=%5B%257B%2522

Same problem here with a Samsung NZ64B4015FK/U1 cooktop. I am running iOS17.1.1 on an iPhone 15 Pro, and tried with an iPad Pro : same issue as everyone.

“Wrong pp list”.

There should be another QR code displayed after pressing phone icon in the menu.

I have the same problem!! I hope Samsung due something. I chat with Samsung support but they say i should restart my product and delete the app and install it again…. But it dosen’t work

1 Like

I bought one some days ago and I have the same problem, I have ios system

I just had the NE63T8711SS delivered and, while it took a couple of times (with errors) I eventually got it to integrate into SmartThings. Everything seems to be working normal. iOS 17.1.1

I didn’t do anything special, just started it over a few times until I got all of the way until the end.


I reported this issue. My reply from the development team was that its probably to do with how the app handles the privacy policy and they will update asap

I tried with an ipad using older ios and app version, it got s bit further but failed.
Until a fix is sorted, try android if you have a device available

1 Like

Thank you for your reply. Where do you see that phone icon - it is not visible when I try to scan. There is just one option and that is scanning the QR code - which immediately gives an error message. I take it that everyone that reports the problem with ‘wrong pp list’ does so because the QR scan didn’t resolve. Or am I wrong?

You need to turn on the oven so its buttons and menus are visible. The icon is in the oven menu next to the back and turn the light on button icons (not on the phone screen) - a small rectangle. The QR code will be displayed on the oven screen too. And scanning this code will lead to the pp error screen unfortunately.

Has this issue too and managed to solve it, so registered here in hope this will help somebody, since Samsung isn’t willing to fix it.

As you see in the first picture, the App is trying to open some kind of website to get you to agree to terms and conditions. This page throws an error, since the URL has parameters it does not recognize, specifically everything after “ppList”.

So what you have to do, is in the app, when it shows the error, go to Safari and paste the same link, without the ppList parameters and open the link, It will show “Oven” and option to agree to privacy policy. Check that, hit “Agree” and webpage will say “Do you want to open this URL in the SmartThings app?”.

Say yes and it will open the app and continue the setup. You might have to do this quickly, as the app will time out after a while of waiting for the Agree button.

Your links will be slightly different, depending on the region and product type.

Link that is not working:,%2522needCheckAlways%2522:false,%2522ppVersion%2522:%25220.0.0%2522,%2522isOptional%2522:false%257D%5D

Link with removed ppList (don’t use this, edit your own link):