V2 Hub Won't Reset

I bought a used v2 hub on ebay (maybe a mistake). I need to do a factory reset on it.

I’ve done just about every combination of holding reset button/plugin power/plug in ethernet all in various orders and all I get is a Red/Blue light combo…no yellow solid or flashing.

If I leave it alone long enough, I do get a green light, but I’m not able to add to my ST account due to the fact that I need to reset it to get the Welcome Code “reactivated”.

Anyone have any special tricks, or did I buy a brick?

for a hard reset:

  • unplug the power cord and remove the batteries
  • with a pin, press and hold the reset slot and plug the power cord back in
  • wait about 30 seconds until you see the solid yellow led on the front of the hub and release the pin in the reset slot.
  • then wait about 10 minutes for hub to connect ST servers to check for firmware updates and to apply them

if a welcome is needed, you need to contact ST support. They will generally ask for an image that shows the bottom of the hub with the serial number.

if still not able to reset… perhaps try to get the welcome code to see if you can set it up.

if still not able to: return it and get your money back. :slight_smile:

also check if the hub is valid for your country or not one of those vodaphone models that no longer works.

3 Likes

This doesn’t make sense.

instead of focusing on the last 5 words of the sentence that you quoted from… focus on the first part of the sentence where the OP stated “I’ve done about every combination”. Now ask yourself - did the OP use the proper “combination” (only known method I am aware of) for resetting their hub because any other combination will not work? You are always welcome to step in and offer the OP assistance so that it makes sense for you.

1 Like

Ethernet plugged in.
Power NOT plugged in
Reset button pressed and held.
Then power plugged in.
All I get is a cycle of red for about 2 seconds, blank for maybe 8sec, blue for 3-4 second,and then the cycle repeats with red again. I have a video but can’t upload it for some reason.

(I have also tried a similar sequence where I have the hub plugged in, pressed and hold the reset, then unplug power and plug power back in while holding the reset….same results)

Ethernet plugged in or not plugged in has no effect.

Have also tried with fresh batteries instead of power cable and no effect

Have also tried a known hood power cable from a different Samsung hub also with no effect

I did get the welcome code from Samsung. They just gave me the same one on the bottom of the device. But they even said that from their end they can tell the welcome code is still being “claimed” by a different user and that I need to factory reset it to “free up” that code.

If I just let the hub do its thing naturally (without me holding reset button) it does eventually go green light. If I try to add the device, I get a network error when I try to use the welcome code (in line with what the Samsung rep told me).

They have “escalated” my issue at tech support but I’m guessing that was just a move to get me off the phone and likely a dead end.

Just checking that there are no batteries installed at this point?

I just tried the above on a spare V2 hub. As soon as I inserted the power cord the LED started rapidly flashing yellow. As this point I released the power cord as I didn’t want a factory reset and it took a few minutes of cycling through red, blue, magenta and green lights before it settled on green, meaning that it was happy that it was connected to SmartThings and functioning as it should.

It is quite hard to get consistent information on the V2 factory reset and LED lights. Indeed Samsung seem to still be publishing instructions where you can press and hold the reset button at any time, instead of doing so when powering up, and I thought we moved on from that many years ago.

I have it in my head that the hub alternates blue and green when it is ready to be registered but I may be getting horribly confused.

I never got a yellow light when factory resetting my old V2 hub either, following the same directions. But when it connected after my attempt to factory reset it, it was back on an old firmware that had to go through a cycle up updating to install Edge drivers on it when Edge drivers had been previously installed on it, so I assume it did it just without giving me the signals that it did it…

Correct. No Batteries.

How did you know when to let go of the reset button if you didn’t have the yellow lights?

I don’t recall exactly. It was several months ago and I think I just tried it for the amount of time I saw in posts and tried it several times. Eventually, I guess I got the right duration.

1 Like