Can not add z wave switches to Aeotec hub/can’t control Leviton DZ15S

Any ideas why my z wave Leviton switches and Schlage locks will not connect to an Aeotec V3P01 hub? I had a SMT hub and they worked great until the hub crashed… The new hub loads ok to the ST app. The devices show offline on the app. My Wifi works throughout the house.

Perform a z-wave exclusion from the Advanced Web App. Go to the hub section and tap on the name f your hub to find the tool. Put your hub in exclusion mode and perform the needed task on your devices to complete the exclusion. Then try to add them.

for your schlage lock, install @philh30 Z-wave lock PH edge driver and changing to it on the lock.

Channel Invitation


ok thanks. I went to advanced user and added a switch in the device tab. There is no network id or the hub associated with it. It only seems to work off of the cloud, but not in real life.
How does one add the network id and the hub associated with it?

You added a virtual switch. To my knowledge… you can’t add Network IDs (at the time of this post). The only way to add physical devices (zigbee/z-wave) is to use the ST app to add them.

yes. I’ll exclude and delete it again. I have excluded and added before. Also, reset the switches to the factory settings, moved the switch right next to my hub. I’ll try it again but for some reason the switches are not joining my wifi.

when you are excluding… are you receiving the confirmation that a device has been excluded?

what model is the new hub?

the model is aeotec v3p01. Yes I get a confirmation that the device is excluded

I have the same hub in my garage. I set up devices in my house on the wifi a few months ago. I then moved the devices to the garage. That still works.

More questions:

  • Model of Leveton switches and Schlage lock?
  • you have two hubs and the devices connect to the hub in the garage but not the one in the house?
  • distance from those devices to the hub you are attempting to pair them to?
  • have you tried bringing the hub within 10 feet of the hub when you pair them?
  • do you have any main powered z-wave repeaters?
1 Like

I’m sure that’s very frustrating. :disappointed_relieved:

sounds like @jkp has got you on track to troubleshoot this, but first, just to clear up one misconception…

Wi-Fi and zwave are different radio protocols and have nothing to do with each other.

Your Aeotec hub is a plastic box That includes multiple radios, including one for Wi-Fi, and one for Z wave. Both connect to your smart things account, but otherwise they don’t interact.

If you have your hub connected via Wi-Fi, then it will use Wi-Fi to reach the smartthings cloud, and the cloud will use the Internet to reach the app on your phone. But your hub will use the separate Z wave radio to talk to Z wave devices .

So… z wave devices will never connect to your Wi-Fi. That’s just not how they work. For example, you would never see them in a listing of devices connected to your Wi-Fi router. So it doesn’t make any difference whether you have good Wi-Fi or no Wi-Fi as far as reaching your Z wave devices. Except, of course, that if you are using a Wi-Fi connection to the hub, the hub has to be able to connect to your Wi-Fi.

Your Z wave devices will show up as devices in your smartthings app, but that’s because the hub is telling the cloud that it is connected to those Z wave devices.

Leviton does make both Wi-Fi versions and zwave versions of its switches which look identical, so we do need the model number of those devices just to make sure that they are in fact Z wave and not Wi-Fi.

If the Switches are in fact Z wave and they are showing up in the list of devices in the smartthings app for your hub, then at least at some point they did connect via Z wave to that hub. If they are showing as off-line now, that might be a different issue. But @jkp can continue working with you on that. I just wanted to explain the difference between a Wi-Fi connection and a zwave connection to clear up any confusion there.

1 Like

When the mobile app is searching for a device, is the green LED on the front of your hub flashing?

1 Like

leviton dz15s
schlage connect be46nx and be469zp
garage hub is ethernet and works
house hub distance to devices 20 feet. I have alsp brought a switch within 2 feet but wouldn’t connect
no powered repeaters.
house hub is connected by ethernet

thanks, the switches and door locks are z wave. They show off line for some reason

1 Like

I’ll check later and let you know thanks

All of your switches are z wave repeaters so you’re probably OK as far as that goes. :sunglasses:

I have the switch one foot away from the hub. The green light on the hub flashes. The switch shows up in the app but it doesn’t work.
Do you think the hub could be the problem? I bought an open box on Ebay

Firmware version of the hub?

I get the message for the switch “offline check that it’s on and connected to a network, and that the network is online”

If the switch shows up in the app, it is being added to the hub.

My next step would be to check which edge Driver it is using and probably try one of the community edge Drivers instead. :thinking:

There is no driver listed for the switch in the app on my iphone. I’ll remove the switch and try adding it again. I have seen the driver before in the advanced ST for z wave switch.