Button editing stopped working after latest iOS update

Not sure if this for everyone, couldn’t find a post about it, but since the last update, the edit of individual buttons have been lost in the app.

I’ve got a couple of Ikea 5 buttons and an Xiaomi Aqara. I can still use them physically, but not edit the actions.

Known issue they are working on :frowning:

1 Like

As I’m saying this… even the physical buttons stopped working. How can someone release an update the breaks such a crucial part of this device eco system and then take more than a week to launch a fix?
For me this touches on unacceptability. Parts of the house lights are not working as intended and half the family will complain that the whole system does not work. If it’s that fragile then I’m not sure how capable it is.

Do you have a link to a bug report? I cant seem to find anything but this topic and the one I replied to you on as well.

Im having this exact same issue. I see the buttons and key presses, but cannot edit the pressed/held events anymore and the buttons just stopped working a couple days ago. I dont think the iOS update specifically messed it up as my work phone is older and same issues when I login to smartthings on that as well, and the app was last updated 3 weeks ago. I think someone borked the backend server plugins as the buttons execute their code via the cloud and not locally.

1 Like

exactly. it is a plugin issue. So luckily can be fixed without an app update.

1 Like

Now the question is on who maintains that plugin, my support inquiry to Samsung said it wasnt a supported thing so I think someone wrote it and just got it published via the Web IDE to be publicly usable. However, I did install the CoRE Smartapp and that seems to have allowed my buttons to work with the pistons via the new app so going to set all of them up on that to get everything working again.

Samsung better support their own buttons.

1 Like

My issue is similar with two Smartthings buttons. I can edit the actions and when the button is pressed it shows that it was pressed in the app but nothing happens. I have two buttons controlling two separate lights and both stopped working last night. I can turn the lights on and off from the app just fine.

1 Like

If you can edit the buttons then it might not be the same issue.

What do you mean by plugin? This happens on my IKEA TRÅDFRI Remote which is supported. The inability to edit started happening immediately after updating the app a few days ago, and the buttons themselves stopped working yesterday.

The same happens on three different buttons and two different DH so I’m sure the issue is deeper

Hello guys, I’ve already passed this to @Arkkous in his post, but in order to find solution soon, submit a ticket to SmartThings Developer Support so problem can escalate to a solution soon.

Greetings!

Developer support isn’t really the proper channel for this IMO. We aren’t developers with questions about APIs, capabilities, etc. This should be handled by the normal customer support channel.

Actually, if you look at the list of officially supported things (https://www.smartthings.com/products/-/filter/brands/ikea), the buttons are not on it. What I mean by plugin is if the developer that wrote the “IKEA Button” type may be the one who has to fix it as I do not know if Samsung officially authored that handler, or if it was a submitted development thats available to the public.

I did however get CoRE SmartApp installed and a piston configured and that does seem to be working so far at least with the one test button I setup.

So you are having this issue with the actual Smartthings branded buttons? Zohar, prjct92eh2, and myself are having this issue regarding the IKEA 5 button remotes.

I’m having it with both ikea and SmartThings brand buttons.

I now begin to think these are two separate issues.

  1. Edit buttons lost on some 3rd party buttons. For me since the iOS update a few days back. At the time, physical presses still worked.

  2. Physical buttons stopped reacting. For me and others since yesterday as mentioned in @Arkkous 's post . This is for both ST and 3rd party buttons

1 Like

Yes, the Smartthings branded buttons. The app shows that the button was pressed but the light doesn’t toggle. I tried removing and re-adding the action but that didn’t help.

I agree, it appears to be two separate issues as I don’t even use any IOS devices.

I have the same issue, Smartthings branded buttons stopped responding properly to physical press. I worked out that for me it’s to do with “switching state” of devices when pressing the button. If I do a single press it switches state but then a second single press doesn’t switch it again. To make the ‘single press device’ switch state again I need to do a double press (which switches a different device) and then go back and try a single press again, which then works. Same issue if I start with double press, I can’t then double press again without doing a different action first. Not sure if others with Smartthings buttons not working are experiencing same thing?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.