Smart things buttons stopped working

Hey wonderful people, I’m not overly technical so am a bit confused with what’s going on in the smart things world. Today my smart things buttons, which control my LIFX lights stopped working. I can see them in the smart things app and they appear to be registering their current temperature, but they do not register a push or hold and so do not trigger any lights…

I’m confused. Have tried resetting and reconnecting as well as uninstalling app, but I’m guessing it’s all to do with these changes.

Do I ditch my smart hub V3 and or the buttons or am I missing something?

Many thanks M


Hi, I’ve experienced the same exact issue. SmartThings button events just stopped triggering and don’t show in the button’s history as of early this afternoon. Three independent buttons, no configuration changes or updates have happened to my knowledge.

I’ve restarted the hub, changed batteries in buttons and moved them next to the hub to eliminate any interference. The buttons history are all showing frequent temperature readings and the battery status updates appropriately when a new battery was put in. Button events are just not working.


1 Like

Me too. Worked earlier this morning. Mini-mote and smarthings button do nothing.

I do see events on the History for the buttons, but they do not activate any devices.

Also checked the button configuration - all is correct: Button set to turn on or off the device as has been working for years…

The lights (devices controlled by the buttons) do work in the app.

I’ve ended up manually removing the buttons from the SmartThings app, pulling the batteries, putting battery back in and re-adding each to the app and reconfiguring all the events. Things then work again, it’s a huge pain in the butt but it’s at least a route to getting everything working again.

1 Like

me too. same issue.

my smart lock and automations stopped working today

I figured out what went wrong. when the devs pushed that quick fix, they defaulted my lock back to “Z-Wave Smart Lock” when it is supposed to be “Z-Wave Smart Lock with codes”. that explains why removing and repairing your devices worked, because then it had the proper settings. The fact that I wasted an hour of my time searching through the API web interface to get my lock fixed is disgraceful. the smartthings customer support has always been terrible and I’m really sick of my devices getting screwed by bad updates.

Same here. 5 Smartthings Buttons stopped registering any presses roughly at the same time. Batteries are fine, Temperature is still reporting in those devices.

I am hesitating to register/pair them again due to many automations. There is also no possibility to manually change the driver.

Any other ideas then re-doe it all? would be a first timer within smartthings in all the years for me…

1 Like

Same here. All my buttons stopped working after last night’s firmware update.

Phew… I’m glad it’s not just me being a numpty…

So I’ve tried to delete the device and then add it but still no joy. Has anyone has any luck? I use my buttons via the smart lighting app, but obviously you can add actions in the device settings, not sure this makes any difference as the device still has to register pushes to cooperate.


I have a smart things multi purpose sensor controlling a LIFX bulb in the under stairs cupboard and that is still working fine.

As everyone’s buttons appear to be down I assume they will do something about it?

Just referencing a thread discussing failure of Aeon/Aeotec buttons:

1 Like

Also in the same boat, 3 buttons all pretty much stopped working. Funnily enough a single press still works fine which I usually use to trigger a light on/off, but double press and hold when I usually run scenes are goosed. Tried deleting twice and re adding but still the same result.

On the android app, even a single button press does not update the status of the button, it still shows as in standby

Just adding a “me too”. 2 buttons no longer register presses but are connecting and reporting temperatures. Problem started yesterday.
If there was a firmware update it’s a bit of a rookie mistake to post it before a weekend.

1 Like

I have 3 buttons, two stopped working. The one that is working is newer and has a “Driver” option in the 3 dot options…thing. sorry I don’t know what it’s called. My understanding is if it has Drivers as an option it’s up to date. Ive read a couple ways to force an update but I don’t even understand how to get to my devices the website. Did it once… and now I forgot. I hope it’s all part of the migration thing they are doing and it’ll be fixed soon. Already lots a lot of automation from just one button not working anymore.

Complaining here is not going to get SmartThings support to resolves your problem. Open tickets directly with SmartThings support! The more tickets opened, the faster this will get resolved.

By chance are any of these buttons been in place for many years? I’ve had MiniMotes continue working with a configuration of buttons that no longer have a UI. This occurred when the old app was retired. The solution was to remove the device, and thus the automations were deleted. Then I added them back as new devices and used the modern tool for configuring the button actions.

1 Like

ALL of my buttons stopped working last night. My 94 year old Mother uses these exclusively at her Assisted Living Home to turn on/off lights. She is 600 miles away from me, and I’d like to get her going again. Can you direct me or give me a URL to put in a support ticket. I have never had to do this before. Thanks. Ugh.

1 Like

Same here - but I’ll add one other observation: I have a Smartthings button with routines configured for press, double press and held. Only the double press routine runs locally (house symbol in routines listing in the app). That routine still works, but the other cloud-based routines stopped working yesterday. So I can still use this button with double-press.

1 Like

Thank you. I have little faith that I will get an informative response, though.

so, out of about 20-25 buttons so far i’ve only experienced one non-responsive button that controls a bedroom fan last night. this morning it still wasnt working so i tried a new battery, but that didnt resolve it. when i removed it and re-added it then it started working again.

I also have determined that this is related to rollout of new Edge Drivers. Some buttons updated to new Edge drivers, some didn’t. The ones that didn’t will not work now. (Maybe you didn’t have Auto-Update Enabled?) Anyway, removing the button device, and then adding it will set the button to use the Edge drivers. And, once you replace your settings for button-presses, it will be functional again.

Button will now show as “placeholder” Type in Groovy.

Interesting thing: One of four Samsung ZigBee Buttons now shows an option of up to 6 button presses for action.