Broken presence in iOS and Android - what's the deal?


#1

Like others I had mobile presence problems with the iOS 11 update. Presence is critical to most of my automations so I downgraded my phone to 10.3.3, and have been paying attention to community activity and ST updates around this subject. I have ordered a Pixel 2 and am preparing to make the switch to Android, and from the forums I see Android users are also having similar problems.
All I’ve seen so far is scattered comments from user communities… has there been any response from Smartthings on this? Presence is one of the foundations of home automation, I would think the company would be worried about users leaving. When working ST has been great but this has been going on over a month.


(jkp) #2

discussion on this topic in the following threads…


#3

Honestly,if you search the forum, you will find that presence has been an issue on both Andriod and IOS for a very long time. I don’t believe from reading all of these posts over the time I have been a member that this issue has ever been solved long term by anyone that’s posted here.

Over time there have been many solutions, some quite convoluted, applied. Some worked for quite a while, some for only a couple of days, but all eventually fail at some level. I don’t really look for any solution from SmartThings as I have not read anything that would lead me to believe this is a SmartThings issue. I believe this is a phone issue which stems potentially from both how location tracking is implemented and the limitations of location accuracy when phones are out of sight with the satellites.


(Mike Thomas) #4

Bite the bullet and use Life360. I can’t remember ever having any misfires with SmartThings presence (using Life360) with either of our phones (running Android M & N).

And this works well even though I almost always have the phones in “battery saving” mode - meaning cellular & Wi-Fi only, GPS not used.

What do I care if the Russians tell the NSA where I am within a quarter mile? :grinning:


#5

Disagree. I never have issues with location based reminders from the native Reminders app and other apps that use Geofencing. Webcore has also circumvented the issue and works reliably with presence as a workaround to SmartThings app issues. This is definitely a SmartThings app issue.


#6

If you say so, I believe you.


(Betty) #7

To the original question about whether there’s been response from Smartthings, I haven’t seen any. I find that odd too. This is a big problem that affects the very use of their product.


#8

I have to disagree I have had issues with Life360 since I switched to Android. I am using g the tasker and sutolocation approach and it is working.


(RH) #9

My Android has worked perfectly for a very long time with zero issues, but last Sunday, it stopped showing away. I thought I’d wait to see if it healed itself but it didn’t. I removed and reinstalled the phone as a presence sensor and it is working fine again for the past 10 events with again no issues.


(Mike Thomas) #10

Interesting @BBoy486. I do need to clarify my statement a bit, though.

Life360 itself has been flawless as far as I can tell. We each get a notification when the other leaves/arrives at home/work and it seems pretty much spot on.

However, occasionally SmartThings doesn’t “get the memo” and one of us stays in the wrong presence (e.g. SmartThings thinks I didn’t come home last night, but Life360 shows I am home. Sometimes that clears up the next time whoever was affected transitions from home to away (or vice versa), but occasionally I have had to deselect and reselect that person in the SmartThings app (Automation > SmartApps > Life360 (connect)).


(Bryan) #11

+1. My hub is really struggling to recognize when users are home or away. How do I fix this? This issue is crippling my automation.

iPhone 6S+, 7, and 6. None seem to be accurate.


(David) #12

Had this issue for most of the Sept and up to about a week ago. Rebuilding smartthings hub, phone, defaulting and re-installing going to life360 never could get it to work more than 6-7 days kind of reliably.

Finally talked to phone carrier, replaced my phone and now going on week 2 with no problems. We’ll see


#13

I think it all comes back to Smartthings.

I posted about this here Using SharpTools with ST and Tasker for presense sensor as I have had issues with my new August Lock. As you can see in the thread I am still having trouble but getting closer.

Options #1 - [HOW TO] SmartThings Presence reporting using Tasker/SharpTools/AutoLocation

Option # 2 - [RELEASE] Improved Mobile Presence (Android only)


#14

I slightly disagree with you. Yes, while there are a ton of presence issues that can be directly attributed to ST being the culprit, I believe there are also other issues causing this that has nothing to do with ST whether it be the OS or the phone itself. Kyle, one of the ST staff members reported seeing this in his Nest App (posted yesterday in Mobile device presence broken with iOS 11 )where he arrived home and it didn’t register Nest as Home as his cameras stayed on so presence in that app didn’t recognize his phone as being there. He believes that is directly related to the IOS version. Another person also stated that when looking directly in the August app detecting false arrivals as well. While i agree that most issues that people have with Presence (including mine last week posted in other thread with resolution attributed to ST version 2.8.1 causing it) are directly attributed to ST, I believe there are multiple types of issues that affect everyone in different ways with a different source of what the issue is, between Android and IOS and all the flavors versus GPS on phones, etc etc. No matter where the issues stem from, I know it’s frustrating for all those that don’t have it working reliably.