Android Oreo


(jkp) #1

Broken presence in iOS and Android - what's the deal?
(Joe) #2

It’s on mine officially 5 minutes ago. Just restarted.


(Michael Harman) #3

I know it shouldn’t be that bad, but I feel like I’m going to be confused for a split second on a lot of articles over the next couple of years… we have a dog named Oreo…

FYI, this is what happens when you give a dog a piece of Kale…


(Kanishk Singh) #4

That’s cute! Now I want a dog name oreo eating kale, with a cat watching!


(Derek) #5

Any issues with the ST app or presence detection?


(Kanishk Singh) #6

On Nexus 6p Android O Beta 2 and 3, I had lot of issues with Presence detector. But i believe that was due to ST app not optimized for Oreo, so will have to wait and watch.


(jkp) #7

your dog Oreo eating android oreo…


(Joe) #8

None that I’ve seen so far but I didn’t have any on the beta Oreo and I have a pixel phone


(jkp) #9

#10

I just got the Oreo update on my Pixel a few days ago. Mobile presence hasn’t worked since the update. I have emailed ST support (moments ago), it might be something with my phone as iftt presence isn’t working right either. It seems the settings for optimization have migrated during the update though. Going to start troubleshooting here shortly by removing apps and reinstalling them. I also have MobileIron for work and I was told Oreo wasn’t supported yet, it’s notorious for not working right anyways and it has admin privileges so it could very well be the culprit. Last attempt will be a hard reset but wanted to see what support said before doing that. I’ll share whatever I discover.

Update:
I believe I have identified the issue, it appears that the application mobileiron busted some of the functionality of my geofencing based applications (Tasker, iftt, and Smartthings). The apps themselves worked but not the location service parts. Google maps did work though so I overlooked the possibility that location based services was broken elsewhere and maybe they use different stuff to do their job - idk. It does appear to be working now though with my tests using joystick.


(Jeffery Mc Dowell) #11

+1 Oreo pixel with presence no longer working. I have found if I open maps that it takes a second and then I appear as present. I have location set too high accuracy. Looks like I need to contact support.


#12

Did you try to re-add the phone as a presence sensor. This happens all the time after phones get updates.
You should also uninstall the ST app and re-install it.
This works for me all the time. Can’t say the same for my wife’s IPhone Crap 6


(Alex Walker) #13

I heard the Oreo UI is much cleaner than Nougat. Any insights on this?


#14

Same presence sensor problem with Android Oreo on Pixel XL. Tried reinstalling app and re-adding phone as presence sensor to no avail. I’ve also opened a support ticket with SmartThings.


(Russell B) #15

Same issue on the presence sensor. It’s very frustrating. From what I can tell, it appears that in their attempt to control background tasks taking up too much resources in Oreo, Android has kneecapped applications like SmartThings. Even Google Maps takes a few moments to activate location and then find me. This is incredibly irritating. I doubt ST can do much about it either. Unless I hear anything back from ST that they are aware of the issue and have a solution in progress, I feel like the only option I have is a physical presence sensor.


#16

Not sure if this is the cause, but could need to update Google play services. I still had the version that was not updated to the Oreo targeted version. I updated based on poor battery performance but also I was finding GPS getting stuck on and it seemed to resolve that so clearly has an impact on location.


(Scott Tuck) #17

Same issue with presence here. Worked great before the Oreo/8.0 update.


(Russell B) #18

My phone is completely up-to-date, including Play Services. Battery life is excellent, but that is due to the fact that Oreo seriously hinders apps running in the background, like SmartThings. I should be able to override that somehow and tell the OS to allow the level of access that I want.


#19

Just fyi GP services was not updating on its own. I had to go side load it my self. Yours very well could be up to date, noting just in case it was like mine.


#20

This is concerning because I pre-ordered a Pixel 2 XL, which should be arriving by the end of October. Hopefully an update or work around will be possible by then. This sounds like the same issues people had with IOS 11.