App Just Deleted All of My Devices/Routines

So, I was having issues with some of my inovelli light switches after this most recent change where cloud based handlers have been turned off. I updated to the new edge drives at inovelli’s suggestion and created a bunch of new routines to get things working again. (I hate this new system btw.)

I saw that I had old device handlers and devices so I was deleting some of them no problem. Then in the “no rooms assigned” category I had an old Harmony Remote hub that was still connected. Haven’t used it in 2+ years so I went to delete it. When I did the app acted funny and then all of a sudden when the icon stopped blinking, all of my devices and routines have been deleted. Off both mine and my wife’s phone. I tried to log off and log back on, nope. Tried deleting app and logging back on. Nope.

If I truly have to start from square one, this will be my final straw and I will move on to another hub/platform. This has been the most frustrating year with all the little tinkering I had to do get this thing to work and every few months another change causing me to have jerry rig it again to gain back functions.

Any idea’s or help to restore? Apologies for the rant as I’m pretty ticked right now.

Wow, hopefully they aren’t gone for good. :disappointed_relieved:

First thing to do would be to contact support if you haven’t already. They may be able to see more from their side. :thinking:

Check to see if anything shows there

1 Like

And the ST CLI as well.

Everything is gone from there as well. All rooms blank and nothing in unassigned. Also, all routines and scenes gone. Only thing still in app is the Samsung robot vacuum and 3 Samsung security cams.


wow. Sounds like you may have deleted your SmartThings hub instead of a Harmony hub. :worried:

Technically the Smartthings hub is still there and has all of my other information like home address, etc. still listed. I just noticed that sensors for my Honeywell Thermostat are still there. Those sensors connect to the Thermo and control its function and not through Smartthings … they are just ancillary for viewing in Smartthings app.

I suspect most users would do this. I would certainly.
I bang my head against a wall in frustration that Smartthings do not allow you to back up and restore your hub, and everything that comes with it.


You can’t “update” your existing switches to Edge drivers if they were still using Groovy DTH. You would have had to delete the switch, and add the switch back. Deleting the switch would cause the deletion of any Routines/Automations that included those switches, because you can’t have a partial automation. The only way to avoid that is to create dummy devices in the Routines/Automations in place of the ones you’re planning to delete.

1 Like

Yes, that is what I did. I reached out to Inovelli and followed their recommendation and instructions to “delete” the switch and reinstall them. That was not the cause of this issue. All of my switches were paired and working correctly when the app deleted everything.

ETA instructions I followed regarding installing Edge Drivers:
To install the Edge Driver, please follow the instructions below:
1 Click on the following link Samsung Edge Driver Access and sign into your Samsung account (you may have 2-Factor Authentication on – if so, please follow the directions Samsung gives you to attain a code)
2 Next, click, “Enroll” by the hub your devices are paired to
3 Next, click, “Available Drivers”
4 Finally, click on the driver you’d like installed by clicking, “Install”
To get your device to use the Edge Drivers, you’ll need to exclude them and then include them again. After you pair your switch, it should automatically pick up the Edge Driver.

1 Like

check one more spot…

  • login to IDE
  • go to the My Locations section
  • check how many Locations appear there
  • if only one, click on the Location name
  • then go the My Devices section and check if any devices show there
  • if two locations, click on one, check My Devices and check the other if needed.
  • if devices are showing in a location, check the app to make sure the proper location is selected.
1 Like

The moment you excluded them (deleted them) any Routine or Automation they were used in would have been deleted as well. It is likely the cause of the missing Routines/Automations.

This behavior is discussed here:

1 switch was used to run a scene to control basement lights. 2 button presses down turn off and up turned on. That was the only thing associated with the switch. The second switch, was associated with Vacation Lighting Director (no extra button pushes like the first).

Everything was working fine after re-pairing the second switch, and yes I know that automations would automatically be deleted with those switches. I’m having a hard time believing me deleting the Logitech Harmony Hub that wasn’t attached to any other device, routine, scene, etc. would cause now approx 40 devices (window sensors, light switches, motion sensors, flood sensors) to be nowhere to be found. I did check IDE and they are not in another “location” or hub.

1 Like

I think there’s some confusion here on the architecture and/or terminology of SmartThings. Thinking of it like a tree structure, under your Samsung account, there are SmartThings locations. The location holds your geolocation, members, rooms, etc. The next level within the location are cloud connected devices, direct connected devices and hubs. Then under the hub you have all the hub connected devices. The hub also shows as a device within the Smartthings app so you can manage its settings, run utilities, etc.

This diagram also helps explain it:

So if you can still see your account, location details, and cloud connected devices (Honeywell), I have a feeling your accidentally deleted your SmartThjngs hub thinking it was a Harmony hub which then subsequently took out all the hub connected devices with it :confused:

1 Like

Thinking I am following, but all I can go on is what I’m also seeing on my end. I’ve made some bonehead mistakes in my life, but I’m pretty sure I would not have deleted the hub. I was more shocked that the harmony device was still in there. I just did a long press on it and it came up with options, just like deleting a device/switch.

Anyway, this is what I see in the IDE if that gives any direction to you all who know more than me:

What I see under My Hubs - Home Hub (only hub I have)

What I see under My Locations - Home

One thing that did give me a glimmer of hope … I went out to dinner and when I can back, I got a push notification from Smartthings that “I’m Home” and “Security mode disarmed” when I pulled into the drive. It didn’t give me the alert that it was armed when I left, but did recognize I had left and came home.

Maybe just a false glimmer :zipper_mouth_face:

Wow… I can’t believe it’s that easy to just nuke your entire hub… that is a shocking oversight on Samsung’s part. There should be a confirmation explaining whats happening at least.

Hmm, that does look somewhat hopeful the hub is still active. If you scroll down further on that screen does it show devices paired to it? Has support provided any guidance?

I haven’t tried, but it does seem long pressing the device and tapping the trash can at least initiate the process…

No specific guidance from support yet. Late last night, they did get to me asking me to allow them access to my account/hub for 7 days and I did that on the Today I got a request to supply a screenshot of the app version, to delete and reinstall my app and to send them error logs with exact date/time. I don’t have high hopes at this point that this is salvageable. [quote=“Automated_House, post:18, topic:258931, full:true”]

1 Like