Alexa, smartthings isn't responding


(Pier-Luc Boucher) #1

Hello guys, since yesterday, I can’t control ST with my echo dots.

Alexa answer : Smartthings isn’t responding

What can we do when it happen?

thanks!


Echo Dot and Smartthings not seeing all devices it did 5 days ago
(Micheal ) #2

Are you using just native integration or another skill? Native is working for me…What are you attempting to do that isn’t working.


(Pier-Luc Boucher) #3

Native integration, in canada

Trying to turn on/off devices, launching scene…those kind of things


(Micheal ) #4

Hmmm…working well in the US. Speaking of which, however, you might want to check your settings to see if you are set to Canada or US. Toggling that might get you working again.


(Lee Lauer) #5

I am having the same issue here in the US. Any command from Alexa fails, but control from the ST app and also from Action Tiles is fine.


(Kurt Sanders) #6

Amazon Echo and SmartThings integration has been flaky over the past few weeks, with the Echo stating the phrase, “I cannot seem to communicate with SmartThings at this time.”

Interesting, if I repeat that exact same commend, she executes it.

I suspect a timeout from sending a command from Amazon Cloud to SmartThings Cloud and a missing response?


(Lee Lauer) #7

Would it be worth submitting a ticket to ST? So hard to tell where the fault could be, with ST or Alexa?


(Pier-Luc Boucher) #8

I disabled the ST skills in Alexa, enable it again / with reconnection to ST and it start working again!

Solved


(Lee Lauer) #9

Thanks for the tip, that worked perfectly!


(vlad) #10

Sorry chiming in a bit late but its always worth putting in a support ticket when you run into issues (if you want to that is). Especially things like this where it seems like just your account is having an issue, (Include any times, apps, etc…) we may not know about the bug yet/if more people call in, more visibility, higher priority to fix (not the only metric used to judge priority) but engineering frequently meets with Support to go over submitted issues.


(Alex) #11

@vlad - I guess then I need to open a ticket as I have been having this issue for many weeks now and it is getting old. Alexa always says that ST is mot responding when I try to trigger an ST scene but most of the time she actually executes it. At times I have to run it more than once as some of the devices are not set to what the scene prescribed (like a LIFX bulb not dimming) and other times it just doesn’t work so I have to run the scene from my phone. Even running the scene from the phone sometimes requires more than one trigger.


(vlad) #12

Please do - we don’t get many reports of issues for Scenes so would be good to try and track this down. The main issue I am aware of is in certain cases we have seen race conditions between sending device commands - there is a fix going out tomorrow that should help with that (could cause a light to not set the level correctly) though it sounds like you are seeing something that occurs much more frequently than the issue I described. I am an engineering lead for one of the teams that makes scenes work - will be on the lookout for a ticket. Would be best to provide the time the issue occurred, what happened, and the name of the device (if ST responded at all) that didn’t set state correctly.


(cjcharles) #13

I had the same thing happen to me a couple of times today (about 7pm UK time). Ended up doing it with the ST app, though the ST app took about 20s to load aswell, and I had to force close it once to get it to show anything (on Android). There is definitely something funky going on!!


(Alex) #14

@cjcharles - starting from the last Android app update, I too have very slow loading of devices in certain instances. I am using a Galaxy Note 8 and if I kill all applications and then open ST, it takes 10 seconds on wifi and 14 seconds on LTE to just show me a populated “Things” tab. It used to be much faster not too long ago. I believe the moment it became worse was with the latest app update. I believe this is not the only instance where it takes a long time to load but the only one I could reproduce reliably right now. Also, I am currently not at home so the delay may be somewhat different (feels longer but that may be due to urgency to get something done) even though my latency and throughput on wifi at home is multiple times better than where I am at right now.


(Alex) #15

@vlad - The scenes we use the most are “Kids Bedtime”, “Night Night” and “Wakee Wakee” which are all related to the various stages of getting my 1yr old and 2.5yr old in and out of bed. Triggering them using Alexa is the most convenient if it works reliably so we don’t have to fumble with the phone while struggling with a toddler refusing to go to sleep… Having to ask multiple times, having to wait, and having to pull out the phone, just causes extra drama each night. I will try to record the times tonight so I can provide those. When the scene actually triggers, it is always the LIFX bulb (Kids Bedroom Table Lamp if you want to look at my logs) that doesn’t set to the correct level (the color does change to red but it doesn’t go down to 8% unless we repeat the scene). The kids go to bed between 7pm and 8.30pm depending on how much we have to struggle to make everything happen. Since you work on scenes - I have been unable to get SmartLighting to trigger scenes upon pressing a button on a minimote (Kids Bedroom Minimote). The same minimote used to control specific devices using a custom DTH, but I am now trying to use the ST provided one and controlling devices or scenes with each button. None work. Excluding and Including back did not fix the issue either. The remote was to help us trigger scenes when Alexa failed, or just to replace doing so with Alexa given the issues.


(cjcharles) #16

Indeed, it does seem random when it happens, and every time I check and the internet is perfect so it must be server related. Excited friends taking a look get rapidly bored when they see the lack of response and force killing the app!!

If relevant then I am using a Samsung S8, though I dont think it will be since the problems also happen with Alexa giving up. I dont use scenes at all (for the moment).


(Alex) #17

The relevance is in the processor speed. I always see some improvement when I jump phone generations however I was not saying that the long delay in this case is due to the phone as the slowdown in loading the ST tabs started after the latest update. Maybe it is some sort of caching issue… I wonder whether nuking the cache might help… I’ll give it a try.


(vlad) #18

I’m in the central time zone and should able to hop on tonight (though it’s easy to pull wife aggro working on Friday nights). At the very least I can look through cloud logs and see if anything out of the ordinary is happening. Just let me know when you start running this stuff and if your login is different from the forum please send it to me via DM.


(Jason Holling) #19

We are having issues too in the last few days with lights taking 20 secs to respond when turnin them on…or they just never turn on.

Google will say “ok” like it’s trigger the lights to turn on and nothing happens. Running android phones, GE zwave switches, and google home. Reboot the hub and lights will turn work as expected.


(vlad) #20

Forgot to follow up here as @aruffell and I continued our discussion over dm. By looking through his logs I was able to find an issue with Alexa (not just Alexa, all Scene integrations apart from manually actuating the scene) and our Scenes service, specifically when a request took longer than 5 seconds to complete the connection would automatically timeout to prevent blocking threads of executions in the core part of the platform, this was an oversight when we set up monitoring for the apis so we weren’t alerted to these errors. Scenes with a significant number of devices or devices that are part of a cloud to cloud integration (such as lifx) are more likely to be effected. We will be making a few changes to mitigate these issues:

  1. Increase the timeout so execution requests to the scenes service will not terminate in the event of a longer running scene
  2. Change the calls involved to be asynchronous instead of synchronous to reduce blocking threads of execution

I’ll update this thread again when either of these changes go live but they should reduce the frequency of Alexa errors when executing scenes.