Aeotec Smart Home Hub/2018/2015 Model Hub Firmware Release Notes - 0.53.19

UPDATE: The release of this firmware version is extending a couple of days past the original estimate. The post below has been edited to reflect this.

Last year we announced two new hub features — Hub Groups (multi-hub networks), which let users extend their Thread and Zigbee networks across multiple SmartThings hubs to create a stronger mesh; and Hub Replace, which enables users to upgrade their hubs, so their smart homes can grow with them. With this release, we are expanding hub groups functionality with hub backup. To access the hub backup feature in the SmartThings app, an app version of 1.8.17.x (Android) / 1.7.17.x (iOS) or higher is required.

We will begin rolling out Samsung SmartThings Hub firmware version 0.53.19 starting Thursday, June 20th. Once downloaded, your Hub will briefly go offline as it reboots and applies the update; most customers will experience less than one minute of downtime. We will update the status page when the release is complete.

Hub Target:

  • Samsung SmartThings Hub 2015 (Hub v2)
  • Samsung SmartThings Hub 2018 (Hub v3)
  • Aeotec Smart Home Hub

Release Date: 20 June 2024 ~ 03 July 2024

Note that this release will be spread out over multiple weeks, so you may not see your Hub update on the first day of the release period. This release period is an estimate, so the rate of hubs updated and final completion date may vary slightly within the timeframe. Please check the status page for more up to date information on this release.

Release Notes


  • Hub Backup - a new feature of Hub Groups which increases resiliency by allowing secondary hubs to act as a backup if your primary hub goes offline. If that happens, you’ll get a notification that your hub has disconnected, along with help to diagnose the issue. If the connection can’t be restored, users will be able to select another hub in their Hub Group to serve as a new primary hub, transferring all devices and routines, if supported by the receiving hub.
  • Matter SDK upgraded to version 1.2.
  • Updates were made to the Zigbee and Thread stacks for Aeotec and V3 Hubs only.
  • Fixed a bug that causes sleepy Z-Wave devices to be incorrectly marked offline in some cases.
  • Fixed a bug that causes sleepy Zigbee devices to be incorrectly marked offline after a Hub replace operation.
  • Fixed a rare bug where the Zigbee device firmware update status does not reflect that an update is happening when manual updates are enabled.
  • Changed Zigbee firmware updates to timeout after 30 minutes if the device has not started to download the update.

Edge Drivers

  • Matter 1.2 device type support.
    • Refrigerators
    • Room air conditioners
    • Dishwashers
    • Laundry washers
    • Robotic vacuums
    • Smoke and carbon monoxide alarms
    • Air quality sensors
    • Air purifiers
    • Fans
  • Fixed a bug that could occasionally cause duplicate configure calls for Zigbee devices on driver start.
  • Fixed a bug where Zigbee devices may not have logged sent messages.
  • Fixed a bug where Z-Wave fallback and error handlers were not supported.
  • Various minor optimizations.

The Station isn’t one of the targets for this update?

1 Like

The Station hasn’t been included with the v2/v3/Aeotec hubs firmware updates in the past but it is usually not far behind :slight_smile:


I just think it’s going to be really weird if someone with a V3 hub can add matter devices like window air conditioners and robot vacuums and someone with just a station cannot. :thinking:


Turns out the new firmware is not needed for the new matter devices, they made the drivers backwards compatible with 0.52.x versions by adding the new library code directly in the drivers code.


Please check out the ST Application stability/performance.

All my devices show unknown in the app, there is no status from the main page of the app for my entire home. I cannot control them, every time I try to access any of the devices it shows “Can’t connect to the device”

If I login into “” I can see all the devices show the correct status and control them. So, there is an issue with the application on Apple IOS?

I have rebooted the hub V2 and uninstalled the ST app twice. I did “reset” the app, and still nothing. Please check the ST app connections

Since the rollout started most iOS app users are reporting losing all access to all devices on the SmartThings app. Is this being caused by the Firmware updates or a new unrelated issue ?

1 Like

Unrelated. I don’t have any of these hubs and am having the app issues.


It appears this update has impacted how low battery devices appear in favorites (they don’t any longer)

Not sure if it’s the firmware update as I’m still on 000.052.00021 and the Offline devices is not showing along the top row in Favourites either. How to bring these back, SmartThings?

It is not related to the firmware update but it is a cloud issue which appears to affecting many users. Look for the recent threads on the iOS and Android apps to find others reporting the issue.

1 Like

Has the latest firmware started to rollout yet? Or had it been deleted

Check the status page for any updates… if it gets delayed… it would be posted there :slight_smile:

Yes I always check the status page, but SmartThings never seem to update it with issues.

1 Like

For firmware updates… they post for delays and when completed they close it out

I’ve looked at the April Fireware announcement, and it took 11 days for completion. So still early days could be another week or so.


1 Like

You can sign up for Beta participation and get it before non-beta users :sunglasses: next release of course.


While not included in this notification my SmartThings Station Hub has been updated to FW 53.19. It looks like this might have happened Monday Evening eastern US time.

My two v2 hubs have not been updated and are still on FW 52.21

I initially saw that the ST Station update to 53.19 in the Advanced Web App. The mobil app was still showing 52.09. I had to reboot the ST Station to get the AWA and the mobile app to both show 53.19.

So if you are looking to see if your FW was updated check in both the mobile app and the AWA.


My Station just updated to 53.19, I think just last night.

The reason is I had 2 routines; one that during the night while charging a device the hub status light would turned off as to not disturb myself with it’s bright blue color and two when nothing was charging no matter the time would turn back on so I knew the status of the hub. As of last night these routines have quit working.

Another thing, I tried to go into the Station settings and uncheck the Hub Status Light setting to bypass these routines, but it won’t let me change this setting anymore. I also tried this on another Station I have and it too won’t work, this one also just got updated to 53.19.

Could any if you have a Station(s) confirm or deny if their Station(s) are also having this issue.

1 Like