Aeotec Smart Home Hub/2018/2015 Model Hub Firmware Release Notes - 0.41.08

We will begin rolling out Samsung SmartThings Hub firmware version 0.41.08 starting Monday, January 31st. Once downloaded, your Hub will briefly go offline as it reboots and applies the update; most customers will experience less than one minute of downtime. We will update the status page when the release is complete.

Hub Target:

  • Samsung SmartThings Hub 2015 (Hub v2)
  • Samsung SmartThings Hub 2018 (Hub v3)
  • Aeotec Smart Home Hub

Release Date: 31 January 2022 ~ 4 February 2022

Note that this release may be spread out over a week, so you may not see your Hub update the first day of the release period.

Release Notes

Edge Drivers

  • Fix for Zigbee devices with the Power Meter capability reporting power levels that were off by a factor of 1000 (incorrect conversions between Watts and Kilowatts)
  • Fix colorTemperature rounding inconsistencies
  • Fix a bug where updating a crashing driver could sometimes lead to a driver becoming stuck in an unrecoverable loop
  • Fix an issue with Zigbee-backed edge drivers sometimes failing to configure in a rejoin situation (e.g. after factory reset)
  • Fix for stale tcp socket connects timing out and killing the driver process
  • Edge Driver Enhancements for Development
    • Add AnalogInput Zigbee cluster to the library
    • Allow usage of the “visibility” field for edge driver events.
    • Add Particulate Matter 1 constants for Z-Wave Multilevel Sensor Command Class

General

  • Reduce CPU and Memory consumption in various components
  • Other minor bug fixes and improvements
16 Likes

Hi,
Could you please elaborate a little about this one?
Thanks

1 Like

It seems to be in the best SmartThings tradition of the engineers not being aware that the users haven’t been told about stuff. As far as I can see even an absolutely critical thing like the state change flag for emitted events isn’t documented.

It would be tempting to think of it like the Groovy ‘displayed’ flag but who knows?

3 Likes

Nothing has changed;
I always have to multiply the power meter value for 10 to have the right value …

Firmware version 000.041.00008 has arrived for me some time in the last few hours. All ok so far.

My v2 hub did not come back immediately after the update.

My devices in my Grafana were offline for some 90 minutes.

Then I remembered the firmware update email notification. On checking the hub the red LED was blinking, and I dithered whether to risk rebooting or not. I rebooted the hub and it came back.

It was the first time I had to reboot after a firmware upgrade.

I am having a problem with my v2 hub since this update, yesterday. My smart lighting routines no longer turn on my multiple GE zwave wall switches or zwave outlet. Oddly, if I go over and manually turn on one of these switches after the turn on time, that switch turns on as well as the other z-wave switches that were sent the turn-on command from the routine (but didn’t turn on at the time sent by the hub). Does anyone have any suggestions to fix this? Thanks, John

2 Likes

Have you tried using Routines instead?

1 Like

Thanks. No, I haven’t tried routines. I am not a power user. Are there any advantages to using routines?

Just wanted to see if the issues affected Routines as well. I should point out that Smart Lighting will be phased out when ST ends support for groovy on their platform.

2 Likes

Thanks. I don’t currently use routines but will research how to use them.

Should Smartthings Wifi also receive this update? Mine is crazy. I am not able to add removed items, and also not able remove these items in API website.

API website error message includes “…amazonas:3310. Connection timed out”.

The same thing happened to us, John. All our Smart Lighting automations stopped triggering on Tuesday after we received this update.

I deleted the Smart Lighting app, intending to recreate it, but Smart Lightning wasn’t even an option.

Made the routines instead and looks like that was the right call from @jkp.

The hardest adjustment was the sunrise / sunset, actually: turns out these need to be separate routines. Trying to put it in one (on at night; off in day) forced us to add extra conditions. By separating them into two routines, no extra conditions needed.

And we finally saw the little :house: icon for local automations. Fingers crossed but looks promising so far.

My only other comment: is there a reason I have to set every light individually? Perhaps better for another thread. Adding “45% dim” to each bulb is a little tedious. :smiling_face_with_tear: Will research this.

EDIT: ah, we can make scenes…

Thanks for the info ikjadoon.

Paul, i am away from the unit most of today and will try to get that info for you tonight. Thanks

1 Like

You’re welcome, John. Routines are relatively easy to create. Open SmartThings > Automations tab at the bottom > “+” at the top right > “Add routine” > I selected custom (instead of discover) and worked from there.

However, I was wrong in claiming Smart Lighting was removed. It’s still there! It’s just at the very bottom of the Discover tab. However, now that I’ve made the routine, I may leave it as such and see if the issue reproduces; it seems Routines will be the new method going forward.

Hat tip to @JDRoberts on noting where Smart Lighting now resides:

So far, the 1/1 timed routines has already worked, so a good sign on that front.

1 Like

Smart lightning is not working with sunset anymore and normal routines sunset is limited until an hour earlier or later and a power monitoring outlet in a routine won’t be saved locally anymore.
In smart lightning sunset earlier is not possible anymore because you cannot select a minus.
Firmware updates should improve things and not disrupt it I hope it will be corrected in the next update.

Jeffrey

1 Like

edging myself waiting for this hub to be sold in America…chips are gone.

Ikjadoon: I have started to add Routines to replace my Smart Lighting apps and the Routines are running successfully. Thanks again for your help!

2 Likes

Lighting automation no longer works for me as well as of 2/1. Tried deleting and redoing the setup, upgraded app, and cycling power multiple times on device. Also, one Leviton Z-Wave disappeared and the app says my hub doesn’t support Z-Wave, despite it did the day before and all my other devices are still present and working.

Switch over to Routines.

Login to IDE at https://account.smartthings.com go to the Hubs section and check if the z-wave state shows Functional. If not, click on view utilities further down on that screen and from there you can enable z-wave module. If still not functional… contact ST support.

2 Likes