Aeotec Smart Home Hub/2018/2015 Model Hub Firmware Hotfix Notes - 0.45.11

For now I have solved it by buying a new hub. On one hub I have all the Zigbee devices and on the other the Zwave ones. For now everything works fine.
Fortunately, all my automations are between devices with similar protocol, so it’s all local.

3 Likes

I think it maybe the solution for me too, but waits too see what SmartThings team are up to.

yeah, i’m very interested to see how this memory issue plays out. For the longest time we’ve been told the lower spec hardware on the V3/Aeotec hub vs the V2 wasn’t a concern since V2 never used more than a very low % of resources. Maybe things will improve once Groovy is totally removed?

3 Likes

I ended up removing one Edge driver and related virtual hub i wasn’t using, to clear up my memory issue.

I may still end up moving some other devices with more complicated automation needs to my Hubitat hub.

I don’t think it’s a memory issue. My v.3 does not report full of almost full memory yet only ZigBee devices go offline randomly. I have tried deleting drivers, devices and re installing but no improvement.

A post was split to a new topic: [ST Edge] Z-Wave devices going offline

I think it’s two different issues getting mixed up in the discussion. Two distinct problems:

  1. Zigbee device reliability
  2. Memory full messages preventing new device from being onboarded (and mayb hub power cycle?)
3 Likes

For example @pilone For example he has many zigbees that disconnect (as I had later solved with 45.11) but also continuous disconnections and reconnections of the hub. He doesn’t have many drives or devices, so it can’t be a memory problem.

This is a mess. You may be right however, these ZigBee devices that go offline are the most reliable I have (Smartthings/Aeotec and Securify Peanut Plugs), all UL-certified devices and I’ve gone thru many different brands throughout the years.

The “Zigbee device reliability” mentioned is a platform issue introduced in the same hub update where they turned on Thread. It can affect any Zigbee device of any brand. It’s not about the reliability of any individual device, it’s about your Zigbee network not working reliably because of changes SmartThings made to hub firmware.

You’ll see mentions on the official status page.

Update - Some users may experience issues with ZigBee functionality since our last hub firmware update. We are currently preparing a firmware release to resolve the issue, but in the meantime users can reboot their hubs to temporarily regain ZigBee functionality.
Oct 27, 2022 - 22:03 UTC

The thing is, this latest update was supposed to have fixed that problem. From community reports, it appears to have fixed it for some people, but not all. :thinking:

3 Likes

Is it possible these issues only started arising today?

This morning my usual routine of entering my garage, lights go on, garage door and gate start to open, didn’t work at all. Tried my Ikea Styrbar button to open the gates, nothing. Opened them using the normal openers, got in my car, drove out, pressed my smart button in the car and the doors started closing. I thought, a hiccup, no problem. Luckily my mother in law was watching the kids and noticed the garage door and gate were open when she left. So I guess after some time the commands came through and opened everything after I left. It took me about an hour to remotely close them. I can’t use the Smartthings app from where I am, so I was using Sharptools. Also one of my light sockets didn’t turn off as it should. The sensors on the gates didn’t see any movement. Now after 3 hours the sensors show the gates are closed.

Little info on the devices: Sonoff Zigbee plug, Frient sensors, Ikea Styrbar button, generic Amazon Zigbee switches for the gates and Aeotec hub.

1 Like

My Aeotec Smartthings Hub continues to experience severe problems with constant offline instabilities (Blue LED). When goes offline for zigbee module and z-wave module together. This 0.45.11 update only got worse 5 times than the 0.45.9 update. I’m losing confidence with Smartthings. Disappointed with Smartthings’ lack of transparency with its users. Automations have a huge delay of late or not executed. So far they haven’t solved a damn thing with these hub failures. When they will solve my problem, I’ve already sent a message to support, I’ve activated Account Data Access for a month. I want answers and I want them to stabilize the hub, and stop with constant blue led offline.

8 Likes

Still complete radio silence from Smartthings… what good is to have an unreliable hub/platform? Everything in this site becomes meaningless. Companies can have problems like this, it’s understandable, but the way they respond to these differentiates good from not so good companies. This also gives me second thoughts about future issues. After doing some research, I will start looking into running Hubitat in parallel, starting with ZigBee devices and see if it works for me. I don’t care about fancy stuff or eye candy app, just no frills reliability. Many of my automations involve the furnace/heating and winter is almost here. Hope they fix this ASAP or at least some information to keep some hope.

Hubitat is a great platform. Its not perfect, but it has a lot of positives. I have both Hubitat and ST.

Have you published a list of your devices you have on your Zigbee network? Both routing (line powered) and sleepy (battery) devices.

  • Are all your Zigbee devices going offline at the same time? If so, when this happens is your Zigbee radio details on the IDE for your Hub showing that its offline?
  • If only some of your Zigbee devices, is it the same ones repeatedly? I’m convinced for this situation there is a routing device that is either faulty or its the device that’s not compatible with the recent versions of firmware. If a powered routing device<->hub goes offline or wonky, it would stop repeating messages for all the child devices under it, and if the connection between the device and the wonky routing device is still responding, the child devices under its control won’t go looking for a new parent.

I have NONE of the Zigbee issues others have been reporting, so its puzzling what the issue is.

2 Likes

The devices that go offline are random almost always Smartthings branded, Securify Peanut Plugs, and Sengled bulbs all Zigbee, they go offline randomly in time and number, wired and battery powered alike, but the same devices go offline alternatingly. They are listed as OFFLINE on the IDE. Could be routing, that would make sense. They used to be the most reliable devices I had until the recent firmware updates 45.9 & 45.11

I use Ikea and Sengled Smart bulbs around our house.

I have either Ikea or Sonoff smart plugs scattered about the house as well, which act as repeaters and ensure the zigbee mesh is strong on both floors of our house (my SmartThings and Hubitat hubs are on the upper level in the center of the house).

I’ve not had any issues with either brand of bulbs during the recent upgrades (I’m part of the beta program, so I get the updates before they rolled out to the general public).

How many devices do you have?

I have approx 140 devices with Smartthings. The bulbs that are failing (3 Sengleds) I use as guide and indicator lights, not for lightning (for example when somebody is in the front porch, garage doors are open, etc, different colors turn on, on a dedicated bulb socket). My house lights are controlled via Lutron wall switches so no need for smart bulbs for lightning. These are the only smart bulbs I use; everything else are plugs, motion sensors, valves, water sensors, open/close, temp sensors, etc. I would say my ZigBee network has to be strong, since I build it up starting from the basement where the hub is, with 2-3 wired ZigBee devices (also repeaters) per room and no more than 5-10 feet apart from the next ZigBee device.
I should also add everything was working perfectly for the last 3+ years. Very reliable until few weeks ago.

Since the release notes for the most recent platform update say specifically that they include a hot fix for a platform issue with zigbee from the previous release, I would say the problems people have been reporting are not just repeater issues.

Identified - Some users may experience issues with ZigBee functionality since our last hub firmware update. We are currently preparing a firmware release to resolve the issue, but in the meantime users can reboot their hubs to temporarily regain ZigBee functionality.

I’m glad to hear that you haven’t had any problems, but there was an acknowledged architecture issue with Zigbee recently that did affect a number of customers.

Since the update that was supposed to fix that Zigbee problem was released (the one covered by this thread), some customers who were previously affected said that not only were the problems not solved, in some cases they had gotten worse. :scream: So the current open question is whether that is also an architecture issue, or whether something else is going on for those individual customers. :thinking:

1 Like

We don’t know your house, so we have no idea how many rooms you mean. 2? 20?

I would say a good rule of thumb for repeaters is 1 for every 4-6 devices in a room. Some repeaters are better than others. For instance, the IKEA repeaters can only handle 6 child devices max due to limited memory.

The guys on the Inovelli forums are having issues on the current firmware for Blue 2-1 switches when mixed with Sengled bulbs. If the switch is acting as the nearby router, the bulbs keep falling off. Switching to another brand of bulb solves the issue. Inovelli is on the case and will fix the issue soon, just thought that was interesting note on Sengled. Perhaps they are more sensitive to timing than other brands.

I personally have 6+ Sengled Zigbee bulbs and have not had an issue on them on ST.

1 Like

My problems seem to be fixed. Since Saturday the Ikea button, my Sharptools rules for me leaving, work flawless again.

Weird thing about this was, my lighting in my house and relevant automations all worked. Only the devices and rules I had for my garage in my backyard stopped working. So I guess it might have been a routing issue, but since I changed to Zigbee at the start of this year and added repeaters in my backyard I didn’t have a single issue. Since it’s all fine again now, I don’t think it’s a repeater device issue that occurred. Don’t know if there was another update last Saturday, but either way since then all issues seem te be resolved.

1 Like