Aeotec Smart Home Hub/2018/2015 Model Hub Firmware Hotfix Notes - 0.45.11

I had almost all devices go offline after the update to 45.11
After a reboot and about 40 minutes they came back.
That was Last Friday.
It happened again today, not all devices offline but maybe 30% of them.
another reboot and another wait of about 40 mins and all but one ikea zigbee outlet are back online.
Any sign of RCA or workaround for this (workaround other than reboots)

Reliability has been excellent the last 6 months and I would hate to have to do random reboots to recover.
Weather is getting colder now and I’m using ST to control heating so it’s beyond a minor inconvenience.

1 Like

What’s the memory situation like on your hub?

Wondering if your memory is full and the hub is unloading drivers to clear memory.

Go to your devices tab and press the + and select Add Device.
Pick any device type from the list, press the Start button once available.

You may see something like this:


Tried as you suggested and picked an osram light . This is what I see, no messages about memory warning

Press the start button.
Next page will show whether there’s a memory issue.

2 Likes


Looks ok ?

My HUB changes between full and almost full, so I think I’m on the edge so may say.
I have 167 devices thats inclusive virtual switches and 19 active edge drivers.
Yesterday I had to delete 4 edge drivers and 8 devices to get a stable HUB from disconnecting randomly. So far no more disconnects and delays in automations.

I’m in a similar boat. I have 120 devices, 28 drivers and about 50 automations. The move to everything being local is fine, but my hub is now out of memory. And I’m not done. I want to add another 30-odd devices.

Is Aeotec planning to release a souped-up hub with more memory, or do I add a second hub? I like SmartThings and don’t want to migrate to HA or another platform.

For now I have solved it by buying a new hub. On one hub I have all the Zigbee devices and on the other the Zwave ones. For now everything works fine.
Fortunately, all my automations are between devices with similar protocol, so it’s all local.

3 Likes

I think it maybe the solution for me too, but waits too see what SmartThings team are up to.

yeah, i’m very interested to see how this memory issue plays out. For the longest time we’ve been told the lower spec hardware on the V3/Aeotec hub vs the V2 wasn’t a concern since V2 never used more than a very low % of resources. Maybe things will improve once Groovy is totally removed?

3 Likes

I ended up removing one Edge driver and related virtual hub i wasn’t using, to clear up my memory issue.

I may still end up moving some other devices with more complicated automation needs to my Hubitat hub.

I don’t think it’s a memory issue. My v.3 does not report full of almost full memory yet only ZigBee devices go offline randomly. I have tried deleting drivers, devices and re installing but no improvement.

A post was split to a new topic: [ST Edge] Z-Wave devices going offline

I think it’s two different issues getting mixed up in the discussion. Two distinct problems:

  1. Zigbee device reliability
  2. Memory full messages preventing new device from being onboarded (and mayb hub power cycle?)
3 Likes

For example @pilone For example he has many zigbees that disconnect (as I had later solved with 45.11) but also continuous disconnections and reconnections of the hub. He doesn’t have many drives or devices, so it can’t be a memory problem.

This is a mess. You may be right however, these ZigBee devices that go offline are the most reliable I have (Smartthings/Aeotec and Securify Peanut Plugs), all UL-certified devices and I’ve gone thru many different brands throughout the years.

The “Zigbee device reliability” mentioned is a platform issue introduced in the same hub update where they turned on Thread. It can affect any Zigbee device of any brand. It’s not about the reliability of any individual device, it’s about your Zigbee network not working reliably because of changes SmartThings made to hub firmware.

You’ll see mentions on the official status page.

Update - Some users may experience issues with ZigBee functionality since our last hub firmware update. We are currently preparing a firmware release to resolve the issue, but in the meantime users can reboot their hubs to temporarily regain ZigBee functionality.
Oct 27, 2022 - 22:03 UTC

The thing is, this latest update was supposed to have fixed that problem. From community reports, it appears to have fixed it for some people, but not all. :thinking:

3 Likes

Is it possible these issues only started arising today?

This morning my usual routine of entering my garage, lights go on, garage door and gate start to open, didn’t work at all. Tried my Ikea Styrbar button to open the gates, nothing. Opened them using the normal openers, got in my car, drove out, pressed my smart button in the car and the doors started closing. I thought, a hiccup, no problem. Luckily my mother in law was watching the kids and noticed the garage door and gate were open when she left. So I guess after some time the commands came through and opened everything after I left. It took me about an hour to remotely close them. I can’t use the Smartthings app from where I am, so I was using Sharptools. Also one of my light sockets didn’t turn off as it should. The sensors on the gates didn’t see any movement. Now after 3 hours the sensors show the gates are closed.

Little info on the devices: Sonoff Zigbee plug, Frient sensors, Ikea Styrbar button, generic Amazon Zigbee switches for the gates and Aeotec hub.

1 Like

My Aeotec Smartthings Hub continues to experience severe problems with constant offline instabilities (Blue LED). When goes offline for zigbee module and z-wave module together. This 0.45.11 update only got worse 5 times than the 0.45.9 update. I’m losing confidence with Smartthings. Disappointed with Smartthings’ lack of transparency with its users. Automations have a huge delay of late or not executed. So far they haven’t solved a damn thing with these hub failures. When they will solve my problem, I’ve already sent a message to support, I’ve activated Account Data Access for a month. I want answers and I want them to stabilize the hub, and stop with constant blue led offline.

8 Likes

Still complete radio silence from Smartthings… what good is to have an unreliable hub/platform? Everything in this site becomes meaningless. Companies can have problems like this, it’s understandable, but the way they respond to these differentiates good from not so good companies. This also gives me second thoughts about future issues. After doing some research, I will start looking into running Hubitat in parallel, starting with ZigBee devices and see if it works for me. I don’t care about fancy stuff or eye candy app, just no frills reliability. Many of my automations involve the furnace/heating and winter is almost here. Hope they fix this ASAP or at least some information to keep some hope.