Aeotec Smart Home Hub/2018/2015 Model Hub Firmware Release Notes - 0.44.09

We will begin rolling out Samsung SmartThings Hub firmware version 0.44.09 starting Monday, August 22. Once downloaded, your Hub will briefly go offline as it reboots and applies the update; most customers will experience less than one minute of downtime. We will update the status page when the release is complete.

Hub Target:

  • Samsung SmartThings Hub 2015 (Hub v2)
  • Samsung SmartThings Hub 2018 (Hub v3)
  • Aeotec Smart Home Hub

Release Date: 22 August 2022~ 26 August 2022

Note that this release may be spread out over a week, so you may not see your Hub update the first day of the release period.

Release Notes

General

  • Add recovery mechanisms for degraded system performance
  • Other minor bug fixes and improvements

Edge Drivers

  • Fixed a bug that was preventing cosock.channel from timing out
  • APIs that would previously crash the driver when timing out will now gracefully time out with a more helpful error message
  • Addressed a memory leak when using the tcp/udp sockets
2 Likes

This one is going to be great! Should resolve the “deep sleep” reports that are actually caused by garbage collection that occurs when an event is first sent to the driver after a long period of inactivity.

4 Likes

So we are still not including wifi connect hubs as well in firmware roll outs? I would think now that they were recently updated to match the same firmware, we wouldn’t have to wait a long time for future updates.

and since today my Zigbee network just down for 3 hours. my ZigBee devices are blinking like they have lost the hub , can’t neither control not re-connect any of them.

@nayelyz… is there any idea when Samsung Connect Home/SmartThings WiFi Hub will receive the update?

2 Likes

One of my routines I think is cloud executed at the moment isn’t triggering. It’s a routine that turns on a switch if humidity is greater or equal to a threshold value. Was working yesterday. I tried recreating it, but it’s not working. Is my issue related to the platform update? My hub firmware hasn’t update yet.

Why recreating it isn’t working? Do you mean you got an error or that it still won’t trigger?
Have you checked the IDE to see the “Last booted” date? Some have reported that a power outage (which also happens during the update) caused issues with the routine’s execution…but you should have the firmware update if it were related.

My hub is still on the 0.43 firmware. Weird, I checked and the routine finally triggered.

Thought it was a fractional issue, but the routine trigger accepts decimal values (I think). Not sure what the issue was.

I am now confused! I have many ZWave appliances and thermostats that no longer will allow remote access. Is this update going to rectify this issue? All of my ZWave thermostats are now useless. Also, why does a firmware update take a month to perform. It only changing lines of code after all, so why a full week to complete? Thanks

1 Like

It’s standard practice for developers to roll out changes in waves in case they encounter an issue. They don’t just flip the switch and cross their fingers.

1 Like

image

I kid, I kid… I know when things don’t work its frustrating. Just trying to lighten things up. :smiley:

2 Likes

Hi, @allmac
The support for the Samsung Connect Home/SmartThings WiFi Hubs will continue. However, there’s no ETA on when there will be a firmware update.
When this happens, it will be announced in this section (Hub Firmware Release Notes) as well.

1 Like

Thanks for your he response blue eyes!
Dennis

Confirmed that this did in fact address the waking GC bug. Good work ST team :+1:

CC: @robert.masen

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.