Aeotec Multisensor 6 , humidity & Lux update interval


I have just purchased a Aeotec Multisensor 6, I have used the Android app to set the Sensor Report Interval to 8 minutes, thinking that this would update the Temp/Humidity/Lux every 8 minutes. However it doesn’t update the Temp/Humidity/Lux periodically, can anyone explain why it is not finctioining as I think it should and how I can fix it?

Many Thanks

Are you using the official device type? From my reading its broken. Check out this thread Aeotech Multisensor 6 (gen 5 zwave plus, model ZW100-A)

Use this device type

I’ve been using this for awhile now with great success. I have mine reporting every minute with a pir reset of 10 sec. Just be careful on what you choose for a reporting interval as it will effect battery life. Hope this helps.

Hi Jay,

Thanks for the reply, I have added the code from GitHub to the IDE and got the sensor to work a lot better, many thanks.

Though when viewing the sensor in the Android app (My Things/ Right Now) there is a Config button that doesn’t appear to work? I have been able to change the settings via the Edit menu ( after pressing the icon with 3 dots) Just curious if you got the config button to work?

Thanks again.

No problem glad it’s working better. The config button is used to save the settings to the aeon. If ur running on usb then the device is always awake, if on battery you only have a small window to set the setting and then hit the config button. Also with battery youll probably have to tap the button on the back of the sensor to wake it up and then send the settings. Go back to your edit device in the top right and see if your settings took, if not change them again, back out and hit config. You can also turn on live logging and see if it show’s parameters sent and set. I really wish smartthings would create a working device type so we can get this running locally.


Thanks for the config button explanation. I believe the config has been excepted by the multi sensor but it still doesn’t report the Lux/Temp/UV every 60 seconds like I would like. here is an extract from the log:

9a927876-c02c-448b-83bb-a561c4b3d8c8 9:32:02 PM: debug —VERSION REPORT V1— Special Aeon Multisensor 6 is running firmware version: 1.6, Z-Wave version: 4.5

9a927876-c02c-448b-83bb-a561c4b3d8c8 9:32:01 PM: debug settings: [‘debugOutput’:‘true’, ‘tempoffset’:0, ‘humidityoffset’:0, ‘luminanceoffset’:0, ‘ultravioletoffset’:0, ‘PIRsensitivity’:1, ‘MotionReset’:20, ‘ReportingInterval’:60], state: [‘lastbatt’:1451338018180, ‘fw’:‘1.6’, ‘configured’:‘true’, ‘sec’:1, ‘debug’:true, ‘MSR’:‘0086-0002-0064’]

9a927876-c02c-448b-83bb-a561c4b3d8c8 9:32:01 PM: debug Prefernces settings: PIRsensitivity: 1, Reporting Interval: 60, Temp offset: 0, Humidity offset: 0, Luminance offset: 0, UV offset: 0

9a927876-c02c-448b-83bb-a561c4b3d8c8 9:32:01 PM: debug --Sending configuration command to Multisensor 6–

Go to live logging and see what happens there. You should see an update every min. For some reason if your watching the recently tab in the app it only updates every min if the values are changing quickly. For example, I’m using this in my bathroom and once in the shower the humidity is rising quickly and I can see an update in the recent tab every min. Regardless though you’ll see that all the values are reporting every min in live logging.


This is the first time I have published a custom device type so please bear with me. I published Aeon Multisensor 6 - RV 2.2 and it looks like it is working but the format in the device settings on my app looks strange. Below REPORT DATA INTERVAL are 3 setting with no listing.

Is this normal?

Also I just noticed that if I change 1 setting and hit done I receive an error message that says PLEASE FILL OUT ALL REQUIRED FIELDS.

Thanks for the code - I’ve just taken receipt of this device and couldn’t work out why it wasn’t working as advertised. I thought it was fully compatible with ST ‘out of the box’ - so I searched on here and found this thread.

Hope someone can help with the following:
How do I change from Fahrenheit to Celsius?

EDIT - I’ve worked it out. I had no idea it was a top level system setting (under My Locations). Thought it was device specific. Done.

I had this also, if you edit the settings through the ide first then save then head back to the app it works.

Another point to note is this device code changes the light from green to blue to say its all ok, so don’t fret if you no longer see the green light. :grin:

Does anyone know how to adjust the temperature +8 degrees and the humidity -14 in the IDE.
I made a custom device handler but couldnt find it…