Aeon Multisensor 6 Reporting Time


#1

First and foremost, this is my first post and have been reading and learning from this amazing community. A giant thank you to all of the contributors here.

My issue is getting my Aeon Multisensor 6 (http://aeotec.com/z-wave-sensor) to report every 10 minutes.

I’m using this device handler linked from the manufacturer’s website and followed the install instructions carefully: https://github.com/robertvandervoort/SmartThings/blob/master/Aeon%20Multisensor%206/device_type-aeon-multisensor6-v2.2

There is a “Report Data Interval” preference which I’ve set to 600; however, my sensor is only reporting (humidity is the one I’m after) once every hour.

Is there another value in the device handler that needs to be updated so that it reports more frequently than every 60 minutes?

Thank you!


(Eric M) #2

Yes, if the device is battery powered, then the “Report Data Interval” parameter will basically only accept values of 60 minutes or above. You have to adjust the “wake” interval. Looking at the device type it seems like it is set to “wake” every 5 minutes though:

zwave.wakeUpV1.wakeUpIntervalSet(seconds:300, nodeid:zwaveHubNodeId)

Maybe this value did not take. If you change that to:

zwave.wakeUpV1.wakeUpIntervalSet(seconds:600, nodeid:zwaveHubNodeId)

and configure again, see if that works. Try forcing the configure to go through by double tapping the button on the back, wait a second, and then hit configure in the app. The light on the device should light up blue or green for a few seconds after you double press the button.

Also, I think the device is configured to only send reports for certain measurements if they have changed by a certain threshold. So even if the wake time is changed to 10 minutes, you may not get a report unless the threshold is met.


#3

Thanks @erocm1231 for the response. I have two Aeon Multi 6’s that I have updated using the instructions above. Both showed this event after I hit the configure button:

COMMAND | configure | configure command was sent to Bedroom Multi Sensor | true

I then put one of the sensors in a drawer (no light) and left the other where it was in the bedroom. On the same hourly interval both sent back the updates values for temp, humidity, and illuminance.

I’m not sure what to try next, and appreciate your help.


(Eric M) #4

@Pleasant30 Add the following underneath the wakeUpIntervalSet command:

zwave.wakeUpV1.wakeUpIntervalGet()

and add the following method at the bottom of the device handler:

def zwaveEvent(physicalgraph.zwave.commands.wakeupv1.WakeUpIntervalReport cmd)
{
log.debug “Wake Up Interval Report: ${cmd.toString()}”
}

If the config process is working properly you should get that log.debug info with the wakeUpInterval report. That way you can confirm that the wake up interval is getting set correctly.


#6

Thanks @erocm1231. I enabled debug mode and this is the log:

b90e79e6-397c-49e5-be65-95e2b1e15989 5:32:45 PM: debug settings: [‘debugOutput’:‘true’, ‘tempoffset’:0, ‘humidityoffset’:0, ‘luminanceoffset’:0, ‘ultravioletoffset’:0, ‘PIRsensitivity’:5, ‘MotionReset’:60, ‘ReportingInterval’:600], state: [‘lastbatt’:1455834585868, ‘fw’:‘1.6’, ‘configured’:‘true’, ‘sec’:1, ‘debug’:true, ‘MSR’:‘0086-0102-0064’]
b90e79e6-397c-49e5-be65-95e2b1e15989 5:32:45 PM: debug Prefernces settings: PIRsensitivity: 5, Reporting Interval: 600, Temp offset: 0, Humidity offset: 0, Luminance offset: 0, UV offset: 0
b90e79e6-397c-49e5-be65-95e2b1e15989 5:32:45 PM: debug --Sending configuration command to Multisensor 6–


(Eric M) #7

@Pleasant30 It doesn’t look like the configuration is going through. Are you sure the device is awake when you hit the configure button in the app? It might be a triple click on the device instead of a double click, but you should be seeing a bunch of stuff like this in the log:

"—CONFIGURATION REPORT V2—

"—CONFIGURATION REPORT V1—

and

Wake Up Interval Report:

If you added the code I suggested.


#8

Thank you @erocm1231! That worked for both sensors. Can you let me know what:
zwave.wakeUpV1.wakeUpIntervalGet()

Does? I added that to the handler, and tried doing the config process hitting the button, once, twice, and then three times. One of the above stuck for both sensors they are working great.


(Eric M) #9

That just tells the Zwave device to send a report stating what its wake up interval is set at. So if you issue the command:

zwave.wakeUpV1.wakeUpIntervalSet(seconds:600, nodeid:zwaveHubNodeId)

and then:

zwave.wakeUpV1.wakeUpIntervalGet()

You should get a report from the device showing that its wake up interval has been changed. This is how you confirm that setting has actually changed. As you witnessed first hand, just because you send a configure command to a device, doesn’t mean the device actually received the configure command. This is especially true with Z-Wave devices that sleep (most battery powered devices). If they are asleep, they won’t get the config changes.


#10

Thanks very much for your help @erocm1231.