Aeon multi sensor 6 - not working properly? Help!

I just bought an Aeon Multi Sensor 6 and installed it through ST through the menu on the app. It doesn’t seem to be working properly. It detects motion but I put in a warm room (it showed 25 degrees) and then put it in an upstairs bathroom. After forty minutes it showed the temperature as 19.2 degree and hasn’t changed (it is much colder in there). The humidity is showing 51& and stayed that way even though I ran a hot shower for ten minutes. It hasn’t changed. I set the interval reporting time to 10 minutes. Do I need to install some code - eg a device handler? Fairly new to this and learning as I go along. Also the “tamper” sensor doesn’t seem to be working.

A couple of questions:

  1. What device is the sensor type within ST?
  2. Are you using two batteries or the USB power?

It seems to me that you are expecting readings to occur sooner than they are. The temp and humidity readings may be off but you are not saying what they should be. I would measure with another device to compare to the AeoTec.

Battery powered is not real-time and based on a polling interval. Looking at my logs temp and humidity tends to be hourly unless there is a drastic change.

Yes - it looks as though they are hourly. Having ran the shower it now shows 79% humidity but as you say it is only updating every hour. It shows as an Aeon Multisensor 6 and a multipurpose sensor. I was planning to use it to turn the bathroom extractor fan on when the humidity rose when someone had a shower but I guess this won’t work if it only updates the humidity every hour. I am using it off batteries. If I run it off mains USB will function in real time?


Yes, if it is powered by USB it will update in real-time. I believe you can adjust the interval. I am researching if I can use CoRE to measure the humidity when the light is on and then if the humidity goes up run for 30 minutes.

I have a few and found them to function best off USB power.

One when using the battery started acting really goofy and would continually report motion even when there was none, another did not work at all. Per the mfg support they felt the batteries were bad even though the same batteries worked fine in another unit.

I have x12 of these 6-in-1 room sensors, and so far so good. One thing I did with everyone of them was to update the firmware using a z stick from aeotec here. I am running v1.07 and will upgrade with future firmware as it becomes official.

The z-stick is here