Problem with AeotecMultiSensor 6 update frequency

aeotec
troubleshooting

(RT) #1

I’m having issues with the Aeotec MultiSensor 6 not updating. It updates like once an hour and I need it more like once a minute or once every 5 minutes. I’ve tried changing the parameters provided by the device controller for the reporting interval but it makes no difference. It does report motion instantly every time tho so it is communicating fine in that regard.

In the manual for the Aeotec there is a table of values that control what type of data it reports (light sensor, humidity, temperature, UV, battery). It says setting automatic reporting flags: Parameter 101-103 (4 byte code) can be configured through your gateway. Use 241 (sum of all numbers in table) to have all report. How do I set parameter 101-103?

I’ve had issue with other devices like the CT100 - same type of issue, where it only updates the humidity once every hour or so, tho it does update the temperature much more regularly. I have the devices in the same room as the hub, just a few feet away.

Any help would be greatly appreciated. Thanks.


(Tim Raynor) #2

try this thread , there’s some alternative device handlers been written in the past


(Ben W) #3

It also needs to be plugged in. I believe plugged in gives you streaming events.

Using the default Handler I got it to 8 minutes, BUT you have to wake the device in order for it to receive the new settings. Hold the back “button” for 3 seconds, then you have I think 10 minutes of it being fully awake and uber chatty.

It will also only update values on changes, but in live log you can see the messages coming through.


(RT) #4

Hi guys - thanks for the suggestions. Eventually after quite a bit of tinker I got it so its updating frequently. I’m using RV 2.2 and it works well. I’m not sure what change I made for it to start working. I tried removing the device and re-adding it, except this time in Secure Communication Mode (press the button twice to join network instead one). I also tried taking out the batteries and running on power for a while, then going back to batteries. I’m not sure which if any of these things (or some combination) helped, but I’m really glad to see it working as I need it to.

Now if only there was a good replacement for Rule Engine. I was quite surprised to see that it was pulled and I hadn’t downloaded it yet. Any good alternative? I’m using Smart Rules but it doesn’t seem as advanced.