Aeotec Button is Added to Hub but Not Working


This is the result of adding Aeotec Button to the Hub. Changing the DTH to Zigbee Button is not resulting in any change. Still no events are caught. Changing the driver from mobile App is also failing with the message “Check network connection. Make sure your phone is connected to the network”. Adding the device many times… Scanning QR code and searching nearby devices. The result is always the same.

Aeotec Smart Home Hub firmware version: 000.041.00009
Device ID from the URL: a70b7669-efe8-463b-897a-fb20af45e843

In case of any farther input needed just let me know. Thank you in advance for any help…

That doesn’t look right at all. I just added 2 buttons, one was just added yesterday and both are working great. Here’s what it should look like in the IDE:

and in the mobile app:

I recommend deleting it and starting over.

That’s what I did already 10 times. Always same result. I removed all the edge drivers. Looking for some logs and events in the hub. Nothing useful found…

ST doesn’t have an Edge driver for these yet that I know of. Did you have another Edge driver perhaps that is using the fingerprint of the button? Sounds like it me. I had the same issue adding a LUX thermostat and it picked up a Xiaomi edge driver I was testing, which tells me the developer added a fingerprint they shouldn’t have.

1 Like

It looks like you’ve picked up an Edge driver forked from the stock Zigbee Water Sensor. I know @veonua has a Github repository where there is a Zigbee Water Sensor driver that has a generic fingerprint that looks like it might perhaps cause exactly this problem. Is it plausible for that to have been installed somehow?


Solved. Indeed it was related to edge driver which couldn’t be removed from beta drivers web page. I had to use smartthings CLI tool and do it from the console.



Having this same issue, only difference is the Name of the device, the last device I added was the same button which added fine, and now this second one i’m trying to add keeps connecting as the wrong type of button and doesn’t work

Manually chaging it like the OP doesn’t work, how do I add this button correctly.

Below is the exact same button I added a few weeks ago and works fine:

Within the past couple of days, ST has started defaulting this button to use the new Edge driver. Since the old Groovy IDE doesn’t recognize Edge properly, new buttons you join will show as placeholder with cloud execution, and won’t show any logs. They will actually have local execution though, as all Edge drivers run in your hub.

After joining one of these, don’t try to change the device type away from placeholder (I’m not sure whether doing that actually has any effect). Instead, test functionality in the app to see if the button presses are recognized properly.

The button doesn’t work at all, nothing is recognised, to the hub, just an icon on the app that doesn’t do anything. It also has lots of different options for the button that don’t exisit, like toggle etc, temp recorded at 0.0 and batt level 0%

How do I use the CLI tool mentioned above by zborowskil?

I would try removing the device and then adding it again.

Done that about 1000 times, everytihng I could think of.

Not sure how to do this, if someone could explain that would be great.

Looks like an Aeotec/SmartThings button made by Samjin using the new Edge driver that has just gone into production.

Apart from it looking different to what you have been used to when viewed in the legacy IDE, what isn’t working about it?


Sorry, a load of posts weren’t showing where you covered some of this.

Ignore what the IDE shows you, it is a tool for the legacy platform.

The extra options for the buttons shouldn’t be showing. I believe the iOS app particularly has an issue with them though.

Does nothing work at all? No button presses showing?

I’m using their SmartThings Edge beta zwave-button driver with my Aeon minimotes, and the press and hold button features work, but it too has a lot of different button options on the device page that don’t work with the minimotes.


No, nothing registers, it’s added to the app, when setting button press to turn on a lamp, nothing happens, doesn’t even register a press. The previous button I added working perfectly fine.

Shouldn’t it at least have a Device Network ID assigned? All of my other devices have one.

1 Like

Devices connected directly to the hub using Esge drivers will not have any network IDs assigned.

IDE is basically for the legacy groovy stuff. Edge devices would be listed but that is about it. Cloud-to-cloud devices would be assigned a network ID.

Ok, I got it working now. I deleted it and added in the Zigbee Edge Button Driver to the hub.

Re-added the button and it’s working now with all the correct info on the App also.

Used the below link to enroll my hub then install the relevant drivers:

Explanation page here:

Trying to solve the same issue
I tried the drivers after removing it then installing again and nope no responce from the button at all and it was working fine earlier

This should only be 3 options because its just a button. Press and double press and hold thats it and im getting no signal out of it the battery said 70 percent I just swapped it with a brand new energizer it cant be that