Ikea Shortcut Button stopped working

I have a few Ikea buttons and one by one they have just stopped working with SmartThings.

My current one was using a zigbee driver. In troubleshooting, I have since removed it and re-added it. When I do so, it is recognized as a Zigbee Thing, with no control events. I went to the groovy ide and changed it to a Zigbee Button. In the app it still has no control events. So in the ide I then tried changing it to a Type of Ikea Button. Still no events.

No matter what I do, in the app the driver lists it as a Zigbee Thing.

I’m at a loss as to what I need to do to get this working again (it was working 2 days ago)

When you readded the button, it likely picked up the ZigBee Thing Edge Driver because you don’t have an Edge Driver with it’s fingerprints installed. Once a device is using an Edge Driver you can no longer use the IDE. It is obsolete and will be shutdown after the Edge Migration is complete.

I would start by deleting the device, then readd it. Then open the device tile in the mobile app, click on the 3 dots in upper right corner and select driver. Click on the chance driver button. If you have a suitable driver installed it will be listed. If not you will need to find a driver.

I would would try ZigBee button from this channel. If that doesn’t work there are other options, so check back.

I just removed and re-added the button, then enrolled in the beta channel and installed the Zigbee Button driver, but when I try select a different driver in the app, nothing is available

There are other ZigBee Button drivers by community developers available. Here are some others you could try.

@DavidG1 this is the edge driver I use for my shorcut buttons

1 Like

You saved my day.

1 Like

Nothing worked for me - I tried all the suggested drivers and nothing got recognized. I’m glad the thread helped you though, and I appreciate all of the suggestions.

I’d chalk my issue up to a device going bad but since this is the 3rd button that has stopped working, it seems unlikely. In the end, I just paid extra to get an Aoetec button that works flawlessly