Adding devices headache

What is with adding devices now to ST? I have 9 old GoControl Z-Wave Motion Sensors (the old WINK ones) and the all work fine. Strangely half show the driver as ‘Z-wave sensor’ and half show no driver at all with no option to select one. Today I have been trying to add another one of those old sensors (New) and it added, but the icon was a 2 x 2 of squares and circles in diagonals, but when opened the page does not show the normal motion, battery and temp, but like every possibility for sensors from Contact, to Smoke to voltage and whole lot more. I changed the driver to that ‘Z-Wave Sensor’ and it shows exactly the same thing. Smartthings at one time was awesome, and it seems to be getting worse day by day. Solution?

Since it added, check the fingerprint and see if it’s the same as the ones that are working. If not, you will have to delete it and add it again.

The following FAQ has screenshots of where the fingerprint fields are:

FAQ: Manufacturer/Model Shows All Zeroes

Also check what edge driver it’s using. If the device didn’t add correctly, it may have a missing or partial fingerprint, and then it might match with one of the diagnostic drivers, which is what can make it show up with a bunch of capabilities it doesn’t really have. :thinking:


Also, a number of community members with this problem were able to use a custom edge Driver and solve it. See:

WAPIRZ-1Z Monoprice Motion sensors suddenly appear to have additional features


Since then the newer Z-wave Sensor Driver has been working for my other 9 GoControl Motion sensor. The one on the photo is for my garage and has a null fingerprint, no option for a driver and profile for Aeotec for some reason, yet it works.

I am thinking that the ‘Z-wave Sensor’ driver maybe corrupt. I tried to remove it with plans to re-install it, but it will not let as it says that it is in use by other devices. So I tried to switch those devices that use this drive to another driver until I can delete and re-install, but I cannot uninstall ones like that Garage one which are clearly using it (lists it in the error message) and a load of other sensors too. So I am not going to remove over a dozen devices just so I can re-install the driver again, then have to spend hours adding those devices back and a whole lot longer on scenes, routines and more. The device I am trying to add is exactly the same as the other 9 which I have been using since 2016, yet for some reason the driver adds to that, but it shows every sensor option possible when it should just show Motion, Temp and battery.

Thoughts on if my system is corrupt, how I maybe able to have that driver re-installed?

Update I just switched the other motion sensors back to the ‘Z-wave Sensor’ driver, and now all of them are screwed up. I Freaking hate Smartthings.

You have to remove the new sensor you added by excluding it and then pairing it again. Put SmartThings in exclusion mode: select your hub in the app, tap the three dots in the top-right corner, go to settings, then Z-Wave utilities, and choose Z-Wave exclusion. Put the device in exclusion mode, and you should receive confirmation that it was removed. After that, bring the device within a few feet of your hub and add it again. Also, it would be helpful if you provided us with the exact model number of the device and a screenshot, similar to the one you posted above for one of the other devices that is working…


It’s not impossible that the driver is corrupt, but very unlikely, and if it were it wouldn’t cause the problems you’re seeing.

On the other hand – – the fingerprint being null is going to cause all kinds of problems. And the only way to fix that is the advice that @mlchelp just gave you —you have to remove any sensor with a bad fingerprint and add it again and don’t do anything with drivers until it has a good fingerprint. There’s no point in changing from one driver to another if the fingerprint is bad: the device isn’t going to work correctly.

So the first thing is to check the fingerprint of any sensor which has the wrong app presentation or isn’t reporting correctly and get the fingerprint right.

That in itself may just solve the problems. If it doesn’t, try the custom driver I linked to above.

I know, it’s super frustrating right now, and to be honest, I hate the whole concept of edge drivers and fingerprints: other certified Z wave hubs don’t add that extra layer, and I’m unconvinced that there was any reason to. It’s not like it’s hard to add Z wave devices to other certified Z wave hubs, so there was no reason to change up the process. But they did, and we’re stuck with it, so here we are.

In the new architecture, focus on the fingerprints first. Once a device is added with a good fingerprint, that fingerprint will let you match it to the right edge Driver for what you want. And until you get a good fingerprint, nothing is going to help fix the problems that you’re seeing. :thinking:

Good luck!


As far as I can see this issue is now effecting 15 devices, mainly GoControl Motion Sensors, GoControl Window Sensors, a new Zwave Plus Contact sensor and a Fibarro Motion sensor too. I feel like my only option is to remove all 15 of those devices, then try and remove that ‘Z-wave Sensor’ driver, then re-install the driver and then reinstall all of sensors again; however with my poor health this is going to be a big headache.

The question is, would I need to exclude all of those devices before I remove and install that driver? Also is their any chance that Smartthings support could just reinstall that driver so I do not have to do all these removals and re instalations?

If you are seeing null or zero or blank data in the fingerprint, the problem is not the edge driver. The problem is that the Z wave pairing is failing. So the good news is you can stop worrying about the edge driver. Again, focus on the fingerprints first.

You can certainly get in touch with official support if you are having trouble adding devices and if you have multiple devices of different models that are all getting bad fingerprints, personally, I definitely would contact them.

On the other hand, samsung changed up its support process a couple weeks ago and they appear to be trying to force everybody through an AI assistant first and I’m just hearing lots of reports of frustration with the support process right now. I mean, way worse than it was before. :rage: so all I can say is good luck with getting help through that route.

Whether you work with support or not, my recommendation would be to start with just one device and focus on getting it paired with the correct fingerprint. Don’t worry about the dozen or more others that you have until you have a process that is working. Don’t worry about the various drivers. Just focus on the pairing process and getting a good fingerprint. You can’t fix anything else until you have that.

Hi again,

I tried removing, excluding that first motion sensor causing the problem and it gave that same result of the driver listing ever sensor combination possible every time I added it back. I tired 4 other motion sensors which shown bad info (but still worked fine) and then those motion sensors failed and shown all the same numerous fields like that first one thus causing them to fail. (Headache as they then kept causing false alarm, false smoke notification and more. Hence why I still think it is a bad ‘Zwave sensor’ driver. Is their any other 3rd party drivers that do the same as the ‘Zwave Sensor’ that I can install and try switching too before I have to remove half my system and security in hopes to fix this?

It is also strange as I removed all the unused drivers like JBL, Bose, Sonos and so on, and for some reason they are now all back and I did not add them back.

What is the fingerprint for the device that is showing the problem? Focus on the fingerprint first. 🕵🏽‍♂️

As far as the other drivers that you removed like Bose, they are part of the standard set that smartthings gives to all customers. If you remove them, the system will just add them back again the next time it checks with the cloud, usually in an hour or two. So don’t worry about those. They aren’t affecting anything since they aren’t being used.

Why SmartThings has installed unnecessary Wemo etc drivers to my hubs

As a comparison, this one has the correct fingerprint (motion sensor) and works, but does not show a driver and has no way to select one, but when I tried to remove the Zwave Sensor driver, it shows this device as using that driver.

Is that the custom driver from @csstup ? If so, report it in the author’s thread in this forum.

[ST EDGE] Z-Wave Sensor Driver Channel - including specific Ecolink, FortrezZ, HomeSeer, Monoprice and Zooz models

If it’s the stock edge driver from smartthings, don’t try to remove it unless told to by smartthings support.


I believe the Manufacturer code is the fingerprint right? If so the GoControl motion Fingerprint should be 014F-2002-0203 for all 9 of my Motion sensors.

Is their anyway to manually edit the data to fix the ‘Null’ fingerprints?

I just removed, then excluded that first sensor again (Kitchen) and then re added it (I was about 2 feet from the ST Hub) it added it and shows using the Z-wave Sensor Driver, but as you can see it is still screwed up and shows all of the sensors available in the app when it should be just show Motion, battery and Temp.

No, you can’t edit it manually. The fingerprint is reported by the device to the hub at the time that the pairing complete. If the fingerprint is incorrect, the pairing did not complete successfully.

Did you get a chance to look at the link that I gave you about fingerprints? The fingerprint is a combination of two fields. There is a screen print at that link that shows you which they are.

FAQ: Manufacturer/Model Shows All Zeroes


That is a common problem with the Z-Wave sensor driver, so don’t use for those devices.

Install the following driver as @JDRoberts suggested above and change the driver the device is using with the mobile app.


That is exactly what you need to do, even if it is a pain.


Now my replies on here are screwing up. Obviously you seen it though. I must be very tired.

“I did and that iffy sensor seemed to take it. I still have numerous other sensors that wont take it, so I will one by one remove, exclude and rejoin them with the CS driver.”

It sucks that a few of the sensors are awkward to get at, but I want a working system, so maybe when my son wakes up he can do some freestyle climbing lol.

1 Like

As a quick note, most of my GoControl contact sensors show as using the Zwave Sensor driver in the android app, but do not show any driver on the My Smartthings advanced, or offer any other driver in the drop down list of the same driver section (for each device) on my PC. Is that an issue too, or is another driver better to use for them?

Thank you all for your help. Slowly but surely my system seems to be getting back on its feet. :slight_smile:


If you can change the driver using the mobile app you should be good to go.