[ST Edge] Integrating Z-Wave sensor device

For the Edge Driver zwave-sensor and the Edge Driver zwave-button.

Can someone use the device to verify that it is available?

When I added my device fingerprint on top of them for the first time, it worked fine. But recently, they are not working properly:

In the SmartThings APP, the device’s window is showed as profie, but all are showed as default, datas from device do not be freshed.

I tested the Edge Driver zwave-sensor with the purchased device “Aeotec Water Sensor 7 Pro”, but the information from the device could not be updated.

When you experience this kind of issue I suggest you check the following:

  • Are you using the correct device profile within the Driver?
    As this driver supports devices with different configurations (capabilities, etc.), you need to select the one that is compatible with your device (or create a new one in case it doesn’t exist)
  • Is the device onboarding successful?
    Use the logcat command to check for errors during the device join.
  • Are the attribute reports being received and handled correctly?
    For this, you can also check in the logcat if there are errors handling the reports.
  • What is the current state of the capabilities?
    Generally, when the capabilities appear with a disconnected icon, it means they have a null value. You can verify this in the Device endpoint of the API:

Oh,the device “Aeotec Water Sensor 7 Pro” is supported by he Edge Driver zwave-sensor, I don’t need to modify something, and I can paired it successfully.
There is no any report during the device join in the Logcat windows(at the same time I can catch some info for other device)

Oh ok, I got confused because you mentioned you added the fingerprint:

Have you checked the capability values in the API?

You mentioned they worked correctly the first time, but without uninstalling the device, it started to fail?
Did you make a modification to the driver that could cause the issue, or you’re using the zwave-sensor driver from the official SmartThings channel invitation?

To have a better reference of the issue, it would be helpful that you shared with us the Hub logs and result of the query to the device status. This must be through an email to build@smartthings.com for security reasons.

When I firstly download the Edge Driver zwave-sensor , I installed it and test with my “Aeotec Water Sensor 7 Pro”, it woks fine. Then I add my own deivce’s fingerprint, it work fine also–Only the icon is default.
I remove the devices and uninstall the the Edge Driver zwave-sensor .
After a few days, when I finished writing the drivers of other devices, I was going to try to solve the icon problem again. After reinstalling the driver, I found that not only the icon is abnormal, but also the display inside became the default and could not be refreshed, it can not receive any information from the device.
Even if I didn’t make any changes, I tested it directly with the purchased “Aeotec Water Sensor 7 Pro”, and the result was still the same.