15-200 error during connection to SmartThings

I had a similar issue that I resolved by removing a hyphen in the WiFi password.

2 Likes

Changed wifi security type to WPA2-PSK and it worked

2 Likes

I fixed it using the suggestions above. First I changed my wifi name using only letters and numbers (The previous name had a symbol “_”) but still not working. Then I changed the password using only letters and numbers (it had the symbols “%” and “?”).

I have a router with OpenWRT and the only way I could make it work is setting the hwmode to legacy (to use b/g insteaod of n). Beyond me why this happens, though.

I ran into a similar issue. My fridge won’t connect to my network when it is configured for WPA3 + WP2-PSK. It will connect if I change to WPA2-PSK. There is no reason why a device that doesn’t support WPA3 to fail to connect when WPA2-PSK is also enabled. I have several devices on my network that don’t support WPA3 but connect just fine. Also interesting is that when enumerating the networks it can see mine won’t even show up if WPA3 is enabled. This sounds to me like a rally bad bug in the firmware. Does anyone know if that was updated recently? I can’t recall when I change my network settings to include WPA3 but it was some time ago and I swear the fridge was connected just a month ago or so.

I don’t even know if those devices update their firmwares,do they? Would be good to know.

Same issue here. You would think that a $1500 soundbar would connect seamlessly.

I tried with iphone it stops on the first screen. With a samsung phone it goes a bit further but at the end I get the error 15-200. My password and SSID do not have any special characters. I am on WPA2, however I am on wifi 6, my nighthawk modem does not allow me to switch to wifi5.

I had the registration error for my fridge too, turning off the Apple private relay fixed it for me.

Hope it helps, good luck.

I have the same issue with the DV80T5220AX dryer.
Reading the answers here I changed my router (Asus RT-AX86) from WPA2/WPA3 to WPA2 only, and it immediately worked. If I switch back to WPA2/WPA3 the Wifi logo on the dryer disappears and can’t get it to connect, so I’ll let the router on WPA2 fro now. I hope this will be sorted out.

Funny enough, the WW80T554DAX washing machine that I previsouly had doesn’t show this issue. So it’s not just Smarthings. Maybe the thing will update its firmware, I’ll have to try again later.

I had the same issue with our Powerbot Vacuum, but the SID and credentials were fine. Turns out our Verizon FIOS router was blocking the connection. I logged into the router, chose My Network from top and found a connection with “Tizen” and a status of blocked. With the Device Options dropdown I unblocked it and it worked fine.

Unfortunately this issue is still not solved for me :frowning:

I had to create a 2.4 Ghz Network (new SSID) and used that to connect, it worked well. Have you tried that too?

I did yes. Today a breakthrough :slight_smile:
I got a new error code; 04-150 ← anyone know what that means?