15-200 error during connection to SmartThings

I have almost 50 IOT things in my house, including the Samsaung Family Hub refrigerator. Everything works. Except the Samsung Washing machine. I am getting an error code, 15-200, during the registration process.

I can see the machine on my network, but the error happens.
MACadr added to router and static IP for ease. Nothing works.

Does anyone have any experience with this code I can see the internet is flooded with the same questions, all of them remain unanswered.

Br
Simon

2 Likes

Have you ever figure out how to fix this? I have a TV that I can’t connect and the app is showing me the same code.

I also tried to connect my washer and got the 15-200 error.

My Solution:
I changed the wifi security from WPA3 to WPA2 and it finally connected

2 Likes

Yeah, I am on WPA2, so wouldn’t work here.
This is really odd - 50 something devices, all working…except this one.

I did not.

I wonder why ST is silent about this. The internet is flooded with this error - and it seems random.

I’m trying to add a washing machine and get to product register and this code comes up. I’m using a BT whole home hub???!!

I am also having this issue when connecting my Jet Power Bot vacuum. I make it to the final registration step and receive the error 15-200 error claiming my Internet is the issue. It’s not, I have various other Samsung devices running on my smart things app.

Samsung tech — can you please respond as soon as possible. Thank you.

1 Like

I’m having the exact same issue. Have you been able to resolve it?

Nothing yet, hoping Smart Things can reply shortly with an update or fix

Ok, same here!

It worked for me now so Smartthings have eventually fixed something! I recommend you trying again.

Oh wow really? i just checked again and nothing. What device were you able to get it to work on? im trying on my jetbot vacuum.

My washer was connected correctly for months, then suddenly wouldn’t connect any longer a few weeks ago. I get the same error message. The dryer connects okay, and all of my other devices. I’m using an eero hub and temporarily disabled 5 Ghz so the washer could connect with 2.4 Ghz. It almost worked, but hangs on the registration to Samsung part… Then fails.

Frustrating that I sent the error log to Samsung and they replied with “send a screenshot of the error message, the product, the model, etc.” Did they not get the error logs??? Oy. :woman_facepalming:

I really want the Family Hub fridge… But over heard bad things about it.

I am having the same frustrating issue trying to connect 2021 speaker bar model HW-Q900A using a samsung galaxy phone.

No practical solutions or explanations.

I got the same error code: 15-200(Couldn’t register Soundbar to your Samsung account.) trying to connect my Soundbar HW-Q80R. I changed my phone recently. It was connected previously to my old phone without any issues about more than an year ago. I also changed my wifi name to not have any special characters. Also, tried switching between WPA2 & 3 with no luck.

Ok this worked for me just now.

Connected my phone WiFi to 2.4GHz(WPA2/WPA3-personal). Also selected the same WiFi network to use for my soundbar in the smart things app and it registered successfully. Wow, I wasted 3 hours on this, this morning. This shouldn’t be this hard.

My problem was Pihole.
Internal DHCP pointing to Pihole for DNS requests.
Switch to gateway for DNS requests problem solved

I was having the same problem with a Samsung washer and dryer. I already have a Samsung TV connected to SmartThings with no problems, so I thought the problem must have been the washer dryer.

I started trying on Sunday, tried all suggestions in this thread about the wifi network settings, resetting the washing machine, everything in every thread I could find and nothing worked. Tried using a new router, tried using the wifi hotspot on my wife’s phone, tried using my wife’s SmartThings app, tried her SmartThings account, nothing worked. Called Samsung on Monday, they tried everything, nothing worked, they escalated to Level 2 Tech Support, but they never called me back.

Now on Wednesday I just got an Android system update. After updating Android it seems like a new version of SmartThings was installed / updated / reset. After that I was able to pair the washer and dryer on the first try. Didn’t make any changes to my wifi setup or the washer / dryer. Using a Note9.

So I’d also suggest try to check if there are any Android updates available. If not, try to uninstall SmartThings, then reboot your phone in between, and then reinstall SmartThings after the reboot. Or, just try waiting a few days, it seems like the one thing everyone has in common is it just started working after a few days.

Good luck.

I was having the same problem with a brand new Samsung WW80T654ALX/S2 washing machine.
I received 07-199 error code first, but I tried multiple times with restarting the router and washer and my smartphone, updating all devices and finally reached error code 15-200.

I followed Venkata_Janapareddys tip and changed my Fritzbox 7590 (router) security from WPA2 + WPA3 to WPA2(CCMP). I tried again and the washer directly connected to my Fritzbox and everything works as intended. Now I changed my Fritzbox back to WPA2 + WPA3 and it seems to continue working. Finally I got it, thanks Venkata.

1 Like