Help Please - Smart Things Error 04-100

Hi all,

I recently purchased a Samsung washing machine and Samsung dryer. I bought these because I wanted the wifi functionality. Unfortunately, it has been a week and a half and many hours of failed attempts to get these devices connected to the SmartThings app… I must be missing something obvious. I’ve followed all instructions and even called Samsung (only told to restart everything and reset the machine to factory settings / turn wifi on / off on machine)…

Background Info:
Devices - Samsung 5+ Washing Machine / Samsung 6 Heat Pump Dryer
Internet Provider - Vodafone
Mesh Network - Tenda
Phone - iphone iOS

Actual issue:
I’m able unable to get past the “connect in settings” screen in the app when I try to add the device. This is the case for both the washing machine and dryer. I can see the machines in my wifi settings but the app can’t seem to connect and my phone will say “no internet connection” before it eventually hits an error. Error code 04-100

I’ve restarted everything. Turned my mesh network off and tried to use vodafone router (split to a 2.4 GHz frequency), have tried to use the mesh network with a smart assistant function etc. I’m a bit out of ideas… I’d also like to use the washing machine and don’t want to be lumbered with them not accepting a return if this is faulty because I used it once!

Please can anyone help? Or is there a more technical Samsung support line (the person who was trying to help was unable to really understand the problem).

1 Like


The screen I get stuck on before that error code appears, in case that helps

Hey there! @Majesticrace, Welcome to the Community! :slight_smile:

It’s always best to provide the specific model code for your devices to help the community better formulate troubleshooting steps for you.

Additionally, when you select the ( ? ) Question mark at the bottom of both of those screens, it should provide troubleshooting steps to attempt to resolve the error code or provide the next steps in the onboarding process. Have you already been able to attempt them? Can you provide a screenshot of the ( ? ) Question mark’s suggested troubleshooting steps?

I wanted to first provide you with this troubleshooting link for issues with connecting to Smart Things: Cannot connect to SmartThings

Once we know the model code for your devices, we can look up specifics for your device such as if it has a display for WiFi indicators to confirm the device is connected to the internet. (This seems to be the issue occurring)

If the issue continues, please collect as much of the following as possible as it will be asked for by support team:

  • The model of the mobile device(s) setup was attempted with
  • The version of the app (open the menu, then touch Settings , scroll to the bottom, and select About SmartThings )
  • The exact step where the error occurs
  • The exact wording of any error messages that occur

Once as much information is collected as possible, report the problem within the SmartThings app. (Open the menu, and then tap Contact us > Report a problem .)

You can also reach out directly to a support team in your area using the below information:

US: 1-866-813-2404
US: support@smartthings.com
UK support 0333 0000333
UK: support@smartthings.co.uk
CA: support@smartthings.ca

I hope this message finds you well!

^SamsungZell

Hi. Thank you for posting this. I have the same issue with my washer.
Did you manage to resolve the issue?

Hi Rob,

I ended up trying many many different things before I got this working. What I’d recommend is:

  • On your wifi router / mesh network - make sure you have a 2G version (not the 5G one) or check settings to temporarily switch to 2G
  • Uninstall the app on your phone
  • Reinstall app on your phone
  • Go to your app settings and allow everything always (I think this is key)

Finally, follow the normal instructions and hopefully it will work!

Regards,

1 Like

Thank you so much for your reply. I’ll do that.
Did you have any issues with using the SmartControl feature after that?
It seems I have connected but it the smart control feature won’t activate.