ZWN-RSM1-plus not reporting status when turned on by aux


(BIll) #1

If one of my exterior flood lights sense motion, I want them all to turn on. I spent a bunch of time trying to find a product that would fit the bill. I finally came across this little guy and bought 7 of them. I’ve only had my ST hub for a few days and everything else in the house worked perfectly out of the box. After I spent all day dragging an extension ladder all around the house and getting them all installed, I realize that when the motion sensor turns the light relay on via aux, it doesn’t report back to ST that it is on. It originally set up as a zwave switch generic. Should I change it to something else?

Thanks!


(BIll) #3

Anyone having issues with RSM1 plus not updating status, use this device handler. Solved my problem! Thanks, erocm1231!

https://github.com/erocm123/SmartThingsPublic/blob/master/devicetypes/erocm123/enerwave-rsm1-plus.src/enerwave-rsm1-plus.groovy


#4

Tried installing this device handler code verbatim. It’s still not updating status. Am I missing a step? Thanks!


(Grant Harlow) #5

Worked like a charm for me. Once you created the device handler, did you publish and change your switch to the newly created device handler?

It takes a few seconds to update the status in the Smartthings app when switching with the manual switch, but that is by far better than not updating at all!


#6

Thanks enul4u, contacted Enerwave directly and found once I applied the new device handler in IDE and hit configure on the app, I had to cut the power to the switch and restore power and all has been going smoothly since.


(trujumper) #7

Hello community I really need your help. I purchased the Enerwave Smart Relay ZWN-RSM1 and have gone through the installation of connecting it to my flood light w/ motion sensor. For some reason after installing, it worked for a few days and haven’t worked since. I’ve tried using the Device Handler above and also the Enerwave RSM2-Plus by Eric Maycock (erocm123) Date: 2017-06-16. Neither of these handlers seems to be working for me. After publishing the handler and adding the device through IDE, the device shows online. From the Smartthings app, I can see the device and it shows a status of ON. Although the motion sensor shouldn’t be detecting any motion (nothing there). After a few minutes / hour the device will go Offline in IDE and the Smartthings app and never comes back online. I’ve also followed the steps recommended by rshah. Does anyone have any additional recommendations?


(Leonard Jenkins) #8

I am in the same situation here.
I have 3 of the Enerwave RSM1-Plus units, all with the same issue.
They do not seem to have any explanation for this.

I have them contacting their distributors to see if any of the older (non-PLUS) units can be found.
I ran across some other posts, that stated that there are no problem with the older original units.
Which then, probably means that I will need to buy them - if Enerwave can find any…

I just don’t know, whom to “spit fire” at right now.
I am so disappointed about this Smartthings experience.
:frowning:


#9

Hi Bill.

I’m trying to hook up my exterior flood lights just like you did. Do you mind telling me how you wired the Enerwave into your motion sensing flood light?

Thanks.

Chris


(Pasha) #10

Did you get the wiring for your setup figured out?