ZWave troubleshooting


(Kris Linquist) #1

I hooked up a GE/Jasco 45609 ZWave wall switch to my porch light on Friday.  Added it to SmartThings and it worked great.

 

When I got home tonight, it would not respond to SmartThings - it seems that it wasn’t communicating at all.

I removed it from SmartThings and now I can’t re-add it.  I suspect that it never received the “Un-pair” command that ZWave devices must receive in order to be able to re-pair with something.     There appears to be no way to hard reset this switch.

It will also not pair with the old ZWave remote I have, reinforcing my suspicion.

Any ideas other than returning this for a new one?   :/


(Eric Schuld) #2

If you can telnet into the hub - you need to manually do a remove - when you are connected in - do “zwave remove” then go press a button on the switch. Should see it remove in the telnet screen. Then re-add it like normal.

The same thing happened to me. I removed the device from my list because I was thinking of sending it back (the port that goes to the aux switch is bad on the switch - my electrician friend thinks it could have been him that caused it though… not going to complain with free help though) Anyway - I can still use that one in a single switch setup - just will never work in a 3-way setup. But - since I thought I was going to send it back I deleted it from my list of “things” and ran into the same problem when I went to re-add it as you. The zwave remove remedied the problem though.


(Kris Linquist) #3

a-ha, I didn’t know I could telnet in.   What’s the telnet password?


(Eric Schuld) #4

There isn’t one that I had to enter. But you have to know the IP address of the hub on your network. (So you’ll need to figure that out on your end - my router settings show me connected devices so I got it easily in there.)

I also haven’t checked - but I believe in the next firmware update that the hub will receive the telnet functionality will be disabled - so do it quick.

But yes - you have to be physically on your network and know the ip - then in console on your mac (not sure on the PC anymore) just type: telnet xxx.xxx.xxx.xxx - you know :stuck_out_tongue:


(Kris Linquist) #5

I do know the IP address on the hub on my network - and unfortunately it does want a password when I try to telnet in :(.

 

 


(Formix) #6

Is Telnet ever coming back?

 


(Eric Schuld) #7

@Kris - ahhhh - not sure what to say then - must have pushed out the new firmware. (I haven’t telnetted in for a week and a half.) I would just email support@smartthings.com then and explain what’s up. That you need a zwave remove command to resync a a GE switch you deleted from the hub.


(Andrew Urman) #8

Telnet is only there right now for debugging on our end and will eventually not even be compiled into the hub firmware. Kris for now Eric is right, email us at support@smartthings.com and we’ll give you specific instructions on how to remove a z-wave device. Right now when you remove a z-wave device, the hub goes into “zwave exclude mode” for 10 seconds, and we are working on adding a zwave remove button in the mobile app.


(Kris Linquist) #9

Thanks Andrew, I sent you guys an email yesterday .
"[SmartThings Support] Support request #15854: Can I get the telnet password to my hub?"


(Andrew Urman) #10

Cool I can close that out since we’re not giving it out :p. But since you have access to the IDE, here’s the workaround for now. In the devices page click the + New Device. Then give it any name, and any 01 as a device ID, under the Type open the drop down and select “Z-Wave Switch” ,  select your hub and hit Apply. When the new fake Z-wave device shows up in your iOS app, delete it and you have 10 seconds to hit the switch on or off. Either one. Then the device will be successfully removed and you can add it again. No need to email support  since I’ll field it anyway :stuck_out_tongue:

 


(Kris Linquist) #11

Thanks Andrew! I’ll try it tonight and report back.


(Kris Linquist) #12

Worked like a charm, thanks!


(Andrew Urman) #13

Sweeeeeettt!


(Mark M) #14

I am having this problem where my door lock failed to show up and now won’t pair with I don’t have access to an IDE or Telenet.


(Andrew Urman) #15

Hey Mark. While I’d usually like to stay away from sending users to email support@smartthings.com instead of discuss it here, we need to track things like this on a per-user case. This a temporary measure for this issue until it is built into the mobile app. I’ll look out for your email.


(Mark M) #16

[SmartThings Support] Support request #16153: Door lock‏
How do you remove a Schlage BE369 door lock.


(Lowdrag) #17

Andrew,

I have no ide or iOS. I must set this up because I am leaving the country.

Please can someone tell me how to do so without iOS?

thanks


(Andrew Urman) #18

@lowdrag contact the support team at support@smartthings.com. They will try to help you out.


(Eric Arney) #19

I have a support email in #24641… I am also having a problem with a z-wave switch I removed and then tried to re-add. I added a fake z-wave switch and removed it pressing on the light switch many time with in the 10 secs with no luck…

trash Device trash
Name trash
Label trash
Type Z-Wave Switch
Zigbee Id
Device Network Id 01
Status INACTIVE
Hub Home
Last Activity At 23 Aug 2013 16:51:21
Date Created 23 Aug 2013 16:39:34
Last Updated 23 Aug 2013 16:39:34
Current States No states found
Events List Events


(Carl Aydelotte) #20

I do like that fact that we do discuss these things here. For some of us (me) it can be very informative. And I imagine that the support mailbox sees enough traffic now as it is.