I managed to pair in two Z-Wave objects without too much effort. I recently bought a GE 45609 wall switch for my kitchen lights and had issues but worked them out, and I also bought a GE 45604 Outdoor module that jumped right on the network. Once you know what you are doing, this is easy. And a Hardy Hi-Ho to those that chimed in previously to assist me. Thanks for the help.

One big helpful tool is the web utility in the Designer Tools, specifically the Device List. There you can edit / add devices to your network. To fix my light switch I simply created it manually and it worked. At first I set the Type as a “Z-Wave Virtual Momentary Contact Switch” and for the first time it worked!! However, by design, the lights came on for one full second then switched off. That’s when I knew the wiring was good, the switch worked, it was just a configuration issue. Then I simply switched it to the correct setting of “Z-Wave Switch” and now all is well. You can use any unique number for the device network ID… I used 01, 02, 03, etc… for my devices.

The outdoor switch (also a “z-wave switch”) simply jumped on and worked the first time, but I did make sure it was about 6 feet away from the hub when pairing. I still need to place it in its permanent home but it will be close to other devices so I should be good to go.

Let me get some time under my belt with these two devices and if they still work in a weeks time like they do now, I will let you know and give them an official plus one for compatibility with the Smart Things network.


Yes… I’m pretty happy with Z-Wave dimmers, so far, and enjoying exploring how things appear in the API/IDE web pages.

Pairing of Z-Wave is a problem if the device is mapped to some old network: I found that my GE Z-Wave Remote was able to “delete” the network information (some old or corrupt network?) from a device (purchased as surplus) and the ST Hub had no problem adding it.

Newbie question… how do I get to see this stuff “API/IDE web pages”?

I find that an aeon stick is pretty much indispensable for un-enrolling devices that have previously been enrolled onto a different network/controller. I’ve been migrating slowly from a Vera system and its a time saver especially for locks and devices that are going in too far for the Vera to see them but within the effective range of ST.

I also can’t seem to get the aeon repeater to work correctly, it is detected and enrolled but returns an off state all the time - you can turn it on through the UI but it immediately returns an off status. Sending that back and using an outlet module to add to a dead spot I need to extend the network. Since the net mesh repair function isn’t really implemented on ST it’s hit or miss in knowing what the network is doing mesh/optimization wise.

Many devices have the ID number on the device. Other than that, I can’t think of any way other than pairing it to a Controller and reading it off the device lis in the IDE.

For z-wave, I just made up my own ID numbers… as long as they are unique to the device it should work. It did for me anyway…

Yeah, all of my z-wave have added quite easily. I’ve had the occasional stubborn item that I’ve asked support for help with (Z-wave Thermostat, one of the open/close sensors) and I’ve had a couple that have require me to get my hub closer to get them to start, but most have worked quite well.

Note that if you have used devices that were previously connect to another network you do need to un-enroll them as solardave indicated.

I’ve occasionally had it when first adding a device that it sorta “sticks” for a while as turningon or turningoff. Usually it corrects itself after a few moments. Sometimes I’ve had to log off and log back in for it to reset itself. Try doing that with the mobile app and see if that helps.

Has anyone had any success with any of the various z-wave thermostats that are available? I found a Trane thermostat that I am thinking of trying out and wondered if anyone else has any issues with using thermostats with the ST hub? I am not concerned about adding the thermostat to the network, but do they work well with the available software?

I’m using the Honeywell and it’s working great.