Zwave Switch Shows Unavailable - But Somewhat Works - Help


(Squatting Hen) #1

I am fairly new here and I have installed 4 GE Switches, three are dimmers (2 Z wave Plus) and one Fan Control. The GE Fan switch constantly shows Unavailable in my “Things”, and Alexa can’t connect to it, as it shows offline there as well.

If I select the Fan in my things and get the next screen, from there if I adjust the slider, it responds and refreshes to available in both SmartThings and Alexa. Unfortunately, that only lasts maybe an hour or so. Could be a bit longer, could be shorter.

I have also tried pulling the little tab out to power cycle the switch and while that brings it out of unavailable status, it goes back to being unavailable shortly.

I am starting to think I have a bad switch.

Anyone know how to fix this? It is quite frustrating.

Also…if I look at my activity feed, Amazon Alexa is in there lots of times that we didn’t do. Is that normal?


Devices offline, no fix in sight. Smartthings has acknowledged the bug
Recent Platform Update Broke Parse Method Response/Result (April 2017)
(John) #2

For what it is worth, I have had similar problems with Kwikset z-wave doors and GE z-wave regular switches. What I finally discovered, after weeks of frustration, is that you need to add and remove and readd the z-wave device until it works reliably. I can’t explain why this problem exists or whether or not Samsung will ever correct it, but that is what is effective in my experience.


(Squatting Hen) #3

Thanks. I thought I tried that once, the exclusion/replace thing, but I couldn’t remember for sure, but I have done everything except exchange it.

I will try removing it and adding it and see if that helps. from what is sound like, this could take a few tries until it is resolved? Man…that is somewhat a pain.

I read on a different post that someone said to update the FW. I may try to see how to check/do that as well. I have only used the app so far.

One of the worst phrases I hear from Alexa is, “_____is not responding right now…”


#4

Do you have Health Check turned on in the app? There has been some discussion that it in of itself may be the culprit.


(Squatting Hen) #5

I do have it checked, as it sounds like a good feature. I just unchecked it and the device shows available now. Unfortunately, I think it must have some sort of issue currently as when I try to turn it off (it shows it being on) it just says “Turning Off” and doesn’t change. I am not there at the moment, so I can’t verify what it is actually doing.

Seems odd thought that the switch would just keep disconnecting.


#6

I’m sure that’s very frustrating. :disappointed_relieved: Definitely report it to support. If you haven’t already . They may be able to see something from their side.

https://support.smartthings.com/hc/en-us

It might be related to the following


(Squatting Hen) #7

I removed it and added it back. It worked for about two days then became unavailable again. I contacted Smartthings by phone and they wanted me to remove it and add it again. I explained that if I do that it will work for a day or so then stop working. They said to send an email or use the chat feature for higher tech support. I then tried the chat and the rep said he can see it falling off and suggested I get the switch replaced. He said it is probably a bad switch… Ugh. Guess I can try that.


(Devesh Batra) #8

I had similar issue with some of my ZWave devices. Tried exclusion/inclusion, did not help

Turned off device health and they all showed up fine

Interestingly only the regular ZWAVE devices were showing offline (GE switches). All my ZWave plus devices (Aeotec, Kwickset lock, ) were still working reliably while using the GE devices as network hops