ZWave Switch Connection Issue

I have several Zwave Leviton light switches I operate through a Smartthings hub. One of the switches recently started having network or server errors. I have tried to re-add the device by excluding the device in the Smartthings app, deleting the device (though I never disappears from the list) and repairing the network. I get a “failed to update route” error during repair. I have tried adding it as a new device but it’s not discoverable in the app.
Im still having connection issues but am at a loss on what to try next.

I am a little confused but that is the usual for me. Are you saying that if you try to exclude the device or try to delete it that it does not get removed? or only when you try to delete it? when you say repairing… do you mean run z-wave repair or trying to pair it (add) it back?

Do you have any custom device handlers being used by it or stock device handlers? if custom, login to IDE and open the device handlers and publish for me, then exclude it, run z-wave repair a few times, reboot the hub in IDE and then try to add the device back.

Sorry I should have been more clear.
Yes - if I try to exclude the device or delete it, it does not get removed.
I did mean that I ran a z-wave repair and received the “failed to update route” error.
I dont have any custom handlers using the device in IDE. I do have it included on a couple of routines in the Smartthings app.

have you tried to remove it in IDE?

hopefully you mean you have it included in automations in the new app? routines are only in the classic app and that will cease in two weeks :slight_smile:

That worked perfectly, thanks! I was able to successfully re-add the device after. Am now having more connection issues after cycling the switch once but will re-run a zwave repair.

And, finally, I did mean Automations… old habits…

Thanks again!

1 Like

Should the routines from Classic app have migrated to the new app as Automations? If they didn’t do you have any suggestions?

If you ran the migration tool, then routines should have been migrated as automations/tools. If you haven’t run tHe migration tool, login to the Classic app and run it. Or manually create automations in the new app.

Be quick, the Classic app is only around for 2 more weeks and the. It ceases.

Doesn’t appear that I did as they didn’t migrate. I have deleted the Classic app, what do you suggest is the best way to get these routines back? I could reinstall the app and try migrating, or start from scratch in which case how do I delete the existing routines. Thanks.

Sure, try installing the Classic app and see if it allows you to migrate. If you can’t run the tool, your only option will be to manually recreate them. Not fun!

I am almost tempted to recreate from scratch as there was a lot of bloated crap in the routines, do I delete them in the IDE?

How many devices? Sounds like overkill. Recreating the automations would be the easier optIon. I would still recommend installing the Classic and running the migration tool. But if you choose not to, still install the Classic and remove any routines and any custom alerts in SHM and then uninstall SHM.

Where is the migration tool in the classic app. Also I get the persistent message that Smartthings has moved to new app, is there a way to get rid of this otherwise you have very short time to do anything and have to restart the app.

You can contact ST support and ask if the migration tool is still available.

Tagging @SamsungZell @Brad_ST

Thank you much.

The current version of the Classic app still supports the app transition if it hasn’t been performed previously.

@Adam12 - The app transition tool is only shown to the user who owns the location within SmartThings. You are a shared user. Ask the owner to sign into the Classic app and perform the migration if you’d like to transfer your Routines to the new app.

1 Like

Thank you much Brad. Yes the owner was my son who set up the hub originally when he still lived with me. Now he is gone. We tried migrating today again, but he gets an error. Since then I deleted the routines in IDE (there was a lot of BS code there) and will start from scratch. Is there a way to change for me to be the owner, this will avoid any further complications.

Do you recall what the error is? I am not seeing a migration attempt on our side. Unfortunately there isn’t an easy way to transfer ownership.


No, my son didn’t mention. I deleted the Routines and HSM in IDFE anyway. Since there is no easy way transfer ownership, what are my options to start as new owner. I don’t mind starting from scratch. Whatever that means.

Thank you,

1 Like