Unable to Add Any New Device

A few weeks ago, I noticed that I no longer had control of a Leviton dimmer switch. I tried excluding the device and re-adding it, but that didn’t work. Oddly, I was able to “successfully” exclude the device multiple times through the SmartThings app (Android; have tried multiple devices). Assuming the device was dead, I ordered a replacement. Upon installing the replacement, I experienced the same issue when trying to add it to my network (simply no device is detected). In an effort to troubleshoot, I removed a known working device from the network (GE Dimmer). After removing the device, I am now unable to re-add it. I power cycled the hub and even moved it as close as possible to the switches I’m trying to include. I have also watched the logs for the hub when trying to add devices, but nothing shows up. I am at a loss and would really prefer to avoid factory resetting the hub.

are you using any custom device handlers for dimmers? if yes, login to IDE and open the device handlers and publish for me again. then exclude and try to add your devices

1 Like

I was just using the generic “Dimmer Switch” device handler for both of the switches I’ve “lost” now. I will double check that and republish anything that might be related. Thanks for that suggestion. I also got a reply from support with some instructions for a power cycle (3-5 minutes!) and exclusion to try.

I had a handful of device handlers (none of which were related to the devices in question) and a smart app that was related to both devices. I went ahead and re-published all of the things, but I’m still unable to add devices. I also followed the support instructions which were just a 3-5 minute power cycle followed by a general device exclusion. One interesting note is that every time I perform the general device exclusion on these devices, I get a success message even though at this point, neither is part of a network.

Looking at the system logs, you are definitely hitting the known issue that jkp is referencing. Make sure to republish or comment out the fingerprint of all matching device handlers as you may have more than one that matches.

Also, that is expected behavior. Any Z-Wave controller can exclude any Z-Wave device.

I tried republishing again with all device handlers that have a status of “Published” (I have one that is Unpublished, and I’m not sure where I left off with whatever project that was). I then did a general exclusion (which succeeded) and tried to add the device back with the same behavior. Full disclosure: the devices in question are just standard Z-Wave dimmer switches (one is Leviton, one is GE), and none of my custom device handlers are for a dimmer switch. On another note, the brand new switch I tried adding yesterday was a Homeseer that had never been included in my network.

I understand that any controller can exclude any device, but it was curious to me that a device would return success even if it wasn’t included previously. If that’s how the protocol works, I’m sure the Z-wave alliance had a reason, and thanks for the info.

*Edited to add info about the Homeseer switch

Thanks for the info. I should have checked sooner but the issue is that your hub’s Suc ID is 00 instead of the expected 01. So your hub likely thinks it is a secondary controller.

I’ll flag this for a Z-Wave engineer to see if we can resolve it.

Brad got me sorted out by correcting the ID issue. Thanks for the help and all of the suggestions.

1 Like

I’m having exactly the same problem. Started the same way (one of my dimmer switches wasn’t working). Have tried adding other devices since then and my hub can’t find them. Like Andy, I removed a known working device and couldn’t add it back again. And like Andy, I’ve tried everything else (excluding the device, soft reboot, hard reboot, etc.). Is the ID issue something I can correct myself? If so, how?

Actually, I just checked and my hub’s Suc ID is already at 01. Is there anything else I can try?

Okay, I’m posting this for anyone else that comes across this old thread and is having the same problems I was. Since it wasn’t an Suc ID issue, after reading all the old comments, I ended up commenting out the fingerprints that were in two of my device handlers, re-published all of them again, then powered down my hub, removed the ethernet cord and batteries for about 30 minutes (probably overkill, but that’s how long it ended up being) and once I hooked it back up and powered it on again, I was able to successfully add new devices. Thanks so much for the help, even though it was from a year and a half ago! :wink:

Well, it looks like I spoke too soon. While I was able to successfully add two devices, I couldn’t add any more after that and it behaved as it did before. Also, the two devices I added (both Smartthings) stopped updating their status after the first time or two that they recorded it. i.e. my motion sensor successfully updated with motion, but then never updated to no motion when there was none. Same with the multipurpose contact sensor. Any troubleshooting tips would be greatly appreciated.

If they are SmartThings branded then they are zigbee so Z-Wave and the Suc ID wouldn’t be an issue as you’ve discovered. How many zigbee devices do you have? If you have 32 without a repeating device such as an outlet, you could be hitting a known limit.