Zooz ZSE40 4-1 Motion Sensor and other Zooz devices (ZSE01, ZSE02)

dth_motionsensor
dth_security
dth_sensors

(Steve Kesler) #203

@ADHawk, I have the same issue with the LED blinking for motion and temp events. I have tried everything I know to turn it off. I’m also using @erocm1231 handler. I have tried others and seems to have the same issue.

After about 5 months, I got a Low Battery warning (1%). I’ve replaced the battery, and it still shows 1%. But other than that my sensor works great.


(www.rboyapps.com - Make your home your butler!) #204

If you have access to RBoyApps, try out the handler there, the LED configuration works fine on that one. For the battery are you using rechargeables? Try using Li Ion (non rechargeable ones)


#205

Ok, maybe I’m doing something wrong here. I’m using robertvandervoort’s DH… I’ve used custom DH’s in the past, so I don’t think the setup of the DH was the issue.

Here’s what I’m getting in IOS. I’ve reset the device, I’ve killed/re-launched the app. IDE shows values where the iOS app does not.


Edit:
Well, I ended up having to add/remove the item several times before it installed correctly. Not sure what’s going on there, maybe a smart things problem because I got a message about an IDE issue while I was working on this.

I installed 3 of these; the issue I’m having now is that 2 of them are reporting motion in un-occupied rooms. Motion triggers and does not reset, even though the PIR is set to level “4” and a re-set of 5 minutes.

Any ideas?


Edit #2

Used a different DH and now 2 of the 3 sensors are working as desired (the one by krlaframboise).

Still can’t get the 3rd to report motion. The 2 working are on the 17.9 firmware, the one I’m having problems with is on 16.9. Not sure if there is an “easy” way to update the firmware.


#206

Well, that’s just weird. Few hours later, everything is working as desired.


(Jane) #207

Did you get this working. I am having similar problems with my motion sensor. It used to work great but now the battery always says 1% and the motion isn’t updating properly. I am using krlaframboise current DH and my firmware is 16.9.


#208

Need some guidance if anyone happens to still be monitoring this thread…

Just bought a ZSE40 and followed the excellent guidance provided here to set up Robert’s DTH in the IDE. I’m able add the device using the IOS Smartthings app and it shows in the list of devices both on the phone and in the IDE. However in the app the device constantly shows “Checking status…” and when I click on it it says “Can’t connect to device. Check device and try again.” I, therefore, can’t get to the reporting and settings tiles at all. I can’t include it in any automatons (which is the whole point of having it). I do see the device reporting values in the IDE, however.

I’ve remove and re-added the sensor about 20 times, tried different DTH’s I’ve found around here, double-checked the device settings in the IDE, etc etc.

Not sure what to try next and ready to just return the device if I can’t get it figured out.

Thanks in advance for any guidance!


(Jimmy) #209

Sounds like you’re using the new app. Custom device handlers only work with the classic app.


#210

Thanks for the quick reply, Jimmy.

Honestly I didn’t realize there was such a thing as a classic version of the app - I’m new to all this. You are correct, I am using the new version. I see the classic version in the App Store. Can I use the classic app and the new app interchangeably? for instance use the classic app to get the sensor working and the new app for everything else? or do I need to drop the new app and only use the classic app to leverage custom device handlers?


(Jimmy) #211

I’d only use the classic app for now unless you have Samsung appliances. Should be able to login with your existing credentials.


#212

Thanks Jimmy - that was the issue. The minute I installed and logged into the classic version I could see and manipulate the device. Thanks. I suspected it was something obvious that I was doing wrong.

I’m sure this is a hotly debated topic in other threads (and I’ll go look later), but do we know if Samsung plans to allow custom device handlers in the new app in the future?


(Jimmy) #213

Some staff members have posted in here and said the goal is to bring the new app up to parity with the classic app before they sunset it. But no time lines given. But some custom ones have already started working.


(Graham) #214

I’ve just setup one of these also. I added the device handler first and it registered perfectly … super easy. The motion sensor seems to be working well, but I’m not so sure about the others … they all seem to have incorrect values being reported. Here’s what I’m seeing:
illuminance: 1.56 %
temperature: 23.09 C
humidity: 51.8 %
battery: 100 %
motion: inactive
checkInterval: 29100
tamper: clear
lastCheckin: 06/08/2018 12:07:09 PM
lastUpdate: 06/08/2018 10:43:13 AM
pendingChanges: 0
primaryStatus: No Motion
secondaryStatus:
pLight: 1.56 %
lxLight: 0.69 lx
firmwareVersion: 17.9

The temp is off by at least 2 degrees C, the humidity seems to be too high (but I don’t have anything else to compare to), and the illumination must be too low (it’s daytime and the sensor is in a room with plenty of natural light). I installed it last night and I don’t think any of these values have changed since that time.

I bought 2 of these sensors, so I can try the other one tonight, but wondering if I’ve done something wrong in setup to cause this?


(BMarkus) #215

Oyjord,
I am running into the same issue you described (and this is my 2nd day using ST). How do “go to the IDE and manually change the device handler”?

Thanks, Brian!


(BMarkus) #216

Never mind, I did not see the EDIT button.


(Curtis Meskus) #217

Robert, I have loaded the code to my device handler, however i cannot get the device to appear in my devices