Zooz ZSE40 4-1 Motion Sensor and other Zooz devices (ZSE01, ZSE02)

dth_motionsensor
dth_security
dth_sensors

(Dave Travis) #1

Does anyone have this working? Just picked one up and it’s only detected as a generic sensor and it only ever shows inactive for me. Don’t want to have to figure it out if someone has already done the legwork.


Help with Zooz ZSE02 please
This is awesome! Power is Out based on state of v1 Motion Sensor
Luminance sensors?
#2

I got my Zooz ZSE40 4-1 Motion Sensor today. trying to pair it with my Smarthtings hub V2, no luck so far.


#3

Hi guys,

If there is anyone willing to spend some time to write a device handler for this sensor, let us know and we will send you the product for free: http://www.thesmartesthouse.com/pages/contact-us


(Ray) #4

Did you guys try switching the device handler to Aeon multisensor gen 5? It’s also a z-wave plus multi sensor.


(Erik) #5

Just received mine in the mail. It only gets recognized as a zwave sensor and looks like it is inactive.
I tried switching to the gen5 and it wouldn’t recognize the sensor.


#6

Hi Dave,

We did some more testing with SmartThings and were able to integrate the sensor to the hub by selecting the Aeon Labs MultiSensor 6 from the list when adding the device. In other words, if you add it as a generic device, it will not be recognized correctly. But if you choose MultiSensor 6 from the list, the app will display an error that it’s not an Aeotec device (different brand) but all 4 values should display correctly. Let us know if that helped!


(Udit Batra) #7

Anyone else try this? Is it a good alternative to the Aeon Labs Multisensor 6?


(Robert Vandervoort) #8

Hey guys. Code is done (in my opinion) for the zooZ sensor. Grab it off my repo here: https://raw.githubusercontent.com/robertvandervoort/SmartThings/master/zooZ-4-in-1-Sensor-ZSE40/device_type-zooZ-4-in-1-Sensor-ZSE40_v1.0%20motion%20primary

Sorry I’m a bit late in posting, I had it working last Friday but there were some bugs due to null parameters in the notification events sent by the motion sensor that took a while for me to work out. It’s working flawless now with all relevant configuration parameters in there in the preferences section.

Only known issues are the offsets are not apparently doing anything that I can see, though the device does set them… The instructions are in the top bit of the code. Pairing is the same as the Aeotec sensor, but I changed the way configuration is handled. for one, there is no usb power option… it’s only battery so config can be tricky. I alleviated that, so all you need to do is set the preferences and hit done, then just leave the sensor by the hub for about 20 minutes or so and everything takes care of itself. If you’re impatient like me, just set prefs, hit done, stand by the hub and poke the little action button once and you see the yellow light blink… then it takes about 20 seconds or so and all config parameters get sent and the sensor gets polled for new values and you’re set.

I see the Aeon multi 6 code from SmartThings improved a hell of a lot since last I looked at it. But while it works, more or less, isn’t without flaws on this particular sensor…

Give it a whack, and let me know any feedback folks.

Cheers

Rob out


(Robert Vandervoort) #9

oh yeah also, the device handler I wrote has the correct fingerprint, so once you add the handler, and you add the sensor it gets recognized from the get go… not futsing around changing types…


(Robert Vandervoort) #10

ok, quick update. there is some funkiness apparently with using && in comparisons for incoming values… going to ping ST about it, but in the meantime I just put up v 1.1 which fixes the exception handling around notification command class for motion and for tampering (cover removal).

here’s the one with motion as primary tile
https://raw.githubusercontent.com/robertvandervoort/SmartThings/master/zooZ-4-in-1-Sensor-ZSE40/device_type-zooZ-4-in-1-Sensor-ZSE40_v1.1_motion_primary

and the one with temp as primary tile.
https://raw.githubusercontent.com/robertvandervoort/SmartThings/master/zooZ-4-in-1-Sensor-ZSE40/device_type-zooZ-4-in-1-Sensor-ZSE40_v1.1

I also removed the decoration from humidity and light sensor tiles… I think it looks better. Also removed requirements for preferences that already had their default values set but gave Android users an error if you didn’t set them again (ANNOYING!!!)

Tested on Android and iOS.


(Robert Vandervoort) #11

Device handlers for their siren, ZSE-01 and motion sensor ZSE-02 is now up on my github repository. It’s the initial push but everything seems to work right. Waiting on @TheSmartestHouse to send me the engineering spec sheets so I can get all the preferences coded in.

For the motion sensor, there is a button on the bottom that disables the sensor and sets the tamper state on. With my motion sensor device handler you will see motion and tamper go on. When you press the button again the tamper goes green and the motion sensor is active again.

The siren type works as you would expect. I have it setup as a siren and as a switch so you can use it with different kinds of smart apps.


(John DiCapua) #12

Thanks so much for creating this code!

I am having some problems with mine in particular.

Mine seems to show Motion all the time and the Tamper tile is lit up

Anything I am doing wrong?


(Robert Vandervoort) #13

The forum topic is a little confusing here so I want to be sure we are talking about the same device…

The motion sensor ZSE-02, round puck with black ring…

The 4 in 1 sensor… ZSE-40 squarish with bubble in the center…

If it is the motion sensor, ZSE-02, what you’re seeing in particular is because the button is depressed on the motion sensor. Unclick it to renable it. it will make tamper go green and motion detection start (and clear again).

I just uploaded v1.1 which fixes an unrelated issue but also some typos and cleans a bunch of stuff up including the text around tamper which has been cleared up by zooZ. You’ll want to switch it out for the new type. Tamper is really ENABLE / DISABLE the sensor…

Also curious to hear how your batteries hold up…


(John DiCapua) #14

I fixed the ZSE-40 which was what I was talking about. I just had to Exclude it and Include it again and it worked after I adjusted the PIR sensitivity and reset time.

Can I get a link to the ZSE-02 code? I have it setup as a Generic Z-Wave Motion Sensor right now and it sucks I really need to be able to adjust the sensitivity.


(Robert Vandervoort) #15

ZSE-02 code is here https://github.com/robertvandervoort/SmartThings/blob/master/zooZ-Motion-Sensor-ZSE02/device_type-zooZ-Motion-Sensor-ZSE02_v1.1

There are no sensitivity adjustments. In fact there are no configuration parameters at all. The only thing you can really set is association and association group, say if you wanted it to fire at other devices directly like a scene controller. SmartThings doesn’t really support that but it’s part of ZWave standards and it probably works fine. These can also be paired with alarm panels too so that may be useful.

-R


(Raoul Banks) #16

Bob,

The screen looks great, but there are no values, except for the centerpiece temperature tile, which reads O, and 0% RH. Missing Something? Raoul Banks


(Robert Vandervoort) #17

If you hit the action button in the little hole (the one by itself to the side of the 4) it should send all the sensor values again… If you paired it near the hub, then hit the action button again near the hub you should have gotten values. If you paired then moved it away somewhere else, it may potentially be out of range. Try flipping the “debug logging” option in the device’s preferences and watching the live logging screen in the IDE… if nothing is coming across, then communications aren’t going on…


(Raoul Banks) #18

Well, patience is a virtue. Shortly after my last query, everything updated…automatically. I like the Zooz so much I bought two more. The reset button still does nothing, but everything else is perfect!

Thanks for your guidance, Raoul Banks


(Shawn) #19

Hello Everyone and thanks @Robert_Vandervoort for your work! Let me know where i can kick you some (0.1) bitcoins hehe. Wish had more.

So my new Zooz device is not being detected and the problem I think, is there is something crazy going on with my account. First i logon to the IDE site below.

https://graph.api.smartthings.com/

At this screen I can add a device handler. OAuth shows TRUE only immediately after saving and publishing the code. After that when clicking on Device Handlers – OAuth field is blank. Not sure if thats a problem.

Ok so whats nutso – is if i click on Devices or Hubs, none of my devices are listed.

Then i click on Locations and am prompted for another logon page

https://graph-na02-useast1.api.smartthings.com/login/auth

After logging onto this Location then i had to reimport the ZOOZ Device Handler. Seems like there are two accounts on Smartthings maybe on different servers?

Thank you and any help is appreciated,
Shan


(Robert Vandervoort) #20

Yeah that’s weird. I would get in touch with support. When you set up your SmartThings hub and tied it to your account, that is the login you have to use for the IDE. The device handler isn’t using OAUTH but I’m not sure what the field would say without logging in to look at it. … You should see your location and hub and devices. Since you aren’t something is up.