Strange (minor) Issue with Zooz ZSE40 4-in-1 Sensor

I have several of these in different locations (separate, identical V3 hubs). They are all identical and all use the same Zooz driver and they work fine.
Even though history shows no motion for a long time in the past, one of them retains the little red motion indicators on the tile.
Not really a problem, but certainly odd behavior. Anyone else see this?

Hmm… With a little poking around in the API Browser+, I see that the last motion event it reported was “Active”(a day ago). Apparently it never reported back an “Inactive” status… Strange…

What model sensor? Model numbers are important.

Which driver? The official Zooz Multisensor driver?

If you trigger motion on the sensor in question, and then let it go back to no motion, will the status of the tile update?

Yeah. ZSE40 VER 2.0.
Standard (official) Zooz Multisensor driver.
Don’t know about triggering it; right now it’s about 1000 miles away from where I am… (But that was going to be my next test when I get back there!)


Few possibilities:

  • The “no motion” message was lost. If for some reason that message didn’t make it, theres nothing but the simple retry that Zwave has to try and get it there. Theres no application retry or “refresh the state every XX minutes/hours” if no further activity occured.
  • The hub may have been power cycled between the motion and no motion events. Same as above, the lack of the hub being up would likely result in the lost message. There were some updates performed this/last week of the firmware so it may have aligned with that.
  • Low battery. Even though a device may report a good battery we’ve often seen that messages will be dropped due to it being low.

SmartThings will put out a “this device is offline” in the case of the device not checking in on its expected WAKEUP period, plus some amount of time. The default WAKEUP for the ZSE40 is 12 hours, so if there was no other activity then it wouldn’t complain about it being offline for a period of time after that.

If messages are being received about the other attributes (temp, humidity, lux, etc) then a low battery or offline condition isn’t likely.

Let me know once you are able to test the sensor and maybe we can troubleshoot it more.


ST is getting temp, humidity, and lux reports as expected.
Probably just a dropped message.
It’s certainly not a big deal - just something I’d never seen before!
Thanks for your response - it’s pretty much what I was thinking…

Interesting! Thanks for mentioning this, @art_333. I’m experiencing the same issue: two ZSE40 devices, powered with a voltage regulator fed by a typical USB charger block, both have showed ‘motion’ when there wasn’t anyone home, and both were switched from the Zooz driver to the more generic SmartThings default driver–which made the false motion event go away. Switching back to the official Zooz driver immediately set the status back to ‘motion.’

A subsequent power outage at the house made the condition go away and I’m back on the official Zooz driver. Like you, @art_333, I’m away from home and can’t troubleshoot further at this time.

Historically (and this may interest you, @csstup) I’ve seen this with other devices over time: an Aeotec Multisensor 6 and two contact sensors (one an older GoControl, the other an Ecolink Z-Wave+ device). These occurrences were observed over years, literally, and happened back in the Groovy days. I’ve always suspected the SmartThings Z-Wave implementation itself–not the specific drivers.

Years ago, as an experiment describe here, I forced a sleepy contact sensor on a door 1500 miles away to report it’s open/closed status the next time it woke to report battery level. The door was closed–not open, as SmartThings was reporting!

Later in the same thread, I recount the Multisensor 6 incident–with the same result.

Perhaps the same thing is happening today! It would be interesting if, perhaps when updating device settings, that the driver request the current state as well as writing the device settings to the device. Then one could tweak a setting and sit back and wait for the device to call the mother ship. That would speak volumes… :wink:

The Zwave Sensor CS driver will do something similar. On WAKEUP, if the hub thinks the device is currently showing motion as triggered, it will request its current status. It supports the ZSE40 if you’d like to try it.

1 Like

So I switched both sensors up North from the default SmartThings driver to the Zooz driver: each immediately showed ‘Motion.’
Then switched to your CS driver: both sensors show ‘No Motion.’

The History for each sensor shows the ‘Motion’ and ‘No Motion’ events mentioned above. Maybe that’s a clue, I don’t know. If my premise that there was a missed ‘No Motion’ event when the Zooz driver was the active driver, I’m puzzled why it thinks there’s motion now. Shouldn’t any knowledge of the device’s prior state be cleared when the driver instance initializes after being selected? :thinking:

Huge plus for the official Zooz drivers is the display of the device’s firmware version! It is invaluable when surveying one’s devices when preparing to apply firmware updates.

Side note: I tried to convince Aeotec to add this for their official drivers for the Multisensor 6 & got no traction. One could hope other vendors–and SmartThings, themselves–would display this information when available!

Think I’ll leave the ZSE40s on the CS driver for now and see how it goes! Appreciate your suggestion, Corey. We’ll be back up at that house in eight days, so will be able to run more experiments then.

1 Like

Well - looks like it was just a dropped “inactive” message.
As soon as motion was triggered, it began reporting correctly again!
(Somehow it just didn’t occur to me that a single message could be dropped!)

1 Like

9 posts were split to a new topic: Zwave details: S2 and Supervision Discussion

Will this nonsense ever stop? who cares about matter, thread border s2 .
will it ever work as used to?
when Kevin’s handlers will be implemented?
These edge devs must have some mental issues, announcing new icon or BS map view as breakthrough feature?

Fair enough, I have moved the detailed S2 discussion to its own topic.

The main point here is that the ZSE40 does support S2 authenticated security, so if you have it paired that way it should theoretically be less likely to lose occasional status reports.

For details on the protocol and why that might be true, see:

Zwave details: S2 and Supervision Discussion

(Note, though, that if you do use it with S2 security, then you will not be able to use it in direct zwave association with something using a lower level of security. So there are reasons to do it both ways, it just depends on your specific needs.)

Otherwise, carry on. :thinking:

In all fairness, the “Edge devs” you speak of may be divided into two categories:

  1. volunteer coders from the SmartThings Community and
  2. Samsung employees tasked with implementing a roadmap, probably drawn up by marketing folks.

To those in the first group: a hearty “Thank you!” for your contributions to the community. There have been many extraordinary contributions that are a clear value-add to many of us here who enjoy the camaraderie of the SmartThings forum.

Those in the second group are doing what their managers are instructing them to do. I’m not crazy about what you refer to as the “BS map view” either, but if you take the time to search the forum you will find many users here are excited about it. New icons fall into the same category. How long would you last in a job if you didn’t carry out your assignments?

The strategy Samsung has for the SmartThings brand is proprietary–unless and when they choose to make announcements. All of us users must make up our own mind if this platform serves our needs: that’s free enterprise at work.

While I appreciate your frustration, keep in mind those who volunteer here on the forum to release Edge drivers are doing us a wonderful service.

Submitted with respect… :slightly_smiling_face: