ZigBee Devices dropping offline recently (October 2019)

Is anyone have problem with “Zigbee” devices dropping of your Smartthings Devices in the past 2 months?

I have a device that works great all day, and each new day when I try to use it, it doesn’t work until I add it back to the system.

I had no problems until 2 months ago.

Which hub do you have?
What is the zigbee device that is falling off?
And just want to check - do you have multiple zigbee devices falling off or just that one device?

1 Like

It’s the New V3 WiFi Hub. v27.9

I only have 2 ZigBee Devices, that I know of.

Orbit Hose Valve-27087, using a grithub DH by imnotbob.

Both units worked wonderful until 2 months ago, not sure but in about the time you were doing platform modifications.

Hi Rick, I’ve heard that Zigbee has frequency collapse. Check out this post

Hi @RickK,

If those devices are outside, and at a fair distance from the hub, you more than likely are experiencing range and/or interference issues with WiFi.

Rejoining those devices may help, but you’re going to want to add a repeater, like a zigbee wall plug (Ikea, GE, and others are talked about in the Community).

Did you change your WiFi router lately? Did you move it or the ST hub around lately? As odd as it sounds, did a close by neighbor add a wifi router?

The article the other member posted shouldn’t concern you, but I would look into what changed that you can control, or add a repeater to your zigbee mesh.

Oh, BTW, you should probably remove all your personal contact information you posted above, as well as stripping it out of any of your email replies that add that info from your signature block when you post replies.

2 Likes

Sorry, “frequency collapse”? I wrote the post that you linked to, and that’s not a term that I would use for what that post describes.

The term is usually used in The context of utility company power generation. There can be a zigbee component if there is a smart grid involved, But zigbee is not contributing to the problem, which refers to the generating output.

And it wouldn’t have anything to do with the kind of Zigbee mesh required for home Automation.

If there was a reference in one of the links from that post, it’s there because of the discussion of smart meters and the utility grid but that wouldn’t have anything to do with an individual home automation device going off-line.

2 Likes

Thank you for clearing that idea I got @JDRoberts

2 Likes

John,

I did some trouble shooting and found a problem with Smartthings.

Please contact me. (717) 321-6566

Rick

UPDATE:

I have noted all your suggestions.

  1. My Router and WiFi Switch is only 5GHz. 2.4GHz, and is over 2 years only now.
  2. I checked with my closest neighbor, which over 1,000’ from me, and they have not updated the WiFi in over 2 years.
  3. Other ZigBee Devices, purchases from Smartthings are working perfectly, and are repeaters, one of which is within 10’ of the Orbit ZigBee Hose Timer.

TROUBLE SHOOTING:

  1. I brought in the Orbit Hose Timer, and put it near the V3 Smartthings Hub.
  2. I removed, what appears to be a Ghost image, of the Pairing of the Device. Note: I showed both in Smartthings App and the IDE, but doesn’t work.
  3. I rebooted the Smartthings Hub
  4. Since this Device is a Generic ZigBee Device, It required a Device Handler to be added to added to the IDE. I checked the IDE and the DH was still there, so did a update on the DH.
  5. Using the OLD Smartthings App, I Added the Device to the Smartthings System.
  6. I renamed the Device, and Saved the update.
  7. Looking in the IDE, it shows the New Device Name.
  8. Using the OLD Smartthings App, I can control the device, and it works perfectly.

HOWEVER:

  1. If you launch the NEW Smartthings App, you will see the New Device that you added, at the bottom since it is not assigned to a Room.
  2. The New Device in the NEW Smartthings App still shows the Original Device Name when it Paired.

HERE IS WHERE I FOUND A PROBLEM:

  1. If you move it to the proper Room, using the NEW Smartthings App, the Device will function ONCE, then never again.
  2. OR… If you rename it to the actual Device Name I wanted, using the NEW Smartthings App, the Device will function ONCE, then never again.
  3. The reason it stopped working every night, and getting it working each day was the fact I was using amn Automation in the NEW Smartthings App to turn on and off the Device. The Device will functioned ONCE, then never again.
  4. If you DO NOT TOUCH the Device in the NEW Smartthing App, and only use the OLD App, the device works perfectly, as a manual triggered Device. Leaving a small problem with Triggering it Automatically on a schedule.

QUESTION:

  1. Something changed in the NEW Smartthings App or Data base in the past 2 months that caused this, as it work perfectly in the NEW App prior to this time.
  2. So what was missed with the latest 2 updates ?

Hubitat user here, I just came over to this forum due to a disconnect issues I am having with a similar device (I have the Orbit 12 station sprinkler timer(s) ). Anyhow, both Orbit devices use a similar DTH and I wanted to post my observations should it help lead to the cause of the issues with them.

From countless hours of troubleshooting, I have discovered, both of my orbit devices work flawlessly but only when connected DIRECTLY to the hub.

The orbits will also initially work when connected to the hub through a repeating device; however, in this scenario they will no longer accept commands if the hub is rebooted either for a firmware upgrade or just a general hub reboot. If I power cycle the Orbits they will function normally again until the next hub reboot.

Long story short, there is something wonky with the Orbits, where being connected through a repeater corrupts the route if the hub is rebooted. A power cycle of the Orbit will re-establish the connection.

Not 100% sure if it is the same with the Orbit hose timer, but it also very well may be part of the problem you are experiencing. Hope this helps and maybe sets a light bulb off in someones head for a cause and cure!

1 Like

Very good info, thanks for sharing. I’ve experienced the same behavior with SmartenIT devices (also Zigbee, but log gone due to this problem).

Yes, I agree.

If I bring in the Orbit Hose Timers, sit them next to the Smartthings Hub, and add them back to the Hub, they seem to work fine, using the OLD app.

If I add them back from outside the house, they only work 1 time.

This all started for me 2 to 3 months ago. Before that they work perfectly.

Have you tried removing the batteries for a minute to see if it will reconnect? Just curious, as if I power cycle my sprinkler timers they hook back up?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.