ZEN AUTO Mode Disabled in Smart Things Help Needed


#1

Is the “Auto” Function in Smart Things disabled and a special config code needed to enable it?

I can’t seem to get the “A” to light up on my ZEN when I put it in Auto Mode and someone mentioned to me that the Auto Mode is disabled and a special config code needed to enable it.

Thanks in advance for any and all help!


(Bruce) #2

I didn’t know that Zen had an Auto mode. Are you sure? I can’t get mine to do that through it’s own UI.


#3

Mine has an Auto Mode… If you scroll through the Modes it appears and then you can Click on it.
I assume it is working but I don’t see an “A” Light On. The Manual shows an “A” Icon listed along with the Fan, On, Cool, and Heat Icons.

I am a bit confused about why the “A” is not showing up on the Thermostat.


(Nufegiyq) #4

auto mode is not setup by default. you can enable it by following the installation tutorial on the zen website. advanced options are at the bottom of the page when you finish the installation tutorial. having said all that, i don’t think the smartthings app supports the feature.


(Bruce) #5

Unfortunately, the device handler for the Zen Thermostat does not support mode Auto. I’ve been messing with the device handler to see if I can get it to work, but so far without luck.

Once I enabled Auto mode per the instructions, I can put the thermostat into Auto manually with the thermostat. But setting it to auto with a command does not work. I will continue to mess around, but lacking documentation makes it tough.


(Bruce) #6

Spoke too soon. I got it to work. I figured out how to modify the device handler to support Auto mode.

So, if you first follow the instructions to enable Auto mode, then use the device handler below instead of the standard one. Then, Rule Machine can set mode to Auto, set the setpoints, etc. @Journeyjoe


(Nufegiyq) #7

Ooo…this looks awesome! I haven’t dived into rule machine yet but I’m def going to give this a whirl! Thank you so very much!


(Nufegiyq) #8

Is it just me or does it say HEAT when it should say COOL? I see the blue icon but it says HEAT with the little flame icon.


(Bruce) #9

Maybe I should remove the little tile in the lower left corner. That’s supposed to be Operating State. The one in the upper right is mode. I think the tiles on the device don’t work quite right. There appear to be timing issues, where the thermostat can’t keep up if you change things too quickly. Interestingly, the Recently log appears to be correct.


(Nufegiyq) #10

personally, I really like being able to see the operating state. i notice the lag issues too, it drives rives me a little bonkers. does your zen take an unreasonable amount of time to turn on your a/c? mine takes at least five to ten minutes, no exaggeration.