Z-Wave Switches Mirror Each Other?

Installed the driver, but I can’t figure out how to add the switches to association groups?

First, you need to have each of the switches using that driver. Go to the device in the ST app, click on the three dots and select the Driver option. If the device is not using that driver, you need to change it. If the Driver menu item is not there, the device is still using a DTH driver and you will need to exclude the device and re-add it.

Next, you need to know the device ID of the other switch that you want to mirror the behavior. There are two ways you can find that. 1) use the SmartThings CLI found here GitHub - SmartThingsCommunity/smartthings-cli: Command-line Interface for the SmartThings APIs. or 2) using @TAustin API Browser SmartThings API Browser+ ... Looking for Testers

Once you have the Device ID of the device that will mirror, go to the device that will be mirrored in the ST app, click on the three dots, and select Settings. Scroll to the bottom and you will find the Association Group 2 (and 3). Put the device ID into Group 2 and that will cause the mirror behavior on that device ID.

1 Like

Thank you!! I have the driver installed on those 2 switches now and it actually stopped them from going haywire using routines/SmartThings, but still going to go the Association Groups route. Also installing them on all the rest of my switches too. This solves a problem I had a while back about enabling double tap.

1 Like

Yes, no sense in burning some of your Routine limit since you can use the Association Group(s).

Are there any other drivers that support setting Z-wave association groups?

I am not personally aware of any as I only use the GE/Jasco switches and outlets. There is a list of Edge drivers here Table of Edge Drivers - Things That Are Smart Wiki and you can explore those drivers to see if they support Association Groups.

1 Like

The Device ID that is 22 characters separated by dashes? I put Device 1 into Association Group 2 of Device 2 and vice versa, but it doesn’t seem to be working.

No, sorry, my bad. I meant the Network ID. From the CLI, it would look like this:

Device Integration Info (from zwave)
──────────────────────────────────────────────────────────────
Network Id 61
Driver Id 5ad2cc83-5503-4040-a98b-b0fc9931b9fe
Executing Locally true
Hub Id 2ca01359-7f67-469e-9887-172e72b0423f
Network Security Level ZWAVE_S2_AUTHENTICATED
Provisioning State PROVISIONED

CLI seems pretty complicated, might be easier with the routine routes then?

You only use the CLI to find the network ID so you put it in the Association Group for the switch. You can download a pre-compiled version of the CLI for every major operating system. If that seems like too much work, then sign up for the API browser which is a web page where you can find the same info.

1 Like

Turns out, I’m an idiot and Device ID is shown by that browser, literally lines away from Network ID. :man_facepalming:

Thanks!

Edit: Works great now!!

1 Like

Glad you got it working :+1:

Hi @HalD

If your device support group association then You can use Z-Wave Device Config Mc driver to get and set association devices.

  • Perform a driver change in app
  • Get the gourp association supported
  • Check You device manual to see wath commands (on/off or level…) send each association group number
  • Perform association Config
  • Without return to original driver You can Test if is working with press on or off in device
2 Likes