Z-Wave Repair Status?

When I innate a z-wave repair command and click on the link to view the status of the repair I’m brought to a empty log screen. Eventually if I sit there a event pops up telling me the repair was finished. Does these mean that the network is fine and there were no failures? Is there a way to view more details about each device?

@Urman, do know answer to this question?

My own experience is you get more information from the general logs. In fact, when you reach a certain amount of Z-Wave devices (I have ~90) nothing shows up with the “Z-Wave network repair initiated - Click to view progress” link.

The Z-Wave repair traces start with “cp desc” i.e. :

cp desc: Z-Wave network repair started

For some reason mine show up in each Sonos Connect device. I saw another user post indicate the same. Other than the start and finish you won’t see any other trace unless there is a problem.

However, just because you don’t see an error, don’t assume it was successful. I first realized this when I had the power off a z-wave device. The log did not indicate an issue with this device when it should have.

7 PM: trace cp desc: Network repair for Kitchen Multisensor [5E]: Did not finish updating mesh info

If your repair takes a long time you may have to click the logs link again because they eventually time out.

There are additional raw traces because support turned them on my account (by accident?) but since turned them off.

you could try turning on z-wave debug mode, but otherwise if the node isn’t being re-assigned a new route or a device isn’t responding nothing will come into the logs.

1 Like

And you turn it on how?

This option isn’t available to us mortals.

I know what you are talking about because it was turned on in the IDE Utilities page for my account. However I made the mistake asking about it and support turned it off. Seems it isn’t ready for prime time yet.


Ya sorry guys, it’s an internal debugging tool right now. Although i don’t see why it shouldn’t be available to all users.

Since last hub upgrade it appears behave differently. Now I never get a “finished” message.

1 Like

I haven’t consistently received a finished message for months. I believe it depends on the number of Z-Wave devices. Otherwise, it could be the known logging issue where messages get dropped under heavy load.

Support knows about the flakiness of Z-Wave repair but for now only address it if there is a device with an issue. For me however with nearly 100 devices, I don’t see a device issue right away.

The debug messages would be nice but sifting through them is not practical. What would be better is the Z-Wave mesh table.

1 Like

If the Z-Wave repair status never gives a “Finished” message, how long should I let it run for? I only have 5 Zwave devices. It appears to be running now, at least the little clock is spinning. Earlier I could see it refresh every 30 seconds or so but not now.

To the left of the screen above you see:

Now if you slide ALL the way to the right you should see:


I’ve seen a repair take 40 minutes. The logs stop after 30 minutes so in this case you won’t see the finish. I recommend trying again after an hour. Keep trying until you get a finish. Sometimes a hub reboot solves the issue.

I don’t know SmartThings support official recommendations, just my observations.

Good article on Wireless range and Repeaters:

Z-Wave repair has become broken to some extent by the recent upgrade, at least that’s my experience. If you see the little clock spinning you won’t get any more information on that screen – ever. If you look at the logs, you can find the z-wave network repair messages that used to show up, but now don’t. I was trying a repair an hour ago after adding a device, and searching through the log revealed that the z-wave network repair was cancelled, which I’ve never seen before. The page it sends you to observe the status of the repair is broken, the logs are not.

Then I made a big mistake: I started a second z-wave network repair, and didn’t notice that my wife had come back in from doing some gardening. Her closet lights didn’t turn on when she walked in. Bad boy! I got chewed on a little about the general state of things with ST being up and down and having problems. Real world. Her comment, “yea, well I live in this house.” My wife is a very tolerant person. ST: Help!! Fix it…

My FortrezZ Siren arrived today, after getting it included in my network I moved it into position. I then ran a Zwave Repair, any idea why it says “Failed to update mesh info”? Fix?

@Dave I recommend running the repair again. Most likely it will disappear in the next repair.

Try #3 worked.

Anyone have any thoughts on the current (early April, 2015) status of Z-Wave repair? Mine not only doesn’t complete, but it always wraps up with a Z-Wave failure/restart similar to this:

  • Err 101: ZW module not responding
  • Z-Wave power cycle started
  • Z-Wave starting up
  • Z-Wave is ready
  • zw network:DD2E896A, node:01, suc:01

It appears the above always happens ~5 minutes after the repair is triggered. Has been doing this consistently since I “got back into SmartThings” a couple of weeks ago after a 6 month period or so without. I essentially started over by deleting all Devices from ide.smartthings.com, walked around to each switch and told it to factory reset, and then re-associated them all to SmartThings. I have tried rebooting the SmartThings hub, the Z-wave switches (by throwing circuit breakers) – neither has changed the behavior I describe above.

Specific to Z-Wave in the environment, I have ~35 Leviton Z-Wave switches and 2 Leviton Z-Wave scene controllers that are AC-powered and are capable of acting as repeaters, as well as 1 Schlage Z-Wave deadbolt/lock and 6 Z-Wave open/closed sensors which are battery powered and will not act as repeaters.

The reason I’d like to do a repair is for mesh optimization – 2 of the sensors that are located the furthest from the SmartThings hub (which is centrally located) tend to not have their updates received by SmartThings. In that same part of the house, SmartThings’s perception of the switch status (on vs off) tends to get out of sync as well (even though the Leviton’s do provide feedback when changed, as opposed to the GE/Jascos I replaced). My experience with a previous DIY home automation controller taught me that after standing the house up I should run things through 3 Z-Wave repairs and things tend to work well for me at that point –

Thoughts? Insights? Suggestions for a third-party product that might allow me to trigger mesh optimization without needing SmartThings’ cooperation?


1 Like

Following up to myself (classy, huh?) it appears that Z-Wave is effectively dead the moment I hit “repair”. I tested this just now:

  • I flipped a Z-wave switch located ~5 feet away from the ST hub on/off three times to confirm that the switch was both working (yes) and responsive (yes),
  • I clicked “Repair Z-Wave network” under the ST hub’s utilities link on the ide.smartthings.com page,
  • I waited 5 seconds then tried to turn on the Z-Wave switch I successfully changed state on 6 times in a row; while the log infers that the ST hub thinks it requested the switch to turn on (“on command was sent to 1F Foyer Lighting”), it never did
  • No further messages indicating that the above request failed in any way,
  • After 5 minutes I got my usual (see previous post) Z-Wave error/restart cycle

With the previous DIY home automation controller I had in place it would be typical for Z-Wave commands to be slow or delayed during a Z-Wave optimization – but the commands wouldn’t be lost altogether.

Looking more closely at the “5 minute failure” condition, it looks to be “5 minutes, 5 seconds” fairly consistently.

Is there any way to increase the debugging associated with Z-Wave and/or this process?


1 Like

Another weird thing that happens to me during a repair is that it starts and finishes and shows that status on about 30-40 Zwave devices in 3-5 minutes. And get this I see the status of the repair in the ide live logging under All as well as SONOS CONNECT AND HUE CONNECT. How can that be. They have no relation whatsoever to zwave protocol.

The z-wave functionality of the hub is disabled during a z-wave network repair. So there won’t be any z-wave events (other than repair events) and none of the z-wave involved automations will work during the repair. Other automations will continue to function, just not anything z-wave.

As to your issue of the repair ending in an error. Try following these steps and see if anything improves:

Disconnect your ST hub from power for 15 minutes. This will allow your z-wave devices to discover that they have lost hub contact, and will want to reconnect.

Open a hub event log window. This is the same window that opens if you click on the log link that shows up in the IDE right after you begin a z-wave network repair. Clear the field in the upper right called Name Filter. Now you will see all hub events, which should include Ping every 5 minutes and any messages from the z-wave network repair, such as a device not responding. Bookmark this page, so you can open it before you start the repair (start the repair from a different tab), and see everything that goes on. Be sure to clear Name Filter to see all hub messages.

When the repair is done, wait for 15 minutes (hub still plugged in), and repeat the repair.

You may have to do this several times to get past the error you have in your network. There is another thing you can look at: using that same hub logging window, reboot the hub (from another open tab). You should see a sequence of hub events including, hub has disconnected, register, zwStatus, zwNwk. Click the left most column of the zwNwk event, and it will show you a list of the z-wave addresses in use in your network. You might want to see if that seems to be correct relative to your list of z-wave devices and their network addresses.

1 Like